Scaling issues on new iPhones[Solved]

Hey @roon_lover_007,

I moved your post over here – see the comments by Mike and Danny above,

Just bought an iPhone XS and the Roon remote is totally nonfunctional (it looks like the interface has scaled to the smallest resolution possible) - please tell me y’all are on top of it!

1 Like

Hey @anon52323635,

I’ve moved your post over to this thread tracking the issue. Please see the comments from Danny and Mike above — The team is currently working on this we will be sure to update you as soon as more news is available.


Same issue here on iPhone XS.
Please let me know if I can be of service in terms of diagnostics info etc.
Otherwise I’ll just follow this thread and wait with baited breath.

Thanks for working on this!

Following thread

xs, xs max, and xr will be fixed in the next build which is currently awaiting apple app store approval.


That’s excellent news. Thank you!

That was fast! Thanks.

The iOS Roon client is basically unusable on an iPhone Xs, as the search and menu hamburger are tucked in the corners outside the battery indicator and time, respectively. Hopefully the screenshot attachment worked…


I moved your post to this thread. Please read above.

Cheers, Greg


If please support the new iPhone XS Max, the interface on the iPhone XS Max is minuscule, at the moment is impossible tu use.


Hey @Ricardo_Ramos,

Almost there – see above! :slight_smile:

1 Like

Thanks Danny!!

Display is unusable! Needs a quick fix!!! Can’t read it or use functions


It was announced yesterday that an update has been pushed to the Apple App Store and will be available as soon as Apple blesses it.


Thank you!!!

Roon appears microscopicly small on iPhone XS. Compatibility issue needs fixing.


I have a iPhone X the roon remote app on my phone is running the iPad version. The fonts are really really tiny and it’s really hard to use. Is this a problem you are working on?

Got the new iPhone Xs Max with iOS 12. The Roon app is unusable in that the buttons are tiny and they don’t respond when pressed. I tried uninstalling and then reinstalling the app, with the same result. Is this a known issue? Previously I had the regular iPhone X and never had a problem. Any feedback is appreciated.

Wow, I searched before I posted but I never came across this thread. Thanks for the info!