Schiit Yggdrasil Gen 5 using exclusive mode [Resolved]

I cannot get Roon exclusive mode to work with my new Schiit Yggdrasil Get 5. When I turn on exclusive mode no sound occurs. When I turn off exclusive mode I get sound but everything is 44.1 :-(.

Roon Version 1.3 (Build 242) stable (64bit)
Roon Core MusicServer Verion 1.3 (Build 242) stable (64bit)

Mac Mini Server (Mid 2011) 2Ghz Core i7 4Gig ram
OS macOS Sierra (10.12.5)
Music is stored on one of the two HD on the MacMini
My collection is 3,800+ songs.

Replying to your own post is bad form but I have additional information. It turns out that when exclusive mode is turned on, it somehow sets the Audio MIDI setup for the device *Yggdrasil Gen 5) to be 32 bit. Manually setting the Yggdrasil to 2ch 24-bit Integer 192.0 kHz get sound working again. In my Roon device Playback settings I do have the Mac Sample Rate (PCM) set to Up to 192 and the Max Bits Per Sample (PCM) to 24 bits. It LOOKS like when put into exclusive mode, 32 bits it being set and the Yggdrasil seems to not like that.

Hello James.

I’ll reply to your post, but I’m not sure my form is any better since I don’t have an answer for you and am going to link to my thread in Audio Products.

I’m having trouble getting a Schiit Eitr (which also uses their Gen 5 USB tech) to work in exclusive mode with my mac. The Eitr doesn’t have manual controls for setting sample rate and bit depth, but per @Adam_Woodbridge’s suggestion I did that in Roon. However, while my settings in Roon called for a max bit depth of 24, Audio MIDI still showed 32 and I was unable to change the mac’s setting to anything else. There was some talk over at head-fi that the usb controller’s accepting a 32-bit device might cause this.

I don’t know if that helps you or not, but I’ll drop a notification for @support to see if they have any suggestions. If you have any, I’ll gladly take them.

Roon Ver. 1.3 (Build 242) stable (64bit)
macOS Sierra Ver. 10.12.6
Mac mini (Late 2014) 2.6 Ghz Intel Core i5 w/8 GB of 1600 MHz DDR3 RAM
Mac --USB–> Schiit Eitr USB/SPDIF Converter --Coax–> Schiit Modi Multibit

(Edit: Corrected link to head-fi)

Hello Jeffrey.

Thanks for your info. Your experience matches mine with the Yggdrasil Gen 5. It seems that for some reason when Roon is set to exclusive mode, it is changing the sample size to 32 which is not compatible with the Yggdrasil Gen 5.

I am VERY sorry to hear that the Eitr has the same problem. I suspected that it would be I am sorry that it has the problem.

I think I will solve this problem by purchasing a Sonore microRendu. I would have the following chain

Ethernet --> microRendu --> USB --> Eitr --> Yggdrasil.

From what I have at least read this should work. Keeping my fingers crossed.

Jim Murphy

Is not working atm.

Hi Jim.

Thanks for your update and the sentiments. I agree, our experience is similar and @miklats reports the same (thank you for that, miklats).

The support team is good and will do all they can (which hopefully will include finding a solution).

How did your experiment with the microRendu go?

EITR in exclusive mode is also not working for me. EITR is working fine with microrendu & ultrarendu (and sounding awesome).

Roon Ver. 1.3 (Build 242) stable (64bit)
Windows 10

I am VERY happy to hear that it is working with the microRendu. I have just ordered one and I am awaiting the resolution to my problem. On the other hand it seems that either Roon or Schiit have a bug that really should be addressed.

Jim Murphy

1 Like

Hi @James_Murphy ---- Thank you for the report and my apologies for the slow response.

Moving forward, may I very kindly ask you to reproduce the issue being reported, take a screenshot of the signal path leaving Roon when the error occurs, and note the time when the observations has been made.

After the above has been completed, please follow the instructions found here and upload us your Roon and RAATServer logs from the device hosting your core.


Dear Eric

Of course you are right. Being an old software developer, I should have done a bit more research and given you the data you will need in order to diagnose this issue. I will say beforehand, that Jeffrey post (Eitr USB-SPDIF Converter) outlines what I consider to be the issue. The new Schiit Gen 5 USB interface has issues with Roon for some reason. With that said, I will conduct the work you have requested.

My system is as follows:
Mac Mini Server (mid 2011) 2Ghz Intel Core i7 with 4Gb 1333 Mhz DDR3 RAM. The server has two internal hard drives. The OS and all of the software including the Roon server software are on one disk the second disk contains only music. I am running Roon version 1.3 (build 242) stable (64bit). The Core: Music Server is also running Roon version 1.3 (build 242) stable (64bit)

The audio chain will be done two different ways. First, I will have a direct USB connection to the Schiit Yggdrasil Gen 5. This was the configuration I had when I first made my posting. I have subsequently acquired a Schiit Eitr USB to Coax SPDIF box that also uses the new Schiit Gen 5 USB input. There is another topic in the Roon community pages for using the Eitr (Eitr USB-SPDIF Converter)

I have Roon working with the Yggdrasil but ONLY when exclusive mode is turned off. To give a complete picture, I will play a single song through the Yggdrasil with exclusive mode turned off and note the time so the logs when supplied will show when the playback worked. I will then engage the exclusive mode and try to play the same song with noting the time. This will fail.

At 11:31 AM I play a song through from Roon my my Apple Mac Pro Laptop to the Yggdrasil zone. The song finished at 11:34.

I then went in and change the exclusive mode on the Yggdrasil zone.

I then went played the same song In Roon at 11:38 AM. Roon tries to play the song and sits at 0:00 for a while then it stops playing.

On my server, the Audio Midi setting has changed to 32 bit.

The Schiit Gen 5 USB interface does NOT support 32 bit sample sizes only 24 bit.

I have added a bunch of screen shots to this posting but when I try to add the logs in zip format, it will not allow me to do so. How can I send you my zipped log files?

Jim Murphy

I will be changing the name of my zip files to be .zip.png so that hopefully the logs will load. That failed as well. I will need to be told how to send you log files.

Hi @James_Murphy ---- This is excellent feedback, your diligence and attention to detail is very appreciated!

I will be contacting you via PM momentarily to offer an alternate upload method for your logs :sunglasses:


Excellent! I have the logs ready to go when I get your instructions.

Jim Murphy

1 Like

@James_Murphy — Just making sure you’ve received my PM :wink: so your not left hanging.


I have uploaded the log files. I hope they help.

Jim Murphy

1 Like

Hi Eric.

I have been in contact with Schiit over this issue. They want me to send my Yggdrasil back to them. I told them that the nice people at Roon were looking at my logs and that I would wait until I had heard back from the Roon folks. I was also stalling because I ordered a Sonore microRedu and I got a tracking number this morning so I should be getting the microRedu soon. It is my understanding that Roon will work with the MicroRedu in exclusive mode with the Yggdrasil. I will know shortly. Please let me know what you find in the logs and I will pass it along to the folks at Schiit.

Jim Murphy

1 Like

Hi @James_Murphy ---- Thank you for the follow up and sharing the latest feedback from Schiit.

Confirming that the requested materials have been received and are in our queue to be evaluated by a member of our tech team. Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you. Your patience is very appreciated!


Hi Eric.

Thanks again for al of the efforts you and your team have done on my behalf. I wait with anticipation for your findings. When I do receive your findings, may I share them with Schiit? I have been working with them and so far their solution is to send in my Yggdrasil. I am loath to do so if the microRendu I will be receiving on Friday actually solves my issues.

Again, thanks for all of your help!
Jim Murphy


The new Roon update Roon version 1.3 (247) stable 64bit now works with exclusive mode on both the Schiit Eitr and the Schiit Yggdrasil! Everything is now working as desired and sounds AWESOME!

Thanks for all of your help and time following this issue.

Jim Murphy

1 Like

Hi Eric.

The latest Roon update Roon 1.3 Build 247 has fixed the problem! I an set exclusive mode on the Schiit Eitr and the Schiit Yggdrasil and all is working as desired and sounding AWESOME! Thanks for all of your time working on this issue.

Jim Murphy