Server "Initializing" after upgrade to 1.6



  • Roon Version 1.6 (Build 390)
  • Running on Synology DS1512+ with DSM 6.2.1-23824 Update 4
  • 2 x Squeezebox Touch + 1 x Squeezebox Receiver
  • Windows 10 and iOS clients


  • NAS wired (2 x 1Gb LACP) to NetGear GS108T switch
  • Switch wired (1 Gb) to ASUS RT-AC3200 running Merlin 384.6 firmware

After upgrading to version 1.6, the Server is mostly in “Initializing” state. Re-starting helps sometimes, but the client UI is very slow and connection goes back to “Initializing” after some time. This happens with both Windows and iOS clients. I had encountered the same problem in earlier versions, but re-starting the server once fixed it and the clients did connect reliably afterwards.

There have been no changes in NAS, network or client setup. It is really getting frustrating to not have a reliable server for streaming music.

Looking at the RoonServer logs on the NAS, I did notice one correlation between unsuccessful client connection attempt and the following traceback:

01/29 17:39:52 Info: [brokerserver] Client connected:
01/29 17:39:52 Trace: [SOOD] Adding User IP
01/29 17:39:55 Trace: SENT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=6b6b2fdd-5bc5-430e-8b57-e6009b8cce7b BrokerName='********' }
01/29 17:39:55 Trace: SENT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status='UpToDate' HasChangeLog=False CurrentVersion={ MachineValue=100600390 DisplayValue='1.6 (build 390) stable' Branch='stable' } }
01/29 17:39:55 Trace: [push] restarting connection (Unable to read data from the transport connection: interrupted.)
01/29 17:39:55 Trace: [push] retrying connection in 67997ms
01/29 17:39:57 Critical: scx: System.NullReferenceException: Object reference not set to an instance of an object
  at Sooloos.Broker.Music.LibraryApi.Sooloos.Broker.Api.Library.get_Playlists () [0x00000] in <dcbcf4f91fec401e800a83ba373c6044>:0 
  at Sooloos_Broker_Api_Library_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x0002c] in <288ef57a6dc74b17996de9c331282b59>:0 
  at Sooloos.Broker.Remoting.RemotingServer._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos.Broker.Remoting.RemotingServer.Sooloos.Broker.Remoting.IRemotingContext.PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x00000] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos_Broker_Api_Broker_Adapter.Serialize (System.Object obj, System.IO.Stream stream) [0x00227] in <288ef57a6dc74b17996de9c331282b59>:0 
  at Sooloos.Broker.Remoting.RemotingServer._PutObject (System.Object o, System.IO.Stream stream, System.Boolean inline) [0x0010b] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos.Broker.Remoting.RemotingServer+<>c__DisplayClass28_0.<OnGetService>b__0 (Base.Result`1[T] result) [0x0002b] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos.Broker.Distributed.ServerConnection.OnGetService (System.Guid guid, Base.ResultCallback`1[T] cb_result) [0x0001e] in <dcbcf4f91fec401e800a83ba373c6044>:0 
  at Sooloos.Broker.Remoting.RemotingServer.OnGetService (System.Int32 rid, System.Byte[] body) [0x0001f] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos.Broker.Remoting.RemotingServer+<>c__DisplayClass22_0.<OnRequestReceived>b__0 () [0x00011] in <56788e8bfcfa4a02b27f94e6455c3d92>:0 
  at Sooloos.SynchronizationContextThread+<>c__DisplayClass45_0.<Post>b__0 (System.Object _) [0x00000] in <7f0a74b68d2a4a0ba3084b62b8028591>:0 
  at Sooloos.SynchronizationContextThread._Dispatch (Sooloos.SynchronizationContextThread+SendOrPostWrapper& ret) [0x00012] in <7f0a74b68d2a4a0ba3084b62b8028591>:0

Hi @Rishabh_Parekh,

Apologies for the difficulties here. I’d like to enable diagnostics on your account so we can take a closer look at what you’re experiencing. Before enabling diagnostics I was hoping that you could do the following:

  • Reboot your networking hardware and Core machine.
  • After rebooting, the next time this behavior occurs (you notice the initializing state) make a note of the time and respond here with that timestamp, your timezone, and the remote device you are using.
  • When the first remote is in the initializing state please try the other remote and let us know if you are seeing the same thing there.

Once we have the above information I can enable diagnostics and will pass the diagnostics report along to the team for review.


Rebooting the router and switch did not help, but rebooting the NAS seems to have fixed the issue. Windows and iOS clients can connect. I will monitor for few days and update the thread if the problem occurs again.

1 Like


The issue happened again today:

  1. At 10:31 am Pacific time, trying to access via Windows client.
  2. At 10:43 am Pacific time, via iOS client.

I was able to recover by re-starting the core.

@dylan @support

The issue happened again today at 2:24 pm Pacific time (from both Windows and iOS clients). Can you please update on diagnostics? It is getting quite frustrating and tedious to reboot the server every day!!

Hi @Rishabh_Parekh,

Apologies for the delay and the continuing difficulties here.

I have enabled diagnostics on your account so that the technical team can review the report. The next time your Core is active the report will be uploaded to our servers.

While the team is reviewing, I’d like to propose a test:

In the past, we’ve seen this type of behavior tied networking difficulties stemming from switches, managed switches in particular. If you connect your NAS Core to the router directly instead of the switch does the same behavior occur?



It is not pysically possible to connect the NAS to the router because they are are in different rooms. As I mentioned in the first post, the network setup (software or hardware) has not changed recently and it worked fine (for the most part) prior to 1.6 upgrade.


FYI, issue occured again at 4:05 pm Pacific time while accessing from a Windows client.

Hi @Rishabh_Parekh,

I wanted to reach out because I’ve been keeping an eye on our servers, waiting for the aforementioned diagnostics report.

For some reason it is not reaching our servers, even after I tried re-enabling diagnostics on your account. I also ran a quick test and I was able to submit a similar report from my setup here, so something else is going on.

So we can move forward, I was hoping for now you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your Core machine.

Restart of the Synology fixed my instance of the issue.

After re-starting the NAS, Roon Core is holding up so far without any issues. Will upload the logs on next occurrence.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.