Server not starting on Synology


I just tried to install a server on my Syno DS 713+, which has latest DSM 6.1.1 update 2.
Everything goes well with packet center, except the server never starts…
I tried to start it with a terminal, the script tells errors and the other tells “failed” for alsa libraries.
I don’t see anything in the posts to help me, except that my DS is a little too short to install a server.

Also : I tried to install server manually with the package for linux, all goes well the server starts even if tells the same alsa libraries… But someone has written not to do like that because of the database created in a wrong place.

So if you have an idea, thanks.

What happens if you start the package by terminal?
To start it you can enter (via ssh):
sudo /var/packages/RoonServer/scripts/start-stop-status start

To stop it enter:
sudo /var/packages/RoonServer/scripts/start-stop-status stop

Please keep in mind, that there will be no interface for RoonServer on the Synology itself. You need to access the server remotely with the Roon software on a computer or smartphone/tablet.

EDIT: One Addition: RoonServer won’t launch, by manually executing the script (that is part of the Linux RoonServer package). There are some environmental variables that need to be set first. Without it an error is normal and expected. Also the script will give you that error for the same reason. The reason the scripts are there, is that the NAS installer use the Linux RoonServer download for x64-systems. The installation process of the NAS packages download it during its installation process, to ensure to have the latest version of RoonServer. By doing that, the and scripts are of course also on the harddrive, but to start/stop RoonServer a special script is called (see above).

I understand, but I just tried without success, same errors as before : see file for what happens.
No more server with Roon app on my mac than before (except when I start the package for linux, not the one installed with package center). I had to kill the script.
Any idea ? What did I wrong ?

I’ve just sent you a PM.

Sorry for the delay, I live in France, different time zone… And many thanks for your help, but it still does not work :

Here is the result of the first command :

And from the second :

Then I tried your new package, no more success from packet center nor with terminal start-stop-status script.

Nope, same timezone. I live in Germany (Berlin). :wink:

When you start the new package via command line (with the start-stop-status script), does it output the same errors as before?

The weird thing about the error on your Synology is, that the path of the files is messed up (in the screenshot of the console output).

How is your volume1 initialized? (SHR?)

The output of ifconfig seemed normal. Can you also run the following ifconfig command. It is the exact command that it executed by the start-stop-status script, which returned no value (The line “MTU:” in the screenshot).

ifconfig | grep eth[0-9] -A1 | grep MTU | cut -d ":" -f 2 | awk '{print $1}' | xargs | sed "s/ ---- /\n---- /g"

Please also paste the output of:
sudo cat /root/.profile

I just checked it’s the same errors with the same files not found.

Your ifconfig command returned nothing, here is the result of the second :

And my volume 1 is SHR.

Maybe the path is messed because of the path modified in the file /etc/profile, since I installed ipkg, screen and other stuff.
The line has been changed to : PATH=/opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin
Before DSM 6.1.1 (and maybe 6, I don’t remember) after upgrade I always changed this line, and the same in /root/…profile.
But now this line no longer exists in this last file. That you see with the capture above…

I’m not an expert, just tried to use my syno with little tricks, at a time to have a minecraft server the way I wanted it.
Thanks for your help.

I have an idea for a different approach: Can you check if Docker is available for your Synology model and install it? Within Docker you can create an additional (clean) instance of the DSM (DockerDSM).
This new instance will get its own IP address for the DiskStationManager and is isolated from your original DSM.

I’d prefer to test RoonServer in the Docker instance, to see if the same errors occur there, before we are making changes to your main DSM-system.

Sorry I don’t manage to make a DDSM work. Docker wants a btrfs volume I don’t have and don’t know how to create without any problem…

ok. it was worth a try. I am currently assuming something messes up the PATH when starting RoonServer. But I am not perfectly sure what it is. As I am currently in Munich, I will send you more info on Monday (as I want to cross-check with my device at home)…

I just typed again your last ifconfig command, it returned 1500 1500.
I think I did it the wrong way 3 days ago.

Hi @S_P
Sorry for the long pause. I was away in Munich.
OK. Here is what I would like you to try:

Stop RoonServer via ssh again by:
sudo /var/packages/RoonServer/scripts/start-stop-status stop

Then start it by entering:
sudo sh -x /var/packages/RoonServer/scripts/start-stop-status start

This will produce a lot of output in your shell!. Can you copy/paste this in a textile and send it to me?

Hi, sorry too I was not here for a week.
I sent you the file by mail.
Hope this will help !
Thanks again.

Ach by mail it doesn’t work, I should have known.
Here is what I sent you :
Here is the file with the output of the second command.
The first did not do anything the server was not launched.
Still no files in the RoonServer directory. I had to kill the process.
For me all this is sort of a chinese stuff…
_Thanks again.

Hi @S_P
Thanks, I will take a look later. Can’t open it with my smartphone, so I’ll look at home.
The command was not supposed to make it work. But it will give a full log of every line of the start script. I hope to be able to find be out where the launch process is failing on your machine (and hopefully also why). I already realised that some variable of a directory was mangled. The question i am trying to figure out is why and in which line of the code. The error was given by a script that has been delivered by the official RoonServer install…

I looked at your provided textile and so far everything seems fine in the QNAP launch script.
So, I’d like to go one step further and log everything that is done by the scripts from the official RoonServer package.

To do that, you need to edit 2 files by entering (both commands are just 1 line! The line break appears here due to the length of the command):

sudo sed -i -e 's/#!\/bin\/bash/#!\/bin\/bash -x/g' /var/packages/RoonServer/target/RoonServer/


sudo sed -i -e 's/#!\/bin\/bash/#!\/bin\/bash -x/g' /var/packages/RoonServer/target/RoonServer/Server/RoonServer

Now run the commands from my previous post again and send me the output.

EDIT: I modified this post. Now you can simply copy/paste the 2 lines to the ssh window.

Hi, here is the file with the result after these commands.
At the end of the file I added the result of what is in my /var/packages/Mono directory, since it seems to me to be a problem from the beginning.
The file :

Do you also have the Mono (SPK or ipkg) installed? If so, do you need it and can you uninstall it?

What output does
ls /var/Mono

I could reproduce this behaviour by creating a Mono directory in /var (Thanks @danny for pointing me to this!) and reported it.
The current version of RoonServer will launch successful if there is no Mono directory in /var or /var/packages/.

I installed the Synology Mono packet for my minecraft server, with mcmyadmin.
There is nothing for “ls /var/Mono” the folder does not exist.
I will uninstall the Mono packet, I hope my son and his cousin won’t ask for minecraft…
I keep you informed.