Server port for port forwarding [Solved: Port 55000]

What port on the server are we forwarding to?


Is this what you are looking for?
For the getting started post:
"Testing Port Forwarding

To use Roon ARC outside your home network, you’ll need port forwarding configured on your network so that Port 55000 forwards to your Roon Core."

Thanks, but my routing (unifi) requires that I specify both the external port (55000), and the port at the roon server (???) in order to establish a forwarding rule.

check this thread. there is s a screen shot of how someone set up their UXG, maybe it will help?

As I’ve been through this, I may be able to help @Akimo. Though I’m not the last word expert. All the ports in the port-forwading schema are 55000 for the first pass.

  • “Listening port” in your Roon application / Roon ARC/Mobile setting
  • Internal and External ports in your router’s settings

Hope this helps, and/or I’m abridged with better info by our more esteemed/knowledgeable tester colleagues. The above is what worked for me as I sequenced through my initial port-forwarding issues when I came on board a few weeks ago.

HERE is a long thread, showing the step by step with screen snips to my problem and solution components.

Thanks very much for the guidance.

I’ve added the rule, and will test it when I’ve got build 996 installed.

1 Like

Does this help?


I’m guessing that since Mike F. didn’t specify a server port in the instructions, Joshua_Nelson’s approach is probably what I needed.

I’ll post the results once I have 996 installed.

1 Like

Hi @Akimo,

Welcome to the testing forum. Please let us know the results of the manual port forward rule and I’ll be watching for your response.

I’m going to move this thread into the #arc-testing:port-forwarding-progress subsection, where we track issues related to getting the router and network setup for ARC. From there, solved issues will be moved to the #arc-testing:port-forwarding-solved section as a reference guide for other testers.

Thank you @Joshua_Nelson for jumping in with quick instructions.

1 Like

Welcome. @Akimo , this eventually worked for me…required that I update the ARC client to finally get things working.

Note: happens to be the static private IPv4 unicast address of my Alpha Core.



Thanks. I’m afraid I’m in the group that has not received the upgrade yet. I hope to post tomorrow with the results.

1 Like

Thanks for moving this thread to the right place. I’ll be sure to post the results.

I’m assuming then that those of us with more than one core will have to pick one core only to be testing with ARC, even tho all cores might eventually run the same ARC features

Thanks for that… done mine too now just need the server install in place. will be putting on my Nucleus initially

1 Like

I was able to manually configure port forwarding on my Unify UXG-Pro gateway/router and ARC is working now. I do not have nor want UPNP to be running in my house so was not going to turn that on and try auto config of this. Had a few problems as when I tried using 55000, Roon was reporting another app was using that port (even though nothing but Roon would have been using it). Resolved by picking a completely different pair of ports (40000) to set for external/internal and that worked.

However, had to set to allow TCP connections from my WAN & WAN2 from anything and I’m not particularly comfortable with that.

Is there a specific address I can set external Roon external TCP communication to come from so I can lock this down a bit more completely and safely?


Your guidance worked perfectly.

Setting the forwarding port and the server port both to “55000” made the connection work.

Thanks very much


Hey that’s great, @Akimo! I’m curious, did you toggle on, UPnP?

I did (turn on uPnP). Bit of an act of faith that Unifi’s uPnP secure mode is more secure than other approaches.

i took a look for my IP at whatismyip and it shows another IP than the IP shown in port forwarding in my router.
So i think my provider has shared IP adresses.
will contact my provider today