Server shows "initializing" - Android app can't connect

Having the same issue. Does the Android app get any priority with the Roon developers? There are problems with the Android tablet app screen tearing at the edges, performance issues with the tablet app and now connectivity problems with the Android phone app which I assume will start occurring with the tablet.

Buggy and frustrating for an expensive piece of software.

Nice to know I am not the only one getting tearing at the edges. I find just rebooting the device fixes the connection problems with core. Hardly ideal but I guess development for android is like windows to many hardware configs to deal with.

Frustrating, isn’t it? I have a Samsung S7 and an old Samsung tablet. Both will connect to the core with the Roon Android App - sometimes. I see no relationship between when they can and when they cannot connect. In fact, I purposely logged into the Roon core a couple hours before my dinner party last night - just to assure muself that all was well. It was - until the dinner party started when, as these folks are saying, the two devices (yes, both of them) failed to connect to the core. I had to keep going back to a hard-wired computer to control the Roon Server.

I am thinking of getting some new tablet or laptop which I will place closer to the “listening zone.” Must it be a hard-wired (ethernet) connection to a windows computer? At least I know that setup works.

Is there any development work taking place now on the Android app? Sure would be nice to be able to use these devices to control Roon…

That’s one of the reasons I put together a Pi3 with a 7" screen running RoPieee and put it next to my TV. it is hardwired and I can skip tracks pause etc. The android devices I have just don’t want to connect unless I restart the core.

Bob, I did that too, at your suggestion. Yes it does keep its connection (unless the Roon extension happens to stop for some unknown reason, which it just did for me). But you cannot select music or adjust volume - just skip tracks and see what’s playing.

Got a new Samsung Galaxy Tab A - still the same problem getting and keeping a connection to the server. Still hoping to use this tablet to control my music. But just when you want to impress someone… it cannot find the Roon server. Not just frustrating, but also maddening.

I have made a bookmark in the web browser on my tablet to the ROCK web manager and I find that just saving the settings makes it connect. I don’t have to change anything or restart. just hit save on the main page of the rock web page. It works better if you tell the remote to try to connect to a differnet core, though.

Sorry to hear your connection problems but fyi, here’s my setup with no problems, nor have have I ever have I ever experienced what you’re describing. Here’s my configuration:
RoonServer 1.0.2 on SSD hosted via QNAP NAS to LinkSys WRT1900AC router
Samsung S8 running Android 7.0 (had an S7 until July), wifi at 5 GHz
Samsung Tab S 8.4 running Android 6.0.1 (latest OS released for this product), wifi at 2.4 GHz
Roon build 269

I recently ran a test on another piece of hardware and left Roon running for 24 hours with hiccups.

[This reply is also for Bob]
I am running Roon Server on my Windows 2016 Server. It connects flawlessly with all of my computers (all ethernet hard-wired and running Windows 10). Are you guys saying that the problem could be with the OS on which Roon Server is running?

Neither of my Android devices will connect - phone and Pioneer DAP. My iPad works fine. Reading this thread seems a core reboot may have some impact, I will try that this evening.

When my core was on Win10 64 I had no problems. It is only when I went to ROCK on a NUC that I have issues with wireless remotes connecting to the core. Yes, I could go back to using my main computer as the core…but I wanted to not have to start it just to listen to music. …

Maybe a solution!!! (Seems to have worked for me/us …)

Hi everyone.
I only recently (4 weeks ago) joined the roon/rock fan community. I stumbled upon this thread when I experienced the same issue as discussed here. I run rock an a NUC i7, remote controls are two Windows 10 laptops, 4 android mobiles and one android tablet. I faced the same issues with the andoid devices (all of them!) trying to connect them to the core as are described here. All the devices showed that behaviour. We use Samsung phones with Android Versions 4.5 up to 6. The (noname) tablet runs on Nougat (Version 7) , I believe.

The problems seem to have stopped after a very simple change in the core settings: I enabled the wifi setting (which by default is disabled). I connected the core to all the three different wifi networks we run and left it set to one of it. The lan is still connected and enabled. Streaming still is viaLAN.
Result: For over a week now the problems stopped. All the devices are able to connect. Sometimes it takes about 15 sec but in the end the device will find the core and connect to it.
Testing I have done (to disturb the connection process on purpose) include switching on/off/rebooting in different sequences/successions. Everthing works.

Maybe this is unique case (because the solution seems so simple) and can not be transferred to everyone, but I thought I’d post the experience anyway. Maybe it works for the one or the other here and helps to get rid of that bug.

Cheers!

2 Likes

Great find, so far it is working for me. Like you said it does still take a few seconds to find the core but it works so far. Thanks!!

Where is this setting ? Can’t find it under my core’s settings…


and then


I’m curious Christian. Does it work for you?

Hi Hans,
Your ‘hack’ unfortunately does not apply to my situation - I am not using a ROCK device therefore I don’t have the same config screen and option as you do… But I hope this will help the Roon labs figure out what the root cause of the problem is.
FYI I run Roon on a QNAP device (which is Linux based).

Cheers

Same issue here, for months now. Running on Synology and managing with a Galaxy S7E running Android 7.0. When managing from my Win 10 Home laptop I never experience this issue.

Very frustrating; I will not renew my sub or convert to lifetime if Roon can’t figure this out.

I think I just solved this one… Go into your roon Audio settings from a remote PC or other device that’s working and enable your android devices under the networked section. As soon as I did that, my S7 connect screen went green and I was able to connect to my roon core again.
I hope this works for everyone else too…

Peter

2 Likes

I am having the same issue on my Samsung Galaxy Tab S2. It started since the last update of my rock and only restarting the tablet seems to solve it. The strange thing is that my oneplus 5t is running the same version but is working just fine.

Hopefully this will be resolved in a future update, because it is very annoying.