Set roon with volumio with raspberry pi 4

Core Machine (Operating system/System info/Roon build number)

build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Computer on wifi Rasberrypi on ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Hdmi usb for music

I have setup nanosound rasberry pi 4 with volumio one room and another nanosound in another room
and have joined roon so I can have music in both rooms, both are up running as rasberry pi should
but I cannot get the other one working as I really don’t now how to set it up and I need
help to do this

Thank you

Ian Segers


Roon doesn’t work with Volumio; you’ll need to install Roon Bridge on the Raspberry Pis. Take a look at Ropieee.

You can install the Roon plugin in Volumio. Install takes a while, have patience. Works great.


Hi Martin, thank you for letting me know that Roon doesn’t work with Volumio didn’t now that, and may have to have a look at install Roon Bridge and took a look at Ropieee will get back to you about that.

Ian Segers

Hi Joachim thank you for pointing this out, so I checked in plugin in Volumio and it was already installed, and in my volumio subscription under (activate my volumio on device , it hade my 2 nanosound ,raspberrypi cool, they both had green arrows so I could switch between both,
music came out of both, but had to play 1 song from 1 and a different song from the other, so my
question now is how can I play 1 song out of the both nanosound

Ian Segers

you can use the grouping function as shown here

Volumio is saying that they work on a multiroom feature, I am not sure when and how.
But when using the Roon bridge in Volumio you can use the grouping function in Roon. Just make sure that each Volumio installation is done from scratch for each Raspi, do not simply copy the image file across. Roon will not see two Volumios in that case.

Thank you for your reply, if this zone grouping function is in roon, at this moment my app the finds that is on my network ie one of my nanosound Device won’t pick me device up so until I get that sorted
probably be able to use roon , but thank you

it is good volumio is working on a multiroom feature, have my fingers cross it is soon ,if I can that roon
set which I am having problems with, and yes both raspberrys an new step not copies but Roon
cannot find volumio with new setup still working on that. thank you

You need to stop playing anything on the Raspi with Volumio, as this blocks the Roon bridge, otherwise Roon will not see them

okay I made sure that nothing was playing on the raspi and had another go, but once I checked the audio device setting, I did see my 2 raspi , once I enabled them then went to zones and the kitchen and lounge was there I picked a radio and music came out via kitchen raspi it worked, and I used the transfer zone option transfer it to lounge and worked as well cool, I even got the same same music through both zones which is real great, I have imported my usb music into roon ,lodged into TIDAL, so I take it I use roon to control the 2 rasbpi instead of Volumio

so all good, and thank you for your help with this topic

I have now got roon working find, and using the zone grouping so all good, thank you.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.