Set up issue - MyRepublic Singapore ISP

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

  1. Who is your internet service provider?
    MyRepublic (Singapore)

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?
    There’s an Alcatel Lucent G-240G-C router provided by the ISP, placed between the access point and the ASUS RT-AX92U.

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

Connected Audio Devices

Bluesound powernode 2i
Matrix Audio mini-i HP amp

All units are connected by ethernet, including the nucleus.

Description of Issue -

What is the exact port forwarding error message you see in the Roon Settings → ARC tab?


“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},

“external_ip”: {“actual_external_ip”:“103.kkk.lll.rrr”,“router_external_ip”:“null”},

“natpmp_autoconfig”: {“status”:“NotFound”},

“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="\” s:encodingStyle="\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}


Hi there,

I’ve tried using auto config but that didn’t work. There’s some security webcams attached so I wondered if that be the problem, or maybe the router provided by the ISP (I tried to log into this but couldn’t).

Here are the UPnP/NAT settings on the ASAU router:


Then I tried manual port forwarding. Here are the settings:

Port forwarding

This is Roon:

Would appreciate any assistance - thanks in advance!


Check if your ISP is using carrier grade NAT? - that’s caused a heap of issues for many people. Search the forum for “CG NAT” for more insights.

1 Like

Ah ok, thanks. Will look into this.

Hi @Simon_Calder,

I agree with @ElTel, i think your ISP has implement CG-NAT. See this site for an explanation

I suggest you contact your ISP and ask the following questions:

  • Have you implemented carrier-grade NAT for my account level?
  • Have you fully implemented IPv6, or do you have IPv4 addresses available?
  • Can I request a static IPv4 address to support port forwarding?
  • Are there any ports you have reserved at the ISP level I should be aware of?

Hope it helps.

Kind regards,


1 Like

Can you access the settings on this device? If this device is not in bridge / IP passthrough mode or similar, you may need to set a port forwarding rule from the Alcatel to your Asus Router.

(I have a similar setup - like many - where the ISP device sits before my own Asus router - it is locked from user access but on request it was switched to bridge mode by the ISP)

Port forwarding between the isp device and main router, or bridge mode, would not be a full solution in CGNAT situations. But it may be needed anyway, if UPnP is not in use or fails. The suggestions above from others would still make a lot of sense if CGNAT is in play. (Although an ip address starting with 103 is not in the range indicating carrier grade NAT, I believe? :thinking:)

Good luck!

1 Like

I think @ToneDeaf made a point there, an ip address with 103 isn’t CG-NAT. Sorry for the mis leading communication.

Kind regards,


1 Like

But ISPs could still do strange things …

EDIT - if Roon tries to show the actual address range assigned to your LAN under “router_external_ip” (not under “actual_external_ip”) this could still be CGNAT with a address range mapped (for multiple user connections) to a 103 range at the edge of the ISP network, and publicly visible. It would make some sense.

So it could be me who is misleading with that particular comment regarding the IP address shown in Arc diagnostics.

(I would normally expect an ip address to become visible in the Arc diagnostics under “router_external_ip” if/when NAT between the Asus and Alcatel device works, or with the Alcatel in bridge mode)


Your ISP (MyRepublic) is using CGNAT; this has been reported before in this forum. You will need to ask them to give you a public IP address for ARC to work. They will probably try and charge you for it.


Ok, many thanks for the various feedback guys. I also checked the chains here re: MyRepublic which were very helpful too.

Have spoken to the ISP and they will do a static IP for one-time fee of $50, and apparently they will also open port 1 of the Alcatel router. Will see how that goes.

I realise I don’t necessarily need a static IP, only a publicly visible one, but this seemed to be the path of least resistance.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.