Setting static ip on brinkmann nyquist mkii

How do I setup the ip on the audio renderer ?

check your renderer’s manual/website/etc… on the ROCK side, use the web ui.

I own a brinkmann nyquist mkii and i only gets ip through dhcp
how do i change its ip using rock web ui…I can set the ip on the second usb the ethernet device but how do i set a static ip on the brinkmann


You have to ask Brinkman. If they haven’t provided the facility for you to assign a fixed IP, it can’t be done. If they have, then it should be in the manual.

thank you for your reply
I didnt find any instruction in the manual…
do you know mconnect app ? maby i can change it using this app…i will try and update

I can’t say as I have never used that APP.

just did it using mconnect app

How? Could you show a screenshot?

I connected the brinkmann nyquist mkii to my vdsl router first and then i opened the mconnect control app from my ipad.
under device setup on the left upper corner there is an option to change the ip from dhcp to static.
when i did that the app required to restart the brinkmann so i turn it off then on and when i did that a the device had the new ip that i chose based on danny recommendation under the post ( but noticed that in order to be able to control it from roon remote i had to chose a gatway too in my case it is my vdsl router address


mconnect player lite or mconnect player?

mconnect control

1 Like
1 Like

it is important to mention that in order to use mconnect your device must have their module hardware

1 Like

And you know what devices have this module? At least some.

no i dont know…my manual refered me to this app and when i read about is the company said in their website that in order to use this app the company module (hardware) need to be implemented
my problem now is to get my dac to DHCP , unfortunately the app now can’t find the renderer and connect to it so that i can change the setup back from static ip to dhcp ip :frowning:

What static ip did you assign, was it a different subnet?

i messed up with everything now :frowning:
I assigned the renderer an ip of and the nuc both with subnet and gatway of my vdsl router

But the way it should be! The main thing that Roon finds renderer and It only ! All was done for this with two ethernet ports.

correct but how do i go back ? i mean how do i get my renderer ip adress from static to dhcp again ? any idea? because in fact the 2 ethernet produce 2 networks while the one between the nuc and the brinkmann cannot be accessed from the ipad

Change ip settings of the router
/any other wifi router to the range…250, connect the iPad to your renderer/router and return back the ip configuration of your renderer by mconnect .