Silence Is Not Golden - DietPi & IQaudio DigiAmp+

Hi all,

I have just built up my third Pi plus HAT combo, this time a Pi with IQAudio DigiAmp+. The build went OK as usual (standard non-GUI build updating itself to v157) but despite all signs of success (eg detected by Roon with Roon playing audio to it) there is no sound coming out of the speakers. The mute LED on the DigiAmp+ board is not lit, nor does it light when muting the audio in Roon. The Power LED is lit. Volume is controlled in Roon via ‘DSP Volume’ in Settings. The other setting ‘Use Device Controls’ doesn’t produce any sound either.

My audio path in Roon looks like this:

I have seen this thread, which contains a similar issue, but have not had chance to read through the huge amount of detail in it yet. During the DietPi setup, there are several audio driver options which reference the DigiAmp+ and I have tried the first in the list and the ‘Unmuted’ option. Neither give any sound. Beyond starting agin or trying a different build I am out of ideas.

What’s that -68db in your DSP doing? Isn’t that the possible cause of your silence?

Hi Geoff,

it is keeping the volume low so I don’t get blasted! Of course I tried much higher volumes but to no effect. Audio sent to the device was only CD quality and there was no signs of life at all, not even any hiss/hum, nothing. The device shows up in Roon audio settings in exactly the same way as my other two Pis do.

There are some troubleshooting tests listed in the IQAudio PDF which I will have time to try tomorrow hopefully. I am just used to these things working first time though.

Sure the DAC is selected (as the soundcard) in the ALSA settings in DietPi? I’ve had mine deselect it after doing installs. Check it via the config menu rather than the GUI - my IQAudio Digi+ didn’t show up in the GUI.

OK fixed it. SSH into the PI and checked a few things:

aplay -l

showed the correct driver was loaded

systemctl status roonbridge -l

Seemed to show that Roonbridge was installed and working.

As the device showed up in Roon and could be played to I was certain the above two would not show any issues anyway.
Now onto the main suspect, the ALSA mixer, which has been implicated in a previous thread…


Showed that the Digital volume was set to zero! Jacking this up to max soon produced some music. The question is I suppose why it was set that way in the first place and what happens when I reboot the Pi? Will update the thread when I find out.

Press esc to exit the alsamixer screen

Note that the volume setting in Roon should be at least -45dB for you to hear anything, so that is a good place to start when you fire it up for the first time (warning, it starts at full volume!)

OK, alsamixer config is not saved after a reboot, so does anyone know how to make these changes permanently as part of the bootup config?

That’s odd, I thought that the config would be saved. Flagging @Dan_Knight for his insight…

sudo alsactl store

Should do the trick.

1 Like

Cheers, have executed that command (no response after execution just back to the prompt - is that OK?), but too busy fiddling with the DSP EQ to reboot at the moment!

Back to prompt is correct. It should write to the /etc/asound.state file. I think that’s where it is on Debian. Will be able to check later.

Edit. Apologies. File is in /var/lib/alsa/

1 Like