Silent Angel vitOS Boot Problems

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

BT Home Hub

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Khadas Tone Control USB DAC

Description Of Issue

I can’t seem to load the vitOS onto my Raspberry Pi4 8GB?
I downloaded the OS from Thunder Data and extracted the zip file using WinRar. I them flashed the image onto my SD card using Balena Etcher.
Inserted the SD card powered up the Pi and the green LED flashes 4 times indicating a corrupt image or poor SD card?
I have flashed the Raspberry Pi OS onto the same SD card and this booted OK all works fine.
The Pi is new.
Has anyone had similar problems with the vitOS from Thiunder Data?

Was the Rpi connected by ethernet cable to your network? WiFi is not an option with this bridge OS, either during install or after setup is completed.

Also, some have been reporting issues with Etcher. You might want to try to use Rufus instead.

Lastly, since you are using Windows 10, you can try using the native extraction in Windows Explorer, in case WinRar is causing any issues. I doubt this is the problem, as WinRar is ususlly pretty good.

Yes Ethernet cable connected.
I’ll give Rufus a go although I have successfully flashed RoPiee XL using Etcher with the same SD card on the same day?
I’ll try again using the Windows native extraction tool although I did use WinRar when I extracted RoPieee and this installed first time with no problems?

Working fine with the 2GB RPi4. Can you connect a display to see what’s happening on the console during boot?

Hello David

I had a monitor connected during the boot there was no video output from the Pi during the boot sequence I will try this again this afternoon just to be sure.

The green LED on the Pi flashed 4 times about 0.5 seconds intervals then flashed 4 times again but twice as quick this sequence continuously repeated in a loop with no video output?

Sounds like a corrupt image download or something gone wrong with flashing.

Hello David

Yes it appears the image is corrupted.
I have downloaded the vitOS again and extracted it using the Windows 10 extract tool.
When I look inside the extract folder at the kernel.img I try and open it and Windows tells me the file is corrupted?
I have successfully installed DietPi this worked first time as did the Raspberry Pi OS and RopieeeXL so I guess the download is getting corrupted somehow?

I ran into the same issue. With other images the pi does work, so it’s not the pi. But with the vitOS image, the pi doesn’t boot. Which version of the pi do you have? Mine is the 8GB model pi 4. That might be an issue? Anyone else tried on the 8GB version? Also used rufus, but didn’t change the result. David, which version of vitOS you are using? 1.0.823? Extracted the image with 7-Zip. Anyone successfully installed vitOS on a 8GB Pi4?
Thank you for any hint.

Hello Patrick
I’m using a Raspberry Pi4 8GB.
Silent Angel uses Source Forge platform for downloading the image it does provide alternative download links if you are experiencing trouble when downloading the image I’ll try a few different links to see if that helps.
I can confirm my Brother also has the same problems he also is using a RPi4 8GB so maybe the problem is with the 8GB version?

Hello Matthew
I just ordered a 2GB Version of the pi4. Just to be sure, it’s not an issue with the 8GB version. I keep you updated here.

Quite strange, and don’t know how to explain it, with the 2GB version of the pi4, it does work. So might really be that the 8GB version doesn’t work with vitOS.

Next issue, Roon Bridge cannot be downloaded from iOS App (VitOS Manager). Any suggestions there?

Pi 4 8Gb the same problem, the image file is absolutely OK. I suppose that we have to wait for a bug fix from vitOS developers.

Hello Patrick

OK so the 2GB version works that’s interesting.
I guess Silent Angel will need to issue an update so the 8GB RPi works; as this is the latest version I assume the OS was probably developed on the 2 & 4GB versions?
Its unclear why you can’t download the Roon Bridge from the App I assume it will be part of the same problem? I’ll keep an eye on the software version and check back from time to time to see if Silent Angel have updated the vitOS version number.

mine is 4GB and have zero issue in both installing on the sd card and add the roon bridge form their app…total time less than 5 mins

Hello Matte_Rocks

OK so the 4GB works with vitOS and you can download roon bridge from the App this is some good news. So I guess Silent Angel needs to work on an update for the 8GB version.

The vitOS version seems to be 1.0.823 unsure when this was released?

Hello Matthew_Hoult, on the official site I’ve found the 12-30-2019 release date

OK December 2019 seems old I think the RPi4 8G was released in May 2020? so the OS must be out of date for the 8GB version

Logged in by SSH onto the pi4, and installed Roon Bridge manually. Now it works.

1 Like

Hello Patrick

Sorry I’m new to all this what is SSH?