Since build 1105, can't connect to core, errors loading saved pages. No other changes to system

Roon Core Machine

Mac Mini 2012 Catalina 10.15.7
2.6 quad core i7

Networking Gear & Setup Details

xfinity modem
Eero wifi network, but core and bridge machines hard wired ethernet

Connected Audio Devices

Ethernet for all streaming devices. (mostly all Pi’s running RoPieeeXL.)

Remotes (phone, laptop) on wifi.

Number of Tracks in Library


Description of Issue

I know I should wait to update, but i just impulsively clicked. Grrrrrrrr.

Roon pages just flash. They render for a few seconds, then they go black, and then I get the “can’t connect” and “looking for your core” messages. A few “errors loading saved page” messages. And the cycle continues.

Been running flawlessly for months before this.

Tried restarting roonserver, Mac mini that houses the core, Xfinity modem, Eero wifi router, switch, etc…


Tried to disconnect and reconnect, and it’s stuck on “initializing”

Screen Shot 2022-09-08 at 1.33.25 PM

ok after an hour of restarting the app, and rebooting devices (and pulling hair out), I seem to be back in business.


(And it begs the question, would I have gotten the same result had I left it all alone?)

Thank you for listening to my Mysteries of the Rooniverse TED talk.

You are very welcome!

On my setup with a ROCK roon core the update went totally smooth without any problems.
As we see here everybody’s milage does vary

just tried to log on and it’s doing it again. :roll_eyes:

for what it’s worth, i reboot the core every night.


Ok, I found a major symptom… I have two laptops next to each other, both on wifi.

If only one has roon open as a remote, no problem, But if I open it on the second laptop, the first one crashes, and the second one just loops.

If I close roon on one, the other is just fine,

I remember this happening in another build.

Fix for now is to only have one instance open at a time, but hopefully this can be resolved.

Hey @terzinator ,

Thanks for reaching out and for your report here.

This is not expected behavior, you should be able to use multiple Roon Remotes at the same time without the other crashing. Can you please reproduce the issue and let me know the time + date of the next crash and which device crashes? I’ll enable some logging for your account to see if we can dig into this further.

ok, trying now, getting same behavior

both instances crash… seems like after a while one will crash and then the other survives.

will be interested to hear if there’s anything in the logs!

Hi @terzinator ,

Sorry for the delay here, things have been a bit backed up with the 2.0 release. Are you still having issues after updating to 2.0? I enabled diagnostics and took a look over your logs and saw you’re playing music ok, have the issues stopped since we spoke?

no biggie. I’ve just been avoiding having more than one instance open at once.

I’ll test with 2.0 and reply to this thread with findings.

1 Like