Single Term search results

@zenit i will use this thread going. I was not aware that partial search worked for me, because I use single word search terms for speed.

Not for me, from my location, at this time. I don’t know how your infrastructure is load balanced, nor do I understand what the error message means (whether a local or remote problem), so I can’t comment further.

What information would be helpful? I restarted the entire stack the first time it happened a few days ago (but I don’t search that often), I have commercial internet at home, run a ROCK, everything on latest version, unmanaged switches, 90k tracks, RoPieee endpoints.

1 Like


Support wants each user to have their own support threads. I pulled the other posts out for TripleCrotchet’s posts, for his issues for his support thread.

I have now pulled your post out. Please keep your discussions here so that the separate support threads can be kept separate.

1 Like

For clarity, I’d like to know what “Connect to Roon Search” means, whether it indicates local, remote, or both.

Also, for future users looking for help, topic split from Partial Name Search Results Inconsistent - #3 by tripleCrotchet which showed other examples of the same search error results.

You probably want a more precise answer from support but my understanding is that it is “remote”. I have seen it mentioned in a few threads now that search has been completely migrated from local core to remote cloud. A major architectural change was announced by roon some weeks ago. Myself, personally, I have only noticed these search issues since build 1169. But it is possible they were there earlier because this has all coincided with me firing up some old NAS storage that was dormant this last 2 plus years over Covid and that has effectively doubled the size of my local library.

@zenit, why are you closing support threads that have not been solved?

I wrote an explanation here Partial Name Search Results Inconsistent - #6 by zenit

It is effectively the same issue.

This is not making any sense. The mods were asked to split one thread into two and you have closed one of them. It makes mores sense that the thread was not split in the first place so that information is not lost.

Nothing is lost, don’t worry. The mods at the time weren’t aware if it was a duplicate or not.

I apologize for the confusion.

I am not sure I understand this comment from the other thread. Are you saying that single word queries must be enabled on a case by case basis, that more generally it is not allowed to search (say) by composer last name? Or do I misunderstand?

No, that’s not what I’m saying. Just that these particular cases are not support cases. You can expect for chopin, brahms, bach to see the composer, but the probability is lower with less popular composers, in particular in cases like beach where there are also significant non-classical matches.

This is not particularly systematic. But here is another:

Search on “Perlman”:

Search on “Itzhak Perlman”

I don’t know if you have seen this one yet, but this guy got a fail on “Elvis”

It does not work on any search.

Why is popularity a determinant for basic search functionality? @brian ’s recent post explains a bit about the nuances of making universal search decisions, but for local libraries with perhaps an unusually diverse range composers, the decision to not allow unpopular single search terms is tough. What if I don’t remember which “Praetorius”? (There are a family of them, like the Bach family.)

I’d love a dialogue on how I would locate a desired album in the new Roon search world.

For completeness, some results are suggested, as per the screenshot. But selecting “See all results” yields the same error.

Curiously, I tried some composers where only one name is known (Perotin or Perotinus), and Roon had no problem finding the correct composer, and quickly led me to the albums in my library:

I don’t quite (yet) understand the difference. I can’t believe that Perotin is magnitude more popular than Praetorius.

But the painting representing Perotin is pretty funny. It looks to be Lassus, from a few centuries later, but maybe I am wrong about that; I tried to use Valence to correct it, but it doesn’t work on an iPad, and then I tried again on a laptop but now get 503 errors. EDIT: Reloaded, and just got in.

I’d probably suggest a snippet from Pluteo 29.1 of one of the 4 part organa instead of a traditional "portrait:, if the mods deemed that substitute acceptable.

It’s a general error that indicates that the core either had an issue sending a request to the cloud, or that the cloud is not responding in a timely manner.

The issue right now is that you’re getting an error for some search queries on the search page (like praetorius), it has absolutely nothing to do with composers. Very likely, you’d be able to reproduce the issue with some album titles as well. This wasn’t a decision, it’s a bug, and its fix is being tested by our QA team.

I am finding that whereas typing the entire second name fails, typing just the first few letters can succeed. This does not work in every case and it is not at all clear how many letters are necessary. For example:

Typing the four letters “prae”

Typing the three letters “kar”

Thanks. I appreciate the direct response. Let me know if I can contribute in any manner.