Singxer SU-1 issue with Roon (Rock) Server Linux


i have a Intel NUC7i5 with installed Roon Rock server and a direct connected Singxer SU-1 USB interface that feed my DAC. The “big” problem with this setup is, that i get after some minutes of listening a horrible noise signal and the connection to the singxer lost, usb cable disconnect and restart helps temporary. I testet also as fallback solution the actual DietPi distribution + Roon server with the same problem. To my Surprise with MS Windows 10 + Roon server the problem doesn´t exist only on the two Linux installations. Maybe there are a problem with the ALSA interface and the Singxer SU-1 or a problem with Roon? I would prefer the Roon server run on Linux, its faster and sounds for me better, but at this time it´s unfortunatelly unusable for me.

Hi @Soeren_Schulze ---- Thank you for the report and sharing your feedback with us, both are appreciated!

Moving forward, to help aide in our understanding of this issue, may I very kindly ask you to please provide the following information:

  1. A screenshot of the signal path leaving Roon when you notice the issue.

  2. When you notice this behavior are you streaming the “same type” of content every time you are experiencing this issue?

  3. Please verify the make and model of the DAC the Singxer SU-1 is feeding. Furthermore, if the DAC is able to receive “USB IN”, can you please bypass the SU-1 (temporarily of course) and confirm if you notice the same noise?

  4. Just to make sure I am understanding your observations correctly :innocent: While running ROCK and DietPi + RoonServer you experienced this issue, however when you used RoonServer under Win10, there were no issues. Correct? Were all the settings the same when you conducted these tests?


Hello Eric,

thanks for your quick reply.

  1. There are no changes in signal path, file is fourther playing but terrible noise (noise starts after switch to next file). After stop playing, Roon loses the Singxer as playback device.
  2. Content is various from 128 Kbit mp3 to FLAC 192 khz there are no specific problematic file type for this issue.
  3. DAC is a SPL Director and there are no problems when i bypass the Singxer and connect the DAC with USB direct to the Intel NUC.
  4. Yes all settings are the same, on Linux there are the issue on Windows 10 (with the necessary vendor driver) no problems.

I think its only a problem with the Singxer SU-1, other devices like the USB Input from the DAC and also a Audioybyte Hydra Z USB Bridge makes no problems.

Actual i found also the “Resync Delay” option in the device setup of Roon to correct synchronisation errors and i will make a test with higher values than 0.




Different settings of “Resync Delay” has no effect. The issue occurs on bit depth change between two files (16Bit to 24Bit or 24Bit to 16Bit).

Hi @Soeren_Schulze ---- Thank you for the follow up and my apologies for the slow response here.

Moving forward, I have went ahead and enabled diagnostics on your account so we can take a closer look into what is going here when you are using ROCK + Singxer SU-1 USB interface + SPL Director. Can you please reproduce the issue a few times, let us know when the failures occur (i.e “The “big” problem with this setup is, that i get after some minutes of listening a horrible noise signal and the connection to the singxer lost, usb cable disconnect and restart helps temporary.”), and we’ll have a closer look.


Hello Eric,

thanks for your closer look to my problem, i have made in the last days some intensive tests with different setups. First the problem is only at playing when switching from a file with 16 Bit depth to a file with 24 Bit depth, the other way (24->16) makes no problem, USB cable reconnect helps to the next Bit depth change. I checked the ALSA output and the Singxer support three formats “16Bit”, “32Bit” and “SPECIAL” and at playing 24Bit files the 32Bit ALSA output is active. If i use the Roon DSP Engine ALSA output are on every time 32Bit and with no Bit depth change there is no problem.

  1. USB Audio Class Digital alsa audio output interface `hw:0,0’
  • device name = USB Audio 2.0(SU1)
  • interface name = USB Audio
  • usb audio class = 2 - isochronous asynchronous
  • character device = /dev/snd/pcmC0D0p
  • samplerates (Hz) = S16_LE:44100,48000,88200,96000,176400,192000,352800,384000,705600,768000
  • monitor file = /proc/asound/card0/pcm0p/sub0/hw_params
  • stream file = /proc/asound/card0/stream0

Next i tested some available Linux distributions with the effect that only! Audiophile Linux (ap-linux) works without any problems. Roon Rock, DietPi and Arch Linux with standard or realtime kernel doesn´t work. I think the problem can be only solved with some kernel settings or module versions. Audiophile Linux uses a customized realtime kernel 4.9.9 and is based on Arch Linux.

I don´t know is this a Roon software problem or a Singxer SU-1/Linux problem, it might be a little bit tricky!? But actual it works and the problem is temporary solved.

Thanks for your help!


Hi @Soeren_Schulze ----- Thank you for the updating and sharing the observations you made during your testing! The insight and feedback are both VERY appreciated!

Moving forward, I touched base with a few of our techs earlier and they have asked if you can confirm if you make same observations while using other applications. For example I know DietPi has other software options such as HQPlayer and Squeezebox (etc). During your test runs have you tried using the SU-1 with any of these other options under DietPi? If so what was the experience like?


Hello Eric,

unfortunately i did not use other applications like Roon, my one and only music software system :slight_smile: I tested now also a Cubox-i as Roon Bridge with actual Armbian Linux standard Ubuntu kernel 4.11.6 connected to the Singxer SU-1 and there are no problems. Maybe if i have time i will test in the next weeks some other configurations.


1 Like

A post was split to a new topic: Singxer SU-1 + Aqua La Voce S2 DAC - Tracks being skipped

4 posts were split to a new topic: Singxer SU-1 and Linux - Producing “white noise” when changing tracks