Skipped tracks due to “corrupt” files

Core Machine (Operating system/System info/Roon build number)

NUC 10 i7, running ROCK (unsupported use, but it works well). i7 processor, 16gb RAM, 500gb m.2 nvme ssd, 1tb storage ssd (completely empty). ROCK version 1.7 (build 571) stable.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Comcast Xfinity gigabit internet; Netgear docsis 3.1 modem; ASUS AC-87R router; microrendu; Synology DS-218+ NAS; NUC connected to router by CAT-8. All wired connection; only Ipad and Android remote apps on wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonore microrendu > Usb > Topping D90 DAC > RCA> A5 powered speakers on desktop.

Description Of Issue

Switched this afternoon from Windows 10 to ROCK on NUC. Approximately 30 mp3 files failed to import and are listed in “skipped files” in Library settings. The log says these files are corrupt.

However, they all imported properly when I last reinstalled Roon last week (including a fresh library scan) when the NUC still was running Windows 10. They also play properly from beginning to end when played tonight on my Windows desktop machine using JRiver Media Center.

In the past, when I have had corrupt music files, they would not play at all on Windows, so I assume they are NOT corrupt. As there were no issues with these files when I was running Windows Roon (until this afternoon) and still aren’t with JRiver under Windows, I would think this is a Linux issue.

Years ago, I had a Linux box and, I recall, there were some characters that Linux won’t accept in filenames. None of these files has those characters. Further, because my NAS is Linux-based, I assume that I couldn’t even give these files names that violate Linux convention.

I successfully imported a gazillion files, so this is not a huge deal other than to the extent I now have some incomplete albums.

Is this expected behavior?

This is a known issue for some MP3 files - Roon on Windows 10 will accept and play them; Roon on ROCK will not. See here:

It may be caused by different versions of the MP3 codecs in the platforms.

Are you able to convert them into a different format using an application such as dBpoweramp?

Yes, tried that with a few (mp3 to mp3), but it made no difference. FWIW, the converted files reimported back into JRiver immediately and played just fine.

I might try converting them to FLAC but I hate giving up the disk space to crappy fidelity. :slight_smile:

Mike - in that other thread you said you tried converting from MP3 to MP3 using dBpoweramp - have you tried converting to another format altogether (e.g. AIFF or FLAC)? That has apparently worked for some of us.

Edit: as Anders always says - disk space is essentially free these days…

Just edited my response above. I haven’t tried FLAC but I will give that a go.

Just converted two of the files to FLAC. One imported, one did not.

I also just realized that ROCK isn’t importing in real time. I had to scan to pick up the file that imported, whereas with Windows it would have shown up as soon as I wrote the file to the NAS.

The converted FLAC files are themselves corrupted, so maybe there’s something weird about the original mp3’s after all. Still, I wonder why they play perfectly on Windows.

Well, it may be that Windows and some other players are more forgiving of corruption in the header information than Roon. Try converting one to WAV as a test as it doesn’t have meta-data. If it works, you can convert back to MP3 and then re-tag the file’s meta-data.

Hadn’t thought of that strategy. Will give it a go.

Weird behaviors. With DBPoweramp, I converted to wav, but it retained metadata and imported into Roon. I then converted back to mp3, overwrote the metadata with the same metadata (to retain consistency with the other tracks in the album), deleted the wav file from the folder, and the revised mp3 didn’t import. Unfortunately, since I deleted the wav file from disk before I deleted it in “file edit,” I now can’t delete the wav file from the Roon database. So, now, I don’t have the track on Roon, but Roon thinks there is a wav version. The “cleanup” function doesn’t delete the “lost” file from the Roon database.

I am inclined to convert all the files to FLAC and import those or just delete them altogether when they are oddball singles that aren’t part of a complete album. Bothers me to have to do this, but I imagine it will work.

Hello @Mike_Rubin, and thanks for this report. I’d like to gather some of the files in question and send them to our QA team for further investigation. If you could please add some of the original MP3 files with this issue here, I’d be happy to pass them along! Please let me know when you have a chance to upload those files, thanks!

Hi, Nuwriy. Thank you for looking into this.

I deleted most of the thirty files in question as they weren’t essential. I also deleted the mp3-to-FLAC and mp3-to-FLAC-to-mp3 converted files with which I experimented because they had incorrect playing times. I also downloaded new versions of some albums and replaced the “corrupt” ones, which might eliminate these issues if I reinstall ROCK at some point. (I reverted back to Windows for the time being, as I need to monitor CPU temperatures with my NUC.).

However, I kept a couple of the original “corrupt” tracks that were part of full albums. I uploaded those as you requested. If you need more, I might be able to reconstruct the original list and find a few more files.

Thanks again @Mike_Rubin, I appreciate you sending the files. They’ve been sent to our QA team for analysis! I’ll be back with some information.

1 Like

Thank you, Nuwriy. Keep me posted.

@nuwriy, do you have any information for me about this? I have reverted to using ROCK on my NUC and I had the same issues trying to import these files when I did. As I mentioned, Windows had no problem with them. Neither manipulating the file names nor converting the files back and forth out of mp3 format makes a difference.

Hello @Mike_Rubin,
Please accept our apologies for the delay here! I took a look at our internal tracker today, and I can see that your ticket is still in our review queue. A member of our QA team should be reviewing this soon and providing feedback.

I’ve requested an update from the team and upped the priority in our tracker so I should be able to get back to you soon with an update. Thanks in advance for your patience!

Thank you again.

I have listened carefully to one of the tracks and believe it has audible distortion, even though it plays on Windows, so it may well be corrupted. Don’t know about the other one, though.