Skipping quickly through all tracks - Windows 10 System Output

Core Machine (Operating system/System info/Roon build number)


Ubuntu Server 20.04.1 - Proxmox - Qemu VM - Build 710

  • 2 cores
  • 8gb ram
  • 64gb ssd

Proxmox System:

  • Motherboard - Supermicro X11SRA-F
  • CPU - Intel Xeon W-2150b
  • Ram - 128gb Registered ECC

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Pfsense - Proxmox - Qemu VM - Same Hypervisor as Core

  • Everything is connected over ethernet
  • Multiple unmanaged switches between core and windows pc

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Sony WH-1000XM4 - Bluetooth - Windows 10 - System Sound


Description Of Issue


When selecting anything for playback, all tracks in the que will be quickly skipped through.

This is happening on multiple output devices on the computer when attempting to play in shared mode.

If I enable exclusive mode, then this does not happen.
This is not a solution as access to sound from other sources is a requirement.

This happened on two separate windows 10 computers.


First PC - Now Working


I have fixed the problem on one pc by disabling most devices through the windows sound control panel.
The disabled devices include:

  • Steam Streaming Speakers
  • Steam Streaming Microphone
  • Nvidia High Definition Audio x 3
  • Both front and back panel analog output

This pc is now working with Windows system output.

Audio chain is:

Roon core ==> Windows System Output ==> Teac UD-H01 USB


Second PC - Not Working


I attempted the same fix on the second pc. It appeared to work temporarily, but is now encountering the skipping issue again.

This is a fresh install of Roon Core on a fresh install of Ubuntu Server 20.04.1

This is the error that shows up in the logs

Source: 44.1 kHz
OS Mixer: 48 kHz or higher (typically)

No sample rate conversion to the OS Mixer frequency configured in Roon?
Does configuring a matching sample rate conversion in Roon or changing the OS Mixer frequency in Windows to match the source resolve your problem?

Hello @flyingears,

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

The OS mixer should automatically convert to the output device sample rate.

The output device sample rate is also 44.1kHz so the mixer would not have to do any conversion for the log I posted.

Windows firewall is disabled completely for private networks.
I verified that the current connection is labeled as a private network in windows.

There are no other firewalls running on the windows machine.

There is some weird behavior going on with the output device in roon between the two computers.


Working Windows PC


System output has these options in the advanced menu


Problem PC


The system output looks different

Both of these are the system output device on windows 10.
What reason would they have for being different?

Differences in the default output device is my guess. On the problem PC, if it has Realtek hardware verify the latest drivers are installed.

Hi @flyingears,

What DAC do you have connected to the non-working PC, is it this one?

Sometime bluetooth headsets are picky about what type of channels they accept, I have seen some headsets only take 5.1 or 7.1 channel content, so you would need to configure this in Device Setup.

I would also try to enable DSP upsampling to see if other sample rates work, you can specify Max PCM rate or custom re-sampling in the DSP menu: