Skipping Tracks from Local Library


It turns out that Shuffle was turned on in the Queue page. Why that should affect the album page, I don’t know, but I turned it off and the problem went away.

Machine, Network and Software versions are in my profile.

Core machine. Output set to local Core Audio.
All local files. Mix of Flac and Apple Lossless.
On an Album page.
Press Play Now. Most tracks flash by and are skipped. Sometimes a track way down the list starts playing.
Pick a track and click, choose Play Now from the popover. Sometimes it works. Sometimes it doesn’t.
Try either action several times, and get different results.
Is not specific to any album or source drive. I’ve tried album on all three drives.

Attempts at Remediation

Restarted Roon.
Restarted the Core machine.
Force Rescan on all Storage sources
Performed Disk Repair on all drives; no problems reported. All directories check out ok.
Repaired permissions.
Checked to make sure drives aren’t sleeping.
Played the same albums using three other methods — Swinsian, VLC, Plex

This is super frustrating. I don’t care if Roon can’t do anything else, it should still play files-on-disk without fail on the same machine as the Core.

Glad you sorted this out! :tada:

Turns out that wasn’t the solution. The problem is back.

And the basics? Unplug everything, modem, router, switch, core machine etc. Start up one by one.

Have you tried disabling your firewall? If not, it would be worth testing to see if it’s causing problems.

Yes to all of that, as noted in my original post, but not the network. These are local files (not) playing out of the Core. If it’s a network issue, it shouldn’t be. It’s displaying the allmusic data just fine.

There is no firewall. Even if there were, how could that affect files-on-disk on a Mac running the Core?

My apologies, I misread your original post, so it does seem unlikely that the mac’s firewall is causing the problem.

1 Like

@kevin I hope you don’t drop it here. This strikes me as a bug that needs fixing.

1 Like

We need a bit more information – everything was working fine for you previously, can you think of anything about your system that may have changed? How often does this happen? Any error messages?

No updates or changes.
I have added tracks. I always restart the whole system after they’ve been assimilated by Roon, or Roon is unlikely to play anything at all, even if it’s just a couple of albums.

This problem is ongoing and has been through the last few releases.
Restarting the Core machine often fixes it for a while, and that’s my 1st remedy each time.

@Andrew_Webb I didn’t notice earlier but it looks like we’ve been down this road before, no?

Can you let me know the local time & date the next time this happens? After that, I’ll try to pull a diagnostics report and see if it’s the same issue.

It does look like that. I’d forgotten what the symptoms were back then. I’ve had several database corruptions/failure to load/backups don’t work.

My guess is that my db is too big. It’s currently 32.5 GB.

Yes, I will let you know next time it happens. Thank you.

Sunday, 24 October
09:12 a.m. Mountain Standard Time

Happening now
10:55pm MST
Local files
All play fine through other apps