Slow backup to Dropbox

@support
Running Roon 1.6
OSX 10.14.3
Core on Salk Sound Streamplayer III
Music stored on Salk Sound Streamplayer III
Streamplayer has an ethernet connection to network > 500 Mbps
Endpoint: USB to Parasound Halo Integrated Amp
About 20,000 tracks

Backing up to Dropbox showed 50% after four whole days!
Manually backing up to another folder on Streamplayer takes less than a minute.

Rebooted everything. Manually restarted a new Dropbox backup. Also tried manual backup in a new Dropbox location. No improvement.

Upload speeds consistent on my network all throughout.
Dropbox upload settings are “unlimited.”

Backups on an every-other-day basis worked fine until Jan 23 (all Roon 1.5 backups; the last Jan 23 backup was of Roon 1.6).

Roon playback continues to be flawless.

Any help appreciated, thanks!

Hello @Scott_Donian,

Can you try disabling and re-enabling Dropbox to see if that helps? Are you by any chance out of Dropbox space? I would verify this on the dropbox site just in case.

Thanks,
Noris

Thanks Noris. Sorry, I should’ve mentioned that I actually did disable and re-enable Dropbox. And no, I’ve 75% of my 1 TB allotment left.

I think it’s very slow as well. I cancelled the backup the one time I tried it a few weeks ago because of how long it was taking. When backing up to local storage it’s very quick. When backing up to Dropbox it’s terribly slow.

My concern was that it seemed to be something new (at least for me) that came to my attention last week. Never had the problem before (over a year).

Hi @Scott_Donian/@John_Aiello,

Thanks for letting me know that information. If there is no change by disabling and re-enabling dropbox, let’s move on to the next troubleshooting step:

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I kindly ask you to reproduce this issue once more and then note the exact local time in your country (ex. 8:12PM) that you experience this behavior. Once that information is provided I can take a look at the diagnostics from your Roon Core to see if there are any issues in the logging regarding dropbox backups.

Thanks,
Noris

I’ve experienced very slow Dropbox backup that mostly just failed to complete…would “time out”. Google search came up with suggestion to check my DNS server settings on the router. Changed from ISP’s default DNS server to openDNS and have had no problems since. Still slow but always completes in a few hours rather than days or never. It may be worth a try?

Noris,

My scheduled backup to Dropbox started at 1:00 am US Central Standard Time. In the last 7 hours, it has transferred 12%.

Thanks for helping out.

1 Like

That’s an idea. Thanks!

I am already at 1.1.1.1 So that won’t help me.

Hello,

@Scott_Donian - Thanks for letting me know that timestamp. I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis. After this has been received I can take a look for any unusual behavior at that timestamps you listed.

@John_Aiello - Can you please let me know if dropbox backups were working before Roon 1.6 as expected? Dropbox’s API is usually slow but the backup failing outright is strange. What is your Core and networking environment like, can you please let me know the model/manufacturer of all your networking gear and how your Core is connected to the network (weather on WiFi or Ethernet)?

Thanks,
Noris

Norris I did not try before 1.6. Sorry. I only tried after 1.6 was installed because it seemed like a good idea but it was taking so long that I decided to let it go and just keep backing up to attached storage.

@noris

Any word on diagnostics?

Hi @Scott_Donian,

I am not seeing anything strange in your diagnostics so I have submitted your case to QA for review. I have just asked them for a status update and will be sure to let you know once I hear back from them.

Thanks,
Noris

@noris
Thanks!

Hello @Scott_Donian,

I appreciate your patience until QA has had a chance to review this case.
We have found the place where it hanged on 12% upload but as far a we can tell the transfer was still in progress albeit it was proceeding very slowly. I have a few follow up questions:

  • When this issue occurred, were you presented with an error message or sorts?
  • Has upgrading to our newest build (b401) had any change on this behavior?
  • If this issue is still the same, can you please share a screenshot of your Roon Settings -> Backup tab? You can use these instructions to upload screenshots.

Thanks,
Noris

@noris
Thanks, Noris.
I upgraded. De-authorized Dropbox. Then re-authorized it. Forced a new back up to start.
The screenshot shows 63% has transferred after about 15 hours!
The other two backups are local. One of them was interrupted by this [long] ongoing Dropbox backup. In other words, things haven’t changed.

Hello @Scott_Donian,

Thanks for posting that information. I am going to check in with QA regarding further steps for this issue but I just wanted to confirm some network information in the meantime:

  • Can you please let me know the model/manufacturer of your router and any other networking gear you may have?

  • Have you updated your router’s DNS servers as per @Richard_Girton’s suggestion? I would suggest giving Google DNS or Cloudflare DNS a try just to see if it helps with this issue.

Thanks,
Noris

@noris
Thanks.
I have AT&T’s router for my Gigabit network to the house (on my 2d floor). AT&T doesn’t permit changing its DNS settings. This router sends wired connections through the house.

In the basement music room, I have a Netgear R6400 router connected to one of those wired outlets, simply acting as an extender. My Roon-ready Streamplayer III has a wired connection to the Nighthawk.

The Netgear is also broadcasting wifi (to which my iPad running the Roon remote connects).

Again, nothing has changed. I had no trouble for over a year, until 6 weeks ago (when I first posted on this thread).

Jim Salk (manufacturer of the Streamplayer) informed me DNS settings cannot be changed on the device.

I’m stumped. Appreciate your ideas and wisdom.

Scott

I was having same issue as of today but I found a solution.

When selecting the file path to backup to in Roon Instead of clicking the DROPBOX file path I went the slightly longer path of selecting Local disc > Users > 'My user name > Dropbox and then folder I wanted to save to.

Hope this also works for others.

1 Like