Slow change of tracks or albums

Roon Core Machine

Mac mini M1 8GB, MacOS Monterrey 12.3

Networking Gear & Setup Details

Unifi Dream Machine

Connected Audio Devices

Matrix Audio Element X//Naim Mu So//Naim ND5XS (through Sonore Bridge)//All wired
iOS Remotes updated to latest iOS version, wireless (5 ghz)

Number of Tracks in Library

+/-150K, 110K own library, 40K

Description of Issue

Changing from one album to another or -within an album- from one track to another, takes 3-7 seconds. This happens most of the time but not all the time. It just happens when you change the track/album in the app. When an album is playing, next song plays without major hiccups. Next album in a queue sometimes takes a couple of seconds to play.

Happens both within Tidal and within own library and when changing from one to the other. It seems it is worse when using remotes than the Mac OS app, but happens in both. It also seems to get worse as playing time increases. Happens with all endpoints.

Hi @Ricardo_Damborenea,

Sorry for the delay in getting to you, we’re sorry to hear that you were having long pauses when changing tracks. This is typically a symptom of slow connection from the customer’s local network with our servers. Are you still having this issue on our most recent update, Build 936?

If so, please let us know. We’ll be watching for your reply. Thanks!

Hi @jamie

I haven’t been able to use Room with the new build for long sessions. Nevertheless, my initial impression is that the lag has decreased significantly. Now is a couple of seconds when changing tracks/albums after the previous song has been playing for more than 1 min.

As previously the gap was “time sensitive” (the longer the previous song had been playing, the longer the gap; the longer the Roon music playing session, the longer the gap) I’ll keep tracking performance and will keep you posted.

Thanks for asking @jamie

Thank you for the update @Ricardo_Damborenea,

You may also want to take a look at our Help Center article on Networking Best Practices to see if any of the recommendations there can be applied to your Setup.

Hi @jamie
I’ve read and followed the networking suggestions. I would appreciate some specific advice on the right set up of the Unifi UDM router, which is the one I have (and maybe some firmware has changed something).

On the lag topic, after 3/4 hrs of play it seems lags have diminished a lot, but not fully disappeared. Now changing song/album after a song has played for 1 min takes 2-3 secs (previously up to 5-7), and after 3 min or more 4-5 secs (previously up to 10-20). So seems much, much better, but not 100%

An additional couple of hours of listening and the problem comes back. If I restart Roon, it +/- disappears for some time, then comes back

Hey @Ricardo_Damborenea,

The first thing you can check is to see if IPv6 is disabled on your router. You may have to do a Google search for how to do that on your particular router.

Next, please ensure that you’ve set firewall exceptions for Roon. You can find more details on that here

Then please check Private Relay settings on your MAC and ensure that it’s toggled off.

On your Mac, choose Apple menu  > System Preferences, then click Apple ID. Select iCloud > Private Relay.

On your iPhone, iPad, or iPod touch, go to Settings > [your name] > iCloud > Private Relay.

Your iCloud settings might take a while to load. In order to disable it, simply untick the box and click “Turn Off Private Relay” when the prompt appears.

Please let us know if this helps, thanks!

Hi @jamie

All suggested network adjustments re-checked but problem persists with same symptoms (time sensitive to how long previous song has played and to time Roon has been playing since last reset)

I’ve also experienced a couple of isolated random surges of RAM used resulting on songs playback stutters, then stopped and a jump to next song.