Slow Connection to ROON from my Android Tablet

Core Machine (Operating system/System info/Roon build number)

PC - Intel Core i7 960@3.20GHz 2.80
RAM - 12.0 GB

Operating System - Windows 7 64-bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Verizon FIOS, Router there latest and greatest and fastest. I have 150 GB downloading speed, actual speed while using ROON to play music was 136.6 Download and 109.6 Upload speeds.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

DAC/Streamer - TEAC NT-505
Network Connection Cat 6 from my router directly to my Streamer
NAS drive connected directly to my Router
PC connected directly to my Router
Using an Android Tablet to control ROON in the room I am listening from.

Description Of Issue

When I start up ROON on my PC were the core is stored it takes a little bit of time to load however when I then start it up on my tablet it takes way too long to load. I am using Bitedefender as my sole virus and network protection program. I have looked at its setting and it is set to allow ROON to access the web. I am not sure if there are other settings that I am missing. Windows is not using its firewall since Bitedefender is using its, I checked.

Disable Bitedefender and see if the behaviour changes.

Hi @Michael_Sharpiro,

Can you please provide some more information regarding the exact error state of the tablet? Are you suck on the “Choose your Core” screen? Is there any change in behavior with Bitdefender temporarily turned off?

I should mention that we have often found ISP-provided routers do not properly pass multicast traffic through, as noted in our Networking Best Practices. I can’t say for sure if the router is part of the issue, but it is something to keep in mind.

I tried the suggestion of turning Bitdefender off prior to loading the program, I also brought the tablet up to the desktop where ROON resides so the wifi connection was closer. This did work. Next listening session I will try turning the virus program off but running the tablet program in my music room to see if it works there also. That should isolate if it is solely the virus program or if the wifi also is adding to the issue. I doubt the wifi is an issue but just want to rule it out.

Thanks for the direction. I should probably have thought to do this prior to posting. It is nice to know people here are on top of it and actively help out.

WIFI is a connection from your wireless device to your router, not to your desktop.

I understand this and the ROON connection that was giving me trouble was not my PC connecting to ROON but my tablet. The tablet would hang up for a longer than what I felt was a normal amount of time. It would eventually connect but seemed to hang up and the program would suggest I look at various computer settings. I just want to verify that it was the virus program which was the culprit and not the wifi connection.

Hi @Michael_Shapiro,

Thanks for the update here, do let me know what the behavior is like with the antivirus turned off or if it appears to be the WiFi.

Sorry if I jumped posts, I was so excited to hear I was not alone with my issue.

I’ve turned both the virus and firewall off on both my PC and Android tablet and have no luck with the tablet loading. ROON core loads on my PC but not quickly but I can accept that since it loads but the tablet is a no go. I checked my Android phone last night and it worked fine so I am really believing that the program on the tablet must be corrupted and will reload that to see if it works.

Again I was not deliberately trying to create issue by responding to another post just giving feedback to someone who was also having issue that sounded like mine, and venting some of my frustration. Sorry if that is unacceptable.

Some additional information:
Rebooted the tablet then went down to the TEAC and unplugged and replugged the ethernet cable and this seemed to refresh and locate the room and the streamer. The list of ROON end points ??? listed shows “Enable” except for the TEAC ASIO USB Driver which says “Device Initialization Failed” however I am not connected through the USB port. I connect through the ethernet plug. Further down in the “Networked” area It shows two listings for the TEAC. One says 'ROON
ready" 192.168.1.155 and the other says “Airplay 192.168…1.155”. I disabled this one, then enabled it again with no change. The ROON Ready has the “i” symbol in light blue, when I click this it shows the Version and RAAT number as listed below:
:
TEAC NT505 info:
Version 11.1e
RAAT SDK Version - 1.1.31

I’ve turned the system on and it is streaming to the TEAC and sounds wonderful, but it took a lot of gymnastics to get it going again. What I’ve been doing is not shutting of ROON from my tablet or turning off the TEAC so it will continue to play with no issue. Once I turn the streamer off and close the program on my tablet it is hit or miss if it goes back on without a hitch.

Hope this additional info helps and I hope I am in the correct post. I am not really network savy which is one reason I chose ROON, easy to configure, so if there is additionl info or tasks I need to try to trouble shoot I will do my best. I really want to put this to bed!

Your tablet connects to your router via WIFI, not to your computer. Moving your tablet closer to your computer does nothing.

People are really difficult. First my router, WiFi is next to the PC not downstairs in the music room. My house is over a 100 years old with heavy plaster walls, WiFi does not reach all rooms with equal strength, so I do believe moving the table next to the router will increase the signal strength. Another option I have tried is to plug the tablet into the PC to see if that helps the situation, which it does not seem to do.

Rather than everyone trying to nitpick how I am describing my issue and my various attempts at finding a solution please suggest another approach that I may be overlooking?

I agree, moving your tablet closer to your router should help. You could even try connecting your tablet to your router with an ethernet adapter just to see if a wired connection makes any difference. If it does, then maybe your WIFI is the problem. In that case, it could be a weak signal or interference of some sort.

I am having this same issue. It was felt that the issue might lie with the virus program so I shut it down and it loaded however it was just a fluk, I have the issue again. I’m listening to CDs now. I turned both my virus and firewall off and tried to run ROON on my Android tablet and it could not find the core. I went to the core on my main PC and it can’t find any of my remote locations including the main one in my music room. All my locations are hard wired from the router. ROON however works fine on the PC where the core is loaded. Needless to say I’m very frustrated. This has been going on for too long. It started out as very slow loads, then sporadic loading issues where the load would only occur if I turned off the machine (the PC that had the core) and then turn everything back on. The issue has been going on for months now. At first due to the sporadic nature I accepted it but in this last month I was afraid to shut ROON down because of the issue of not being able to reconnect so I contacted support, where I tried the virus suggestion, but that isn’t working so I may be force to abandone ROON and go another route for streaming. All the original fun of using ROON is gone. I dread the thought of trying to run the program now. My last try is going to be to unload the program from both my main PC and the tablet and then reload everything hoping that it is just some corrupted file(s) that may have occured during an update. Just a stab in the dark. I hate the thought of not being a ROON user but it seems I have no choice, the subscription cost is too high to be having this type of experience.

Hi @Michael_Shapiro,

Yes, it does seem like the signal strength for the tablet might be part of the cause of the issue here. I would look into adding a mesh-style network in your home if possible (Eero/Orbi), as this may boost the signal enough for the tablet to be stable in your music room. I would also suggest re-installing the Roon app to see if it helps.