Slow on new Rock

Core Machine (Operating system/System info/Roon build number)

Nuc10 i7 8Gb 250gb (NUC10i7FNH) 1.8 (build 764) stable OS Version 1.0 (build 227)stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Vodafone (isp supplied modem/router)
FTTC VDSL Vodafone broadband with Huawei 963168_HUAWEIVOX25 modem/.router (WiFi off) to Netgear Orbi MESH router (RBR50) WiFi on + Satellite set as AP.

ROCK connected to to Orbi Router via ethernet. Remote is either 3rd Gen iPad Pro or iPhone 12 Pro. (both latest OS)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Usual end point is auralic Aries G1 (firmware 7.3.1) feeding Chord Hugo2 to Musical Fidelity KW500 amp. Aurialic connected via ethernet from Orbi satellite access point.

Description Of Issue

System is slow to find and start tracks - often >10 seconds, particularly when from Tidal or Qobuz. Both native Apps work fine on my iPad and also very quick when using AURALiC Lightning DS to the same system outside of Roon.
Can you please suggest how I might resolve this as I’m a big fan of Roon (when it’s working)

Hi Simon,

Just a fellow user and not official support. One thing you might try is to use either or as your DNS if you are not already. If your ISP’s DNS response is slow that can impact response times.


Hi Daniel
I’m a little out of my depth here with networking so please forgive my ignorance. My DNS appears to be set to “automatic” at the moment. Are you suggesting I switch this to set manually to
Many thanks

I should add I’ve ordered a standalone modem ( DrayTek Vigor 130 ADSL & VDSL2) that I’ll use with the Orbi router in the hope this might help too (the modem I’m using currently is a modem/router and I’m told may be a problem?)

Hi @Simon_Dewar

Do you experience the same delay if playing to the output of your iPad remote in Roon?

As Rugby suggested above, using Google DNS is definitely worth trying! You’d want to set Google DNS in the DNS settings of your Orbi router.

Hi Dylan
Yes just the same. I’ve just been installing a new standalone modem tonight and linked to my Orbi router (now set as a router not an AP). So far it seems to be behaving much better. Thanks for sharing the Google DNS information- very helpful for a networking novice like me. I shall try that tomorrow - but as it’s working well now, I’m going to spend this evening listening to the new Nick Cave album :blush:
Thanks again for the help