Slow or no response loading album and artist information making roon unusable

Roon Core Machine


Networking Gear & Setup Details

Netgear network gear

Connected Audio Devices

Lindeman limetree
Linn sneaky ds

Number of Tracks in Library


Description of Issue

I am getting a lot of errors loading albums and album information,

I am not sure why. It has only been happening today.

This is still happening on day 2 and is to the extent that wherever I try to go through to an artist from the album I am left sitting on a loading screen indefinitely.

Have you rebooted everything from the network outward?

Yes, no joy unfortunately,

That error message says “network timeout”. Can you describe your network setup in more detail (e.g. what router(s) and switch(es) you have, and whether you are using a wifi Mesh? Thanks.

I am getting this if it helps.

That also says there may be a network issue (Roon having trouble connecting with servers), so more info on your network would be helpful.

So running RAX200 router with virgin modem and virgin cable supply. Router is hard wired into access point and then hard wired to QNAP. Not sure what else you need.

Is your RAX200 in bridge mode, or is it running a separate subnet from the Virgin modem/router?

The virgin is purely acting as the modem for the cable internet and RAX200 is the router. I have a seperate access point.

Although I am no expert and not sure I fully follow the question

This is absolutely destroying me. I have rest my NAS settings and it just about destroyed roon completely but I am now back to where I was. I have looked at network settings, I have reinstalled roon. I have reset every device I could and still no joy. This is starting to get me very stressed. Any help or troubleshooting ideas would be appreciated.

Sorry, could you clarify what you mean by this? You have the Virgin modem (I thought these were combined modem/routers?), the RAX200 router, and an access point (what is this?)?

To be clear I really appreciate your support on this so before I answer the question can I just take the time to say thanks.

The virgin router has the ability to put it into modem mode so you can use another router. That is what I have done.

I moved my NAS to be connected directly to the router (the netgear previously listed) and have had some small improvement. The metadata issue on the picture above has resolved itself. However, the slow loading is still happening. My library loads pretty quickly it is when I look at albums and artists not currently in my library it can take forever. It seems to hang one in every 2 or 3 times.

OK, so the situation is that your RAX200 is your DHCP server handing out IP addresses over the wired ethernet connections and wifi to your connected devices. You now have your NAS (which also hosts the Roon Core) with a wired connection to your RAX200. It looks as though you are using an iPad or a tablet running Roon Remote and connecting via wifi to your Core. Is this this situation? Thanks.

Yes but also used windows laptop, iPhone and android device for the remote today.

All on wifi?

Yes. Although just trying the android and something very odd is happening.

Will update when I have tried some basis problem solving.

Roon core is dropping in and out on Android.

Getting same core appearing twice and keeps on flicking between initialising and ready on the 2nd. Feel like something is fairly seriously wrong.

It has also been happening to me as well for the last day or so. I’m also with virgin media.

Something very odd - with the network, I think. Best to wait for @support to pull some logs I suggest.