Small pauses/dropouts when upsampling - ROCK Roon 1.7

Core Machine (Operating system/System info/Roon build number)

ROCK on Intel NUC6i5, latest build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Network: ethernet, Tp-link WDR4300 + gigabit switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Audio chain: ROCK (USB storage 2TB SSD) -> USB cable (Wireworld Chroma 8) ->Chord 2Qute -> Primaluna Dialogue Premium HP

Description Of Issue

Like topic title says: I experience random small pauses/dropouts when upsampling. Things started after I moved my library to ROCK. Because it was about the same moment when Roon was updated to 1.7 version it’s hard to say that problem is related.
Things I have done already:

  1. Changed router - nothing helped
  2. Changed USB cable
  3. Tried different upsampling approache (PCM power of 2, max PCM, DSD 64, DSD 128, multithread on/off)
  4. Both Tidal and local files are affected

Previously none of my configurations resulted this issue (most of them included some kind of dedicated network endpoint from dedicated NUC, through Cubox to USBridge).
Anyone experienced same behaviour?

Hi @Sebastian_Ptak,

Just to confirm, when you have up-sampling turned off, do you experience this behavior at all?

Have you seen this issue occur on any other zones or has it been just on the Chord 2Qute zone so far?

Have you tried rebooting ROCK and your audio zones yet? If you haven’t this is also a good troubleshooting step.

If by dropouts you mean short intermittent pops, then yes I get those both local and on Qobuz.

I don’t use ROCK and I don’t upsample.

Started happening about a couple weeks ago.

No, not at all.

I use only this zone for serious listening (my sonos beam doesn’t count :grinning:)

Many times. I work in IT industry (and watched „IT crowd”). I always start with „turn off/on” solution first.

Hi @Sebastian_Ptak,

Thanks for confirming that info/trying the reboot. When you attempt to play upsampled content to this zone, what does the Signal Path look like? Can you share a screenshot?

Hi @noris
Signal path:

And upsampling settings:

As there is no volume levelling shown in your signal path you might run into clipping problems. While I don’t know if this is the source for your pauses/dropouts, it’s something we users usually don’t want to happen. See also DSP Engine: Headroom Management.

Hi @Sebastian_Ptak,

Thanks for sharing those screenshots. I was worried about the processing speed, but that looks to be 5x, so that’s ok in that regard.

Could you try performing upsampling on one of your other zones? Even if you are upsampling a 44.1kHz file to 48/96kHz it would be interesting to note if upsampling causes this behavior for all types of zones.

After 2 hours playback - not a single dropout.
Signal path (through HDMI, to Marantz NR1607) and upsampling settings:

Hi @Sebastian_Ptak,

Thanks for trying upsampling on a different zone. With this information, we can conclude that just the Chord 2Qute zone is affected, and as such we should troubleshoot further in this direction. Some thoughts:

  1. Are you using the newest firmware on the 2Qute?

  2. If you use the previous PC as the Core and ROCK just as a Roon Bridge, does the same behavior occur when the 2Qute is connected to ROCK?

Ad.1 I believe 2Qute does not have a firmware update at all.

Ad. 2 i use ROCK on NUC6I5 as Core and Bridge (direct connection to DAC). Previously I used Allo USBridge as endpoint.

Tomorrow I will test different USB cable.
BTW, yesterday I moved my library from USB attached 2TB SSD to internal 2TB SSD. No change.

This droputs are not so frequent. At first I thought it’s some kind of network related problem but this shouldn’t affect playback in my case, right?

Hi, definitely not a headroom problem. According to your advice, I switched on thisoption (level -6, This wassuitable when I useed room correction). Problem still occurs, no clipping indicator

UPDATE: problem still occurs. It really seems to be random, but my sixth sense tell me it’s network related. I don’t if it’s really possible when my DAC is connected directly to my ROCK core. I have mesh network (remember that my ROCK is wired connected), tp-link Deco M4. Is it possible that my wireless network in some weird way affects my LAN network and my ROCK? It sounds stupid, but may it be this kind of problem? Today for a few hours I had no droput, than my family (and theirdevices :slight_smile:) came back home and problems re-appeared.

I even decided today to purchase Chord Qutest to check wheter this is DAC related or not.

Hi @Sebastian_Ptak,

It’s possible that this is a networking issue, sure. If there’s not enough bandwidth, dropouts can occur, as well as due to any of these other reasons . I have two follow-up tests for you to clarify:

Can you try plugging ROCK directly into the router, bypassing the switch?

Can you give this a try? To clarify, on the PC you need to:

  • Go to Roon Settings -> General -> Disconnect
  • On the “Choose your Core” screen, press “Use this PC”.
  • Then have the Chord 2Qute connected to ROCK
  • Enable it in Roon Settings -> Audio
  • Verify if the same issue occurs with the PC hosting the Core and the ROCK being the bridge

it will be very, very hard to proceed because of the network layout. I’ll try, but not in the first step.

Hmm, maybe it’s my English, but I thought I described precisely my setup. My 2Qute IS connected to ROCK. Directly. My ROCK (Intel NUC) is both my core and endpoint. No other PC/SBC in my chain is present (except my iPad as Control).

These small pauses seem to me random (or I can’t reproduce the cause of course). Yesterday first pause happened after 2 hours of listening.

Hi @Sebastian_Ptak,

Yes, I understood this part. What I am asking here is if you keep the 2Qute connected to ROCK (in the same way it is now), but have the Roon Core on your PC instead of ROCK (and ROCK just facilitates the connection to the DAC), does the same issue still occur?

Once you switch to the PC, the ROCK and devices connected to ROCK should still be visible in the Roon Settings -> Audio tab. My goal here is to understand if the PC acting as a Core exhibits the same behavior when ROCK is just a Roon Bridge instead of the full Core, does that make sense?

Absolutely. Now everything’s clear.
Right now I’m testing new DAC (Chord Qutest) to check whether it is DAC related or not.
But as I wrote above - sometimes it takes few hours for the problem to occur.

1 Like

Time for update:
My setup right now:

  • ROCK as Core —> USB Audioquest Pearl (instead of Wireworld) -> Chord Qutest
  • upsampling: power of 2 (PCM)
  • no headroom
    So far, so good.
    Obvious answer is that probmlem was either USB cable or 2Qute.
    But maybe (maybe!) my Sonos Connect caused some trouble. I started logging my network and occured that my Connect (wifi connected) caused a lot of network errors. I changed wifi to ethernet connection and voila! No dropouts.

And at the end I decided to uninstall Roon Extension Manager from my Raspberry Pi. I mention this beacuse I think that the whole problem was network related. Maybe it was Sonos Connect affecting network. Maybe it was Roon Extension Manager installed on Raspberry Pi to serve my ROCK (BTW any news about extension api on ROCK?).
@noris I believe we can close this topic. If the dropouts re-occur, we can reopen this topic, right?

1 Like

Hi @Sebastian_Ptak,

Thanks for the update. I would suspect the USB cable or the DAC as you noted, I don’t believe the Sonos would have caused this behavior. In either case, I will go ahead and close this topic as requested, if the issue re-occurs feel free to open a new thread and reference this one and we can merge + re-open if needed. Until next time, take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.