'Software update required' but am on latest versions

Core Machine (Operating system/System info/Roon build number)


Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

British Telecom router, hardwired to ethernet switch in kit rack, then to endpoints

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Various - GoldNote DS-10, Pro-ject Stream Box S2 Ultra. Allo Boss

Description Of Issue

Roon telling me I need to update the software - Metadata Improver mentioned. But I’m on the latest versions. See screenshots. I think but am not sure it’s been like this since the recent update. Everything is playing fine so it’s probably just a minor bug. Best to make you aware of it though

Just realised new albums I’m adding from Qobuz / Tidal don’t have much metadata, certainly not album art. Which also helps time stamp the problem - the first occurence was 4th March - Valentina Nafornita, Romance. But I can play them.

Also, might the problem have anything to do with me messing up and letting my subscription lapse about the same time. Sorted within a day…

Edit - Ah, now I have problems. Roon won’t open on my phone any more. I tried to open one of the albums without metadata and it crashed it. Tried to re-open Roon but it crashes as it gets to the first screen. Phone is LGV30 running Android 8.0.0. My Windows 10 laptop works fine.

I’ve just read the posts about problems with Android devices so maybe my issue sare related. Although an LG V30 isn’t that old…over to you guys. Thanks

Hi @Phil_Wright,

There is currently an issue with Android devices opening up albums without artwork. The team is working on testing a fix for this currently and we hope to have it available in the near future. Typically a reinstall of the app or a clearing of the device’s cache will resolve for now.

Is there any change after a reboot of the Core machine for this?


Reinstalling the android control app unfroze it. Still won’t play albums with no artwork. It’s also lost some of my bookmarks (they’re still there on Windows)

Reinstalling it caused my phone to go into apoplexy though - I deleted the app then went to the app store where it said to enable rather than download the app, impying it was still on my phone. Then the phone froze for two minutes. It’s alright now, just saying in case it helps with the analysis.

Re the core - rebooting ROCK hasn’t solved the problem. Indeed rebooting was problematic - I got a message that rebooting had failed. I just tried again and it worked, albeit took a long time to load. Now two of the new albums have artwork but nothing else

Let me know if you need any more info


Edit 20 mins later…

I now have all artwork on both mobile and desktop versions. The core is also no longer processing anything. My assumption would be that something slowed the core down considerably from processing new adds, which had a knock on impact elsewhere. But I’m not the expert :slight_smile:

Oh and the bookmarks were all there on the mobile app, just in a different order


The problem are back. No metadata on new albums added from Qobuz or Tidal, I’m also getting the same error message as in my original post. Only difference is that trying to open a new album in Android app doesn’t crash it. I’ve reinstalled Roon remote and rebooted Rock - no difference.

I know there’s been an update since but it feels like these are the same issues from before that, related to the original ‘problem’ release. What’s your feeling?

Oh and best wishes with the whole coronavirus thing - where abouts are you based, countries are handling markedly differently


Edit - I’ve just had a thought. Isn’t the core of the problem something to do with old Android devices not being able to handle the graphics requirements? Not an iusse for me as my LG V30 should be fine. My Synology NAS however is old - old enough that it can’t take OS updates any more. Might that be the problem?

Hi @Phil_Wright,

Sorry to hear that the issue has returned! I’ve enabled diagnostics on your account so our team can take a look. Would you also kindly use the directions found here and send us over a set of logs using a shared Dropbox link?

Remotes shouldn’t be an issue in this case. There were some issues with Android and other devices with older GPUs that came out of last release due to Open GL incompatibilities on older devices, but that wouldn’t be related to this issue. This has something to do with the Core’s connection to our servers and hopefully the diagnostics and logs will shed some light on what that might be.

Same to you — I’m in Ohio and things are slowly but surely shutting down bit by bit. Stay safe out there!

I had this same issue the other day. I restarted roon and it was gone. Weird.

Will do. I’m running Rock on an NUC. The instructions say to shut down Roon before accessing the logs. Does that mean make sure you’re not playing anything - I’m not sure how to shut down Roon on Rock without powering the whole thing off (says he desperately hoping that’s not a stupid statement).

@dylan I’d previously re-booted Rock. This time I restarted Roon, and like Neil it’s solved the problem. Albeit the album art took a while to load. I presume there’s no point in sending logs now…but if it happens again …


Use the Web Admin page - click the down arrow on the “Restart” button in the Roon Server server section and choose “Stop”

Got it, thanks Geoff

Hi @Phil_Wright,

Please do send the logs still if you have them available. I’ll have the team take a look and if you do see this issue occur again please let us know as well.

I didn’t get them. Should it happen again I’ll send them over. Thanks for your help

1 Like


It’s happening again. I’m getting the same error message as at the top of this post. I’ve got the logs zipped up on my Google Drive, link here

Let me know if you guys see anything please. Roon is still playing fine, there’s just no metadata. So it’s not a priority problem, particularly given the current circumstances.

Cheers, Phil

I had this with my Rock. I did full reinstall of the OS and cleared out Roons Cache and it’s been ok since.

Thanks, useful to know (if not what I wanted to hear!)

Let’s see what Dylan finds in the logs, if needs be I’ll refresh everything


@dylan I rebooted Rock and after about 2 mins all the metadata was there. The re-boot was at 15.50 on GMT 30/4 if that helps with analysis of the problem

Hi @Phil_Wright,

I met with my team to discuss this morning. We are seeing errors in your logs, but they don’t seem to be related to server issues occurring on our end. What we are seeing is that something in your environment appears to be blocking the connection to our servers which is triggering this error to occur.

It’s hard to say exactly what that might be just yet. We’ve seen a couple similar reports of this type of behavior, but none that appear as frequently as what you’re seeing. Have you noticed any patterns in when this behavior occurs? Is there anything that stands out about what might make your setup different than others?

The next time this happens, another test that would be interesting — Does this behavior occur if you switch Core machines temporarily? Does it affect all devices on the network or just the ROCK Core?



Thanks for the feedback. I have a sneaking suspicion…I have one of those VOIP signal boosters in the house as my mobile signal isn’t brilliant here, but it seems to be causing more problems than it solves. And having just switched it off at least one of those problems is fixed. I’ll leave it off and see if that helps…watch this space (but don’t hold your breath!)


1 Like

I’ve been having the same issues on both my iMac and MacBook Pro, both running Catalina, both set up to be the Core. I’ve checked to make sure the firewall is open for Roon on both, and it is. My Roon remotes work fine, an iPhone and iPad. (Obviously an Apple household.) I’ve reinstalled the Core on both.

I’m not in a position to send all the information you need. I’ll do so so when I get back home. This has been going on even before upgrading to Catalina on these systems, so I’m assuming it has something to do with a connection to your servers.