Some Albums have all of their tracks "skipped" when played

CyberPowerPC - Desktop - Intel Core i7 - 16GB Memory - 2TB Hard Drive + 250GB Solid State - OS: Windows 10.
Backup: 2TB Western Digital Passport external hard drive.
Roon Version 1.7 (Build 521)

There are 11,558 Tracks and 745 Albums
All music files are WAV formated and were converted from their CD discs by the dBpoweramp utility CD Ripper.

Entire music/entertainment network is Ethernet.

Yamaha CX-A5200 (via AirPlay)

This problem happened when I was playing music on my computer (see above) that houses the Roon Core .

Recently, when I tried to play the Playlist of the artist, Jason Isbell, I hit the Play Now button, and Roon would stop briefly at each track and then move on until every track was visited but not played. Another example: Loreena McKennitt . All of the tracks in her Playlist were skipped. When I played my Darrell Scott Playlist, certain Albums in the list played and others did not. Other artists, such as Alison Krauss , had tracks played from every Album.
All of these Albums have played perfectly in the past.

The problem seems to be Album-centric : either all tracks on an Album play, or none of the tracks play.

As a test, I had Roon scan my backup drive for my Jason Isbell Albums. When they appeared on the Albums list, every Album I tried to play exhibited the same “skipping” behavior for every track.

I also edited several Albums in order to Re Scan, Re Identify, and Re Analyze. There was no improvement.

Finally, I randomly picked Albums and tried to play them: some played and some did not.

Note: I seem to remember something similar happening a few years ago - but I cannot be certain, and I have no memory of any solution.

Thank you for your help in this matter.

Have you tried rebooting the PC with the RoonCore?

You need to update the Roon Version to B528 unless thats a typo - While that might not help, you should always have roon at the latest build.

Hi @William_Stripling,

Let’s try rebooting and updating the Core machine and let us know if you’re still seeing this issue after that.


I updated to latest build and rebooted my PC, but my problem still persists.

Thanks for giving that a go, @William_Stripling.

Moving forward, let’s focus on a specific example of what you’re seeing. Can you share a screenshot of one of these albums?


I have a screen recording that illustrates what happens when I try to play certain albums (but not others) by a single artist. However, the Upload function will not accept a mp4 file.

I don’t see how a screenshot can illustrate my problem, unless there are some specific album data you want me to access and pass along.

Is there any way I can get the mp4 file to you?


Hi @William_Stripling,

A video is even better :slight_smile:

You can upload the video to us here:


Did you receive the screen recording file “ROON_TEST.mp4?”


@dylan ,

Did you receive the mp4 file I uploaded to you??

I tried to resend it, but the URL you gave me is no longer available.

My problem persists.

Thanks, :worried:

Hi @William_Stripling,

Apologies for the delay here!

Yes, we received the video and we also tried to enable diagnostics on your account, but it doesn’t look like the report came through. Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link?


Try this link:

Did the Dropbox link work?


Dylan !!!

Did you get the logs??? :confounded:

Hi William, no need to worry. I am sure @dylan will be around soon.

Hi @William_Stripling,

Please accept the apologies for the delay here. I have been out of the office for a bit but I checked in with the QA team who was investigating your report and have the feedback from the log analysis.

The team looked into some of the examples of where things were failing and they found many traces like the following:

04/18 10:05:16 Info: [GTX-SYS OUT] [zoneplayer]     Open Result (Playing):Result[Status=Success]
04/18 10:05:16 Info: [GTX-SYS OUT] [zoneplayer] Starting playback
04/18 10:05:16 Trace: [GTX-SYS OUT] [zoneplayer/raat] StartStream Sooloos.Broker.Transport.RaatZonePlayer+Endpoint: StreamFormat(channels=6, bitspersample=16, samplerate=96000, isdts=False) => StreamFormat(channels=8, bitspersample=16, samplerate=96000, isdts=False) streamid=1610651028
04/18 10:05:16 Trace: [System Output] [raatclient] SENT [8]{"request":"setup","format":{"sample_type":"pcm","sample_rate":96000,"bits_per_sample":16,"channels":8,"sample_subtype":"none"}}
04/18 10:05:16 Info: [GTX-SYS OUT] [zoneplayer] Open result (Queueing): Result[Status=Success]
04/18 10:05:16 Info: [zone GTX-SYS OUT] OnPlayFeedback Playing
04/18 10:05:16 Trace: [GTX-SYS OUT] [Inactive] [PLAYING @ 0:00] Tupelo - Jason Isbell and the 400 Unit
04/18 10:05:16 Trace: [System Output] [raatclient] GOT [8] {"status":"UnexpectedError","message":"RAAT__OUTPUT_PLUGIN_STATUS_FORMAT_NOT_SUPPORTED"}
04/18 10:05:16 Warn: [GTX-SYS OUT] [zoneplayer/raat] failed to setup any up
04/18 10:05:16 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
04/18 10:05:16 Info: sleep 0ms after flush
04/18 10:05:16 Warn: Track Stopped Due to Error

Generally speaking, this error means that Roon was unable to properly communicate with the audio device at the time of playback. In most of the examples we saw you were playing to the GTX System Output — Just to confirm, does this also happen with the Oppo?

Moving forward, I’d like to take a closer look at one of the albums that you’re having trouble playing. We’ll give this album a test in our QA labs to see if anything specific about these albums might be tripping up playback.

Can you share the The Nashville Sound album with us here?



The GTX-SYS OUT refers to the desktop computer housing the Roon Core. I am not familiar with “System Output” or “audio/env.”

Since I developed this problem, I have not played any music through the OPPO, but I will test it in a minute.

I’ve sent you a copy of “The Nashville Sound.”

Well, I just finished playing music through the OPPO 205 and all of the albums that were problematic on the desktop played without error on our home theater system – the house is wired for Ethernet.

Perhaps this news will make my problem easier to solve???

I appreciate your perseverance!

Thanks for testing with the Oppo, @William_Stripling!

Since things are working okay with the Oppo, we can safely assume that it is likely something to do with playback to the GTX-SYS OUT that is causing the problem — Can you share a screenshot of Device Setup for this? If you uninstall and reinstall the audio drivers is there any change?

I reinstalled the sound drivers on my PC, and . . .SUCCESS !!!

Dylan, I am very grateful to you and your colleagues for the guidance, patience and perseverance throughout the life of this problem.

I thank you all.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.