Some albums never appear when stored on SMB

Roon Core Machine

Ubuntu 20.04, currently assigned 4GB of RAM and 4 cores (easy enough to upgrade)

Networking Gear & Setup Details

Roon core running as virtual machine, music storage also running VM with SMB share on same host (therefore networking backbone all virtualised on same machine).

Connected Audio Devices

A&K CA1000 is my Roon Ready primary device.

Number of Tracks in Library


Description of Issue

I’ve noticed a number of albums randomly don’t show up when living on SMB shares. I.e. I stored one album on network drive, and mapped it in Roon as SMB share. It didn’t show up at all. Then I trIed copied + pasting it in case it was a file modification time thing (still didn’t show up). I then switch from SMB mounted in Roon to SMB mounted in host OS (and Roon pointing to it as a host OS folder) and the album showed up. However, after importing a few more albums, a further 3 didn’t show up. If I add a completely local folder (i.e. one living on the disk of the virtual machine that Roon lives on) each/all of the missing albums appears in Roon.

I would prefer to have the albums living on the SMB share however, as this is backed up already and backed by ZFS snapshots, so I don’t really want to have to move them over to another location - I’d prefer to find the root cause of the original issue.

I couldn’t see any failures in /var/roon/RoonServer/Logs/RoonServer_Log.txt - not sure what else I should be looking :slight_smile:

This appears to happen occasionally (& annoyingly) on most systems but in my case (Win11) i just force a rescan and missing item are usually found.

Thanks for the suggestion, but annoyingly no amount of rescan resolves it :frowning:

Any chance it’s a file permissions issue? Or any special characters in the file/folder names?

Any chance it’s a too small inotify/max_user_watches?

Something else? Anyway:

None of this is supported.

Did you already look into the usual places (system logs, Roon logs)?

Permissions are squashed to be the same on all folders/everything on the share, so not permissions issue in this case, and filename characters are all standard English keyboard characters in this case. Even metadata is free of special characters - so unfortunately doesn’t appear to be any of these issues either.

I did increase the limit to 50,000, but only 3 are in use at the moment anyways, so not the inotify issue.

I understand none of that is explicitly supported, but the “Installing Roon on Linux” page only lists package with Ubuntu or Arch server requirement, and doesn’t specifically speak to architecture beyond that. Given a virtualised machine shouldn’t affect the software in any tangible way, I didn’t feel that would be the source of the issue - however, I’m not going to blame Roon etc if it doesn’t work. I’d just like to get it working if I can :slight_smile:

None of the usual logs seem to offer anything I can find living under /var/roon/RoonServer or the standard syslog, but is there a specific Roon system log you think more likely to show detail? I’ve tail -f’d some of them whilst manually scanning, but I’ll have another look if you think there’s a likely culprit :slight_smile:

Why? If you don’t have or want to run a NAS then why not just store the music in the same VM that Roon is installed on? Why use a VM as a NAS?

I have a NAS, it’s just that the NAS is also a VM - no need to double up on resources that way. I wanted to use ZFS but not many dedicated NAS’s support that, so I built a VM and passed through the HDD’s for storage direct to it. So the brains of the NAS are running the VM but the storage hardware is unvirtualised. I don’t have the funds to buy 2 different servers just for the sake of not running the NAS host virtualised (given it still behaves functionally the same either way).

Edit: Just to clarify, the NAS/storage VM is not only for music, I store a lot of other things on there too, hence not wanting to split it up if I can avoid it.

So you are using an actual NAS device (like a Synology or QNAP?) as the host with your Roon vm and “NAS” vm sitting on top of that?

Nah, it’s basically:

  • ESXi server running as the VM host
  • Ubuntu Server as guest running only Roon server software, nothing else
  • TrueNAS guest running as the “NAS” only, serving up a number of shares, including Music

Ok, the picture is getting clearer.

What does your your Roon > Settings > Storage look like? Are these troublesome albums showing up as skipped in Roon > Settings > Library > Skipped files?

None of this write-up makes much sense to me – maybe important parts about your setup are still left out? Anyway, this is still the section of the forum for official support. Maybe you can simplify your setup (get rid of all the unsupported VM’s and the virtualised networking backbone) so we’re down to a supported setup and can go from there?

Note: Many users use supported setups and there is usually no real issue with them (Roon is reliably able to detect new files). To me, your issue sounds like some self-inflicted problem with the overly complicated setup. If you wish to troubleshoot your current setup, you may have to share more details but I feel this is better done in the tinkering section of the forum – or another forum completely that offers support for the virtualization solution you’ve chosen.

1 Like

So the storage currently looks like:


Which is a folder I manually mounted in /etc/fstab from the SMB share. However, I’ve previously had Roon browsing the SMB share directly:

Screen Shot 2022-09-05 at 10.03.33 am

This was less successful than the /etc/fstab mounted method, hence the switch.

No files have been classed as skipped however:

I’m sorry, I didn’t realise that this was an official support channel - I thought the “community” subdomain indicated community support, and that official support would be elsewhere. I’ll refrain from furthering the topic. Thanks for your reply

If you want to move your thread over to the tinkering section, you can do so by editing it’s title (this allows you to change the forum section).

Thanks, been many years since I’ve been on forums (at which time only admins could move threads)

Moved :slight_smile:

1 Like

As far as I know about ZFS, 8GB of RAM is listed as bare minimum. As I just visited the QNAP website today, they write that if one wishes to enable further enhanced ZFS features (de-duplication, jadda, jadda, …) 32GB and more are recommended (all this just for ZFS, without the additional needs for running VM’s and so on). Is your installation possibly just running out of resources to properly work?
ZFS, as I understood at a glance, is also strong in snapshots. Can it be, maybe through a setup mistake, that your storage VM is operating on a read-only snapshot, newer data added to an overlay (another snapshot) not being seen by the VM (and in last consequence Roon)?

I had to use fstab mounts to avoid dropouts when I first started using Roon 1.5+ yrs ago. My (small) local library is on a separate physical box though (Synology). My core is Ubuntu 22.04.1 Server.

Unfortunately, I don’t know anything about TrueNAS or ESXi so this is where the road ends for me.

The ZFS virtual machine runs with 16GB of RAM currently (separate to the Roon virtual machine), and deduplication/compression/etc is turned off. Utilisation on the ZFS machine is currently less than assigned RAM in this case anyway, so I don’t think it’s resource exhaustion issue.

Snapshots are definitely on, however, the VM is not operating on a snapshot (in that I can/have been using to import data into that share for this testing, so I can confirm I can write data to it, and 80% of imported albums are showing up). Hope that makes sense?