Some audio players not shown in player selection menu (1.8 build 880) [Fixed in build 882]

For me, as far as I went with my analyzis, the problem is only with the Sonos devices. The problem occurs when I activate more than 7 Sonos devices. If I activate only 7 Sonos and all the other devices, they are all shown. If I activate more than 7 Sonos, there are some audio outputs not shown (it can be the Sonos but I can be others too)

And @Eamonn_Maher has also the same problem. He did an analysis of the logs, and it seems to confirm this issue with the Sonos. The workaround seems to work for him also

Hi @Ivan - some analysis on what sounds like the same issue over on the Beta section

1 Like

@ivan @Eamonn_Maher : same problem here too I guess :

1 Like

Thank you, @Eamonn_Maher, I contacted you via Private Message.

@Mr_Smys, yes, unfortunately, it sounds like a similar problem, we are investigating this issue at the moment. I will post an update as soon as I have any consistent result.

Apologies for inconvenience.


Similar issue here. Thanks, just wanted to subscribe and add my data points.

Hi, @Mr_Smys , @Eamonn_Maher , @Jed_Krohnfeldt , @Scott_Butler , we were able to track this issue down and put a ticket for our dev team. I hope they will be able to find a solution soon.

Sorry for troubles.



Only showing Sonos output devices for us at a showroom. We have many devices that are enabled in settings, but again, only Sonos devices are listed.

Same here. Only seeing Sonos devices.

Realised, I could only see 7 Sonos devices, and I have 11.

Disabled some for now, and the missing devices have returned, and work.


Same issue here. Nucleus+ device, Roon Version 1.8 (build 880). Only my Sonos devices, Marantz and Denon Receiver can be selected, but neither My BluOS, Lumin, Ayon or Auralic Streamers. I never had this issue before. All devices are visible in the settings but don’t appear in the list of selectable devices.
Ok, workaround with taking out some of my Sonos players fixed the problem, however a fix would be highly appreciated.


Can confirm issue seems to be when enabling 7 Sonos devices, once you exceed 6, all other devices drop off, in my case 10 + but all Sonos devices shown
Please advise on ETA of fix

Added sonos devices that I disabled by Airplay in the short term

Thanks for confirming the work around works, @Nicholas_Guy. Our team is currently working on a fix.

Please, bear with us :bear:

1 Like

Hey everyone :wave:,

Our team has listened to the feedback, investigated and just released build 882 that should resolve this. Would you please update your Cores and let us know if this is fixed for you?

1 Like

All working for me. 9 Sonos zones & 4 Ropieee.

Reactivated the 3 Sonos zones that I had deactivated once I figured out the issue. Fabulous, thanks for the responsiveness. All working as planned, really appreciate the hustle to get this out before the weekend.



confirmed that build 882 resolves this issue - looks like ports 30000 and above and being used for those Sonos devices. Many thanks to Roon for the fix!

Hello, build 882 solved the problem for me also. Many thanks

1 Like

The guidance says not to post replies after the issue has been solved, but since I initiated the thread I just had to send a quick and very grateful thank you to your team. The 882 update is working for me and I successfully re-enabled all of my devices. Thanks for the concern and responsiveness to resolve this issue, as well as others.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.