Some audio players not shown in player selection menu (1.8 build 880) [Fixed in build 882]

Roon Core Machine

Intel NUC 8 i7

Networking Gear & Setup Details

SonicWall firewall connected to cable modem. Supports all internal networking - DHCP, gateway. No fancy routing or subnets.

Connected Audio Devices

PS Audio DS Jr. DAC
2- Bluesound - node 2i, pulse mini 2i
KEF LSX
8- Sonos v2 audio devices

Number of Tracks in Library

81,000

Description of Issue

Just upgraded to 1.8 build 880. All of my audio devices are visible & enabled in Setup->Audio. However, not all are shown in the player selection menu on the main page of the app. I have tried multiple reboots, in which case different subsets often show up. A few times, I got the rebuilding database message after a reboot, which is also strange. If I disable all audio devices, reboot, and then re-enable them one by one, I can only add 10 before it completely stops adding them. This issue is new to build 880. Thanks.

Jed

What remotes are you using?

HI, @ged_hickman1, if I understand what you are asking, I am using apps on iPhone, iPad, and iMac, all with latest OS. All have the same behavior - the audio device selection menu shows a subset of what is actually enabled in Setup->Audio. Thanks.

Are they also updated to 880?

Yes, everything was updated at the same time. Sorry I should have stated that.

Also, if I select Group, the missing devices show up as choices there and I can group them with others. But once I remove them from the group, they are no longer visible in the main audio device selection list.

Are they all on with the Roon app running on each?

This sport of issue could be cleared by deleting the roon cache. There is a folder under the roon application directory. Worth a try.

@Jim_F, all of my audio devices are on and network accessible. The iOS and iMac are just Roon Remotes.

@ged_hickman1, there is a fair amount of content under Cache. I am a bit hesitant to delete all of this, except possibly devicedb*. Perhaps Roon Support can give guidance. Thanks.

image

Hi, @Jed_Krohnfeldt, thank you for the report. I am sorry to hear about the troubles you are seeing not the latest Stable build. We are going to investigate this behaviour. Could you, please, try to perform the following steps:

  • Reboot RoonServer. Please, remember timestamp when it was done and post it in your follow up to this message
  • Disable all audio devices
  • Enable them one by one until number reaches 10
  • Please, remember timestamp when it was done and post it in your follow up to this message
  • Enable one more zone. It won’t appear in the Zone Picker
  • Collect logs and send to us

These logs will provide us more info about the issue which is happening on your system.

Thanks!


Ivan

I sent you the logs. Thank you.

I’ve got the same thing, running ROCK, some Sonos are showing up, but nothing else. 2 Ropieee and a DAC connected to my iMac show up in settings, but not the selection list. My phone (also updated) also doesn’t show up as a player when I go in there. Same list of apps show up, I’ve tried viewing on 3 computers and a phone so far. Haven’t yet tried any troubleshooting, just wanted to chime in with a “me too”,

Hi @Travis_Holland, just to clarify if your symptom matches mine. Are all of your devices showing up under Setup->Audio, but only a subset of enabled ones showing up on the Player selection menu? This is what I am seeing.

Also, good catch. My phone (iPhone 13 Pro) is also not showing up as a player. It seems that after I add 10 players, nothing else that I enable will show up in the menu. I submitted some logs, let’s see if they come up with anything.

Yes, exact same symptoms. In settings under audio I can see all my devices properly and even added one. It’s only when I go to actually select them in the bottom right corner that I only see some, which in my case is a subset of my Sonos speakers and nothing else.

One interesting thing I noticed was that when I hit the button to group them all my Sonos speakers showed up. Before out of about 10 zones six showed up. So it’s something with just the main list that is not working. When I grouped one of the non-showing ones up it didn’t play through it. I just can’t see them on the main list, including all my non-Sonos zones.

Edit to add: I just checked, I have 7 zones show up. When I go to group them I see all 12 Sonos zones.

Having the exact same issue after updating to the latest Roon server and clients. I’m running Roon Core on an Ubuntu server, and running clients on a combination of Mac OS and iOS devices. After the update, I can only see the Sonos streaming devices in my house as well as my Matrix Audio Mini-i Pro 3. None of the “local” devices (for example, an Apogee Symphony and an Oppo BDP-105D DAC and a Spectra DAC on my MacOS devices), and none of the “This iPad / iPhone” options show in the client at all…but they’re visible and enabled when I got into settings. Help, please…this is a bummer.

Hello, I may have the same problem as you. Have you tried to limit your Sonos devices to 7 ? For me, if I activate only 7, all the devices are shown. If I activate an 8th one, there are audio outputs missing.

Based on some of the other posts here, I went in and disabled all devices and slowly started adding them back…I could get up to 11 (counting the local “private” device) before they started disappearing. Very weird bug.

For me, as far as I went with my analyzis, the problem is only with the Sonos devices. The problem occurs when I activate more than 7 Sonos devices. If I activate only 7 Sonos and all the other devices, they are all shown. If I activate more than 7 Sonos, there are some audio outputs not shown (it can be the Sonos but I can be others too)

And @Eamonn_Maher has also the same problem. He did an analysis of the logs, and it seems to confirm this issue with the Sonos. The workaround seems to work for him also

Hi @Ivan - some analysis on what sounds like the same issue over on the Beta section

https://community.roonlabs.com/t/beta-864-big-problems-with-the-audio-outputs-please-help/180665/39?u=eamonn_maher

1 Like