Some network devices missing

Roon Core Machine

MacBook Pro, early 2015
OSX Mojave
8GB RAM, 2.7GHz Core i5
Hard-wired to network by ethernet via USB (also tried wireless)
Roon is up-to-date

Networking Gear & Setup Details

TP-Link AX5400 WiFi 6 Router (Archer AX73)
Running both ethernet and wireless connections

Connected Audio Devices

  1. Ifi Zen Stream over wifi >> USB cable >> BorderPatrol DAC SEi.
  2. Macbook Air M1 over ethernet, running latest Roon (and I tried using Roon Bridge) >> USB cable >> Chord Hugo 2.

Number of Tracks in Library


Description of Issue

Roon is only showing some of my connected audio devices. I’ve tried rebooting Roon on the Core system and then I rebooted the Core system to no effect. I also restarted Roon on the Macbook Air and restarted the Ifi Zen Stream. All the devices mentioned here are on the same network subnet as my Roon Core.

What is working: Roon shows the SPDIF output of my Ifi Zen Stream. I am able to play tracks to that.

What’s not working: 1) Roon won’t display the USB output of the Ifi Zen Stream. 2) It also won’t show my Chord Hugo 2 while connected via USB to my Macbook Air. 3) And it won’t display a Shiit Eitr connected via USB to an LG USB-C monitor that’s connected via USB-C to the Macbook Air.

All of these setups were working earlier today but no longer work. I did not change anything with my network, the devices just disappeared. Roon does display my MacBook Air via Airplay, but I was unable to play tracks through it - the music failed to start when I hit play.

Restart your networking gear too…modem, router any switches, AP’s etc too

1 Like

Hey @Ryan_Hutchins so sorry that it took us a while to respond - we appreciate you reaching out to us when you encountered this.

We wanted to check in and see if you were able to connect your devices and if they’re working properly?

Completely rebooting (making sure to also unplug the devices) your Roon setup, including audio devices, Core, and router is a great first step. Were you able to try this suggestion just yet?

Thanks! :pray:t3:

Hi, thank you. I ended up migrating to a new server running Roon ROCK (not because of the issue), and I haven’t had problems this widespread since. The USB on the Zen Stream is working no problem. However, I have continued to have issues with the Eitr > Hugo 2 setup. It frequently disappears from Roon from an extended period of time. Sometimes restarting Roon works, but if it does, it requires me to go back into audio settings re-enable Eitr at an output (and give it a name). Definitely something very glitchy happening. I’d say it was related to the Eitr, but my Macbook doesn’t drop the Eitr when Roon does, so seems software related.