Song resolution doesn't display correctly on DAC

System description - MacMini for Core music source with McIntosh MX120 processor, McIntosh D150 DAC with B&W speakers.

New to Roon and really love it but notice that the song resolution/format does not update with each song during play. In our previous arrangement using Amarra instead of Roon, the D150 DAC would display each song’s resolution as we listened to songs with different audio quality. With Roon, instead the resolution is fixed at 48K regardless of the song’s actual format. The 48K being displayed is the default coming from the Apple MacMini. With Amarra this default was updated dynamically as each song was played. The music is actually playing correctly but the display does not reflect when the song is high res.

Question - is there a way to adjust the settings in Roon or in the MacMini so Roon can display the correct resolution?

Thank you

It should switch if configured correctly. Is the Mac mini in exclusive mode? Sounds to me your just getting the fixed system audio. Not a Mac user so can’t offer any other advice but it should be set in device settings in Roon to be exclusive for the output you added.

A screen print of your Signal Path when an offending track is playing might help in diagnosis.

Also, a print of your Device Setup for the device in use will help.

Are you usng any DSP?

Hi @Denise_Ross,

As suggested above, please share a screenshot of the Signal Path when you’re seeing this issue and we can take a look.


Attaching screen shots - thank you

Image 4-26-20 at 12.31 PM Screen Shot 2020-04-26 at 12.22.51 PM

I just noticed while in NEW device setup mode there is a selectable option for Exclusive that does not appear our current device setup config. Exclusive does not appear as an option to enable for our existing system output. Does this mean we need to remove and reinstall??

Here’s a pic for reference

As @CrystalGipsy said, I think your problem is that you are using the OS mixer.

I don’t speak macOs, but what are the options available for you in Settings==>Sound on your Mini?

Note - that’s Settings in macOS; not to be confused with Settings in Roon. :neutral_face:

I dusted off my Mini and connected an iFi DAC.
Here is my Settings==>Sound -

On your Mini, do you see a Device for your MacIntosh DAC? If so, select it.

The above solutionj worked for me -

That pic shows you are using System Output. You might want to try using CoreAudio, take a read of this FAQ:

Configuration options morph depending upon the abilities of the connected end point. The McIntosh can run in either mode, so, there is an Exclusive option. If an output is hardwired for a mode then the option is not shown.

For example, ASIO drivers are by definition exclusive, so no option.

Just use that one as its seeing the DAC in the McTinosh. Just disable the other and enable this one. Then your good to go.

Thank you all for the help. I changed to the Core Audio config and it is now recognizing the different formats. I can definitely hear the difference in the playback so know it’s had an effect. I don’t know if i’m optimized for other settings but will read more about them - the great news is my original issue is solved and my music sounds fantastic. thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.