SonicTransporter - Brand New - Restored Database Not Working

Hi @David_Haaf,

Thank you for uploading the backup, I’ll get this over to QA to see if they can reproduce the issue.
There is one more piece needed for testing here, I have followed up via private message.

Hi Noris,

Just sent a reply. Please confirm.

Hi @David_Haaf,

I did not see a reply from you in our private message thread, please re-send, thanks!

Hi Noris,

I just re-sent a reply. Please confirm.


Hi @David_Haaf,

Are you using email replies? If so those will not be delivered.

I sent you a private message just now, should show up as a green “1” in the top right corner on

Hi Noris,

What is the current status?

Hi @David_Haaf,

I messaged QA again regarding your case today, it is still in the review queue and we’re hoping to perform the testing soon. Thanks in advance for your patience!

Hi Noris, it has been 6 weeks - what is the delay?

Hi @David_Haaf,

Thanks for your patience here while we had a chance to look into this behavior further.

There is currently an ongoing investigation into users Core’s being logged out after reboot, and the logs from your machine initially suggested that you may also be impacted by this same issue, but upon further investigation it appears that database you have may be the issue.

Do you have another PC around the house you can try to load this database on? Can you please try to restore the database to a PC and verify if you are able to login properly on the PC when the PC is acting as a Core? To switch the Core to the PC, you can use the below instructions:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Can you please give this test a try and let me know if restoring to the PC has different behavior than restoring to the SonicTransporter?

I have done this 4 times on 3 different machines (all four 100% dedicated to run Roon, just roon nothing else)

First on my old sony vio i7 laptop last fall after it crashed, it worked great at 1st but started to slow down as I added files. This machine was my roon core from May 2018 to Jan 2020. Late last fall I did some research and landed on machine #2 QNAP 951x NAS.

Back in January I loaded the db onto my new QNAP NAS, at first it was acting very strange, roon support asked my to try an older version of my db so I went with 7/24/19 and it worked at first quite well but started to slow down to a crawl as I continued to build my library. I spent many hours on the forum and decided that I needed a new core machine so after many hours of research I landed on core machine #3 a Kingdel quad core i7.

I loaded my roon backup db in April onto my kingdel i7, it worked GREAT at first - no problems but after a short period (x weeks) it began to exhibit inconsistent performance^ ranging from working quite well, fast, reliable, stable ----- to a white screen with the spinning black logo.

a) slow (like walking in wet concrete) at times,
b) non working white screen with the spinning black logo

I finally decided I couldn’t live with it, so I decided to buy the sonictransport core machine #4 !!!
I figured this is the fastest machine built to run roon, if this doesn’t work nothing will. I was so excited the day it arrived but as you know it has been a BRICK from day 1. To make matters worse for some unknow reason the kingdel forced me to reload the db from a backup (right after I added the sonictransport to my network) so I did it because I need roon. As of today the kingdel is my daily driver: mostly reliable, at times blazingly fast, yet some days I have to fight with it to play music.

See my other post…

Roon spinning non-stop - Support - Roon Labs Community

I really need roon’s help to get the kingdel working 100% and/or the sonictransporter
I can’t tell you how frustrated I am with my ROON experience.

Please help me, I am asking for daily connection with you and your team, please do not continue to leave me wondering when I will hear from you.


Hi @David_Haaf,

Thank you for that additional information, this is helpful.

I spoke to our QA team today regarding your case and we have a few questions based on your last post, can you please let me know:

  1. If you try to restore this current database to another Core, you are able to use it for some period of time and you are not faced with the same login issue as on the SonicTransporter, is that correct?

  2. Can you please open your Roon Database Location on one of your recent restored machines and post a screenshot of your `Roon / RoonServer -> Database -> Core -> UNIQUE_CORE_ID -> broker_2.db folder? Here is an example of what it looks like on my end:

  1. Do you by any chance have any old sets of these instructions from when this issue occurred on these machines?
  1. What is the size of your library? Please list the number of tracks and albums.

Hi Noris,

Question #1 is correct

Question #2 >>

Question #3 >>>
looking for records

Question #4 >>>>

of Tracks = 420,542

of Albums = 32,579

Hi Noris,

I found one email regarding the problems with core#1 but I can’t find the rest of the tread, maybe you can find it on your end…

I started to have several major problems after the September Roon Update.

Problem #1 Track Erosion - I have re-installed the roon core twice and this is what happens once roon opens: in overview it shows; 5,798 albums , 76,895 tracks, 1,411 artists - it scans my folders for new tracks and my tracks start to erode after scanning today I now have 3,342 albums, 54,483 tracks and 695 artists

Problem #2 New Tracks Not Importing. I have added about 300 tracks to my music folders and they will not import after forcing re-scan many times. The last time I was able to import an album was 27 days ago.

Problem #3 By This Artist -
A) Some artists will not show any albums in the right hand column below “By This Artists” but there are albums in the artists music folder
B) Most artists do not show all of the albums that are in the music folder

Please let me know how to fix these problems ASAP.

I am using a Sony Vaio Laptop as my core - It is 100% dedicated to Roon. My folders are on my NAS.

Vaio Specs:
Intel Core i7 CPU
Q740 @ 1.73 GHz
6.0 GB Ram
64-bit OS
Windows 7 Home Premium
Service Pack 1
500 GB SSD 348 GB Free

NAS Specs:
Drobo FS
5 Drives = 28 TB (25.47 TB Actual)

11.59 TB Used (4.168 Roon Tracks)
7.34 TB Protection
4.40 TB Free Space
2.12 TB Unallocated Space

[Roon Labs Community] [Support] Missing Albums & Tracks after last 2 Roon Updates2



To: [Moderator edit … personal information removed]

Fri, Nov 2, 2018 at 5:08 PM

noris Roon Labs: Support
November 2

Hello @David_Haaf,

Thanks for contacting support, I’d be happy to assist here.

Can you please let me know how your are mounting your Drobo in Roon? Are you using IP address, hostname or a USB connection? How is your network set up here? Please list the model/manufacturer of your router, any switches you have and how your Core and NAS are connected to the network.

Generally speaking, when the amount of tracks erode or albums are missing such as in your case, it can be often traced back to network instability or issues with the NAS itself. One such case of the NAS itself having a failing hard drive can be found in this thread (Slow to operate and skipping a lot [Solved]).

With that said, can you please try running a disk check on your Drobo to see if there are any bad sectors? I have found these instructions from Drobo’s support site. The behavior you’re describing here would also be consistent with a damaged cable, if you have another USB or Ethernet cable to facilitate the connection to the Drobo, can you please try to replace it to see if that resolves this issue? Please let me know your findings when possible.


Hi Noris,

Core #2 Problems >>

[Roon Labs Community] [Support] Roon Not Working after Core Change2
Dylan Caudill via Roon Labs Community

To: [Moderator edit … personal information removed.]

Thu, Jan 23 at 6:47 AM
dylan Dylan Caudill Roon Labs: Manager, Technical Support
23 January

Hi @David_Haaf,

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

\ 45x45 dylan Dylan Caudill Roon Labs: Manager, Technical Support
23 January

Hi @David_Haaf,

Thank you for your patience while our team has been looking into this issue for you.

The diagnostics report was received and I reviewed it with the team. Sometimes, errors like the one you saw can be spurious, but unfortunately in this case they are seeing signs of low level corruption in your database.

This type of error is extremely rare for us and not one that we see often. Our database infrastructure is designed specifically to prevent this type of corruption, and we don’t take this class of issue lightly.

We’ve traced a few reports like this in the past to hard drive integrity issues but generally speaking, this means that Roon is reading information from your hard drive that is different from what was originally written, and the database is now unable to load properly.

What’s Next?

If you’ve been making regular backups, my advice would be to install Roon fresh on your Core machine, and roll back to one of your older backups. If the database loads properly and you don’t run into this issue, things should be good for you moving forward.

If you do not have any older backups than the one you initially restored, unfortunately, you will need to start with a fresh database.

Again, this class of issue is extremely rare for us and you have our apologies for the trouble here.

Hi Noris,

Problems with Core#3 >>>

[Roon Labs Community] [Support] Roon spinning
Arlen via Roon Labs Community

To [Moderator edit]

Thu, Oct 1 at 12:46 PM
1 October

Restarting Roon Server will probably solve your issue.

Visit Topic to respond.

In Reply To

1 October

Visit Topic to respond.

Arlen via Roon Labs Community
Sat, Oct 3 at 12:34 PM
3 October
David, have you asked @support to help you?

Visit Topic to respond.

In Reply To

2 October

I have done this 3 times, it works for a while and eventually it choke’s. Sometimes I can go a day or so - fast worry free - but most days it is a real struggle. I really want to love ROON but so far not so much. Please let me know how to get Roon to be fast and worry free. This is my 3rd core machi…

Visit Topic to respond.

To unsubscribe from these emails, click here.

Nuwriy Nienkirchen via Roon Labs Community
Tue, Oct 6 at 6:04 AM

) nuwriy Nuwriy Nienkirchen Roon Labs: Technical Support
6 October

Hello @David_Haaf, my apologies for the trouble here. Is your core connected directly to the router via Ethernet? Also, what’s the size of your library?

Visit Topic to respond.

In Reply To

2 October

I have done this 3 times, it works for a while and eventually it choke’s. Sometimes I can go a day or so - fast worry free - but most days it is a real struggle. I really want to love ROON but so far not so much. Please let me know how to get Roon to be fast and worry free. This is my 3rd core machi…

Visit Topic to respond.

Nuwriy Nienkirchen via Roon Labs Community
Mon, Oct 12 at 8:56

Hello @David_Haaf, I found your ticket with Noris and the QA team and will ask for an update, my apologies for the delay. For this issue, I’d like you to:

  • Reboot your Core machine.
  • Start up Roon and let the spinner go for ~5 minutes.
  • Reboot your Core machine once more.
  • Start up Roon and let the spinner go for another ~5 minutes.

This should allow the team to gain some insight into what you’re experiencing in the report. Once you’ve done this let me know the timestamps and I’ll enable diagnostics on your account. When the diagnostics report is uploaded I’ll send it over to our team for analysis.

Visit Topic to respond.

In Reply To

9 October

Hi Nuwriy, Core is connected directly to my router via eathernet cable My library is; 13 TB, 31,724 Albums, 405,570 Tracks Any solution yet? I have been waiting 1 month so far… Thanks, Dave

mavmcl via Roon Labs Community
Mon, Oct 19 at 3:20 PM
19 October

It just happened to me after I updated to 667, cleared tmp and Roon server cache and it got fixed, no clue where cache and tmp are in windows…

Noris via Roon Labs Community


Hi @David_Haaf,

Thanks for submitting the above information, I’ve updated your ticket and I have requested our QA team to review your case once more, thanks for your patience while this request makes it’s way through the queue.

Hi Noris, any solution yet

Hi @David_Haaf,

I just wanted to reach out and let you know that our team has been discussing this issue, and our QA team has a full investigation of this situation in their queue. I can’t guarantee any specific timelines here — Our team is investigating, and we’ll likely need to loop in SGC and collaborate with them to uncover the root cause of what you’re seeing.

Ultimately we know that:

  • The ST with a fresh database works
  • The backup restores fine and works on other Core machines
  • Something about this backup with this Core machine is causing issues to occur

Our team is confident that we get to the bottom of this, but this investigation will take some time. While we investigate, you can use the ST with a new database, or you could continue using a different Core.

As soon as we have more information from our QA team’s investigation we’ll be sure to reach out and let you know what they’ve found.

We appreciate your patience here, David. We’ll be in touch.


Hi Dylan,

I am checking to get an update - it’s been over 3 weeks, the new SonicTransporter arrived 3 months ago and has been a brick from day 1. I have been using my 3rd core machine but it has been a bear (see my other post (Roon Spinning Non-stop).

I am so frustrated with roon and the lack of support. I do not understand why I am having so many problems. I love Roon, it is amazing when it is working well.

I need to get my 3rd core machine (kingdel) or 4th (SonicTransporter) up and running hassle free please help me achieve this goal.

Thank you,