Sonos AMP skips to next track after 5-10 seconds

Core Machine (Operating system/System info/Roon build number)

OS: Version 1.0 (build 183) stable
HW: Intel NUC Kaby Lake i7-7567U
ROON Server: Version 1.7 (build 500) stable (
Connected through ethernet

The library is stored on a QNAP NAS (, ethernet) and is shared through SMB to the ROON Server. There is 198058 tracks in the library at the moment.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Single LAN (192.168.0.x) with all devices on. Ubiquity and Netgear switches. All audio players are connected via ethernet. WiFi is disabled on the Sonos devices.
See screenshot for all audio devices in use.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

SONOS AMP (new model) through Ethernet

Description Of Issue

Have retired and old Sonos Connect:Amp and replaced it with a new Sonos Amp.
This new player is having a problem when playing through Roon that it after 5-10 seconds of the song skips to the next track. The music is played from the next track in the playlist but the Roon interface is not updated that it has skipped instead it looks like the song has stopped (no progress on the display).

This happens both with CD quality files and HD quality files that Roon converts.

It is not happening every time I play a track but more then 50% of the time it skips to the next track.

I do not have this problem with my older Connect:Amp HW and I have just used the Sonos offer to upgrade to new HW so within short I will only have new Sonos Amp players and it therefore a bit worried that I made the wrong decision to upgrade the Sonos HW.

Playing to my other audio renderers I do not have a problem.

Hi @Patrik_Falk,

Is the new Sonos amp connected to the network in the same way as the older amp? What are the exact models of the networking gear above? Are the switches managed?

Do you receive an error when the track skips?

Same connection. Unplugged the old Connect:Amp from the ethernet cable and connected the same cable to the new Sonos Amp.

Simple network. FW->Unifi Switch 24->Unifi Switch 8->Sonos AMP. Latest FW released a couple of days ago.

The ROON server and NAS is attached to Unifi Switch 24.


Switches are not managed. No VLANS or such. Just a simple LAN.

No error. The music skips seamlessly to the next track. My iPad stops updating the progress on the display of the track playing but does not understand that it skipped to the next track. If I click the track that got skipped on the Ipad it will start playing again.

I just recieved shipment of the other Sonos AMP players I ordered to replace the Connect:Amp. They behave the same way so now I have verified that It isn’t a single AMP thats missbehaving.

Hi @Patrik_Falk,

Can I please request that you reproduce this behavior and let me know the exact local time + date in your country you observe it occur at, as well as which track appears to be playing and which is actually playing?

15:06 (that 3pm06 in US time). CET Stockholm.

Track i started
The Hand That Feeds - Nine Inch Nails

The track it skips to after a few seconds
Love Is Not Enough - Nine Inch Nails.

The iPad screen dump shows that its still The Hand That Feeds thats playing (see img) but its stuck on 0:01 and the “musicbars” to the left of the track keeps moving.

If needed I took a copy of the logs from the ROON server also. Just ask and I’ll post.

Installed the latest build of ROON. Still same problem.


Track i started
Electraglide - Metal Mean Machine

The track it skips to after a few seconds
Brilliant - Metal Mean Machine.

So the fixes in build 505 did not fix my Sonos AMP problem.

Hi @Patrik_Falk,

Thank you for letting me know those timestamps.

Now that I have this information, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Once these are revived, I will be attaching them to your case for further review with the technical team. Thanks!

My ROON Server is allways on. Anything I need to do or did you get the logs?

Hello @Patrik_Falk,

The diagnostics package was received by the support servers, so no further work is needed on your end as far as that is concerned.

In the meantime, I would be curious to know if you experience this issue when streaming to the Sonos Amp using the Airplay interface.


I have now tried through Airplay (with ethernet connection) and I can on some tracks get a “scratch sound” a few seconds in to the track but it does not skip to the next track. So it seems it is more stable then the native sonos protocoll you use. If you want to check the logs this track I got the scratch 2 times in a row via Airplay but it kept on playing the track and no more “scratches”.

17:31 Peter Gabriel - Moribund the Burgermeister

Not sure if it is connected at all but with Airplay stable I can enjoy my new Sonos Amps with ROON just by enabling them instead of the Sonos protocol which is a workaround while you dig into the root cause.

Hello @Patrik_Falk,

Glad to hear you’re able to get AirPlay playback up and running. I have passed the diagnostic logs to the QA Team for analysis regarding the Sonos streaming issues, we’ll keep you in the loop.


Hi @Patrik_Falk,

Happy New Year! Apologies for the delay in getting back to you here, we’ve discussed this issue a bit with QA and we wanted to inquire if the same behavior was still occurring on your end when using the Sonos protocol?

If the same behavior is still occurring, we were hoping to confirm a few additional aspects:

  1. Does streaming content (TIDAL/Qobuz) behavior exhibit the same behavior or is it just local content?

  2. If you load a few media files to a flash drive and connect this drive directly to the Core, does the same behavior occur?

Do let us know when possible, thanks!

Switched back to the Sonos protocol to do one of the tests you asked for.
The latest build (511) is more stable then the previous so it took me some time jumping between tracks to force the problem this time.

If you want to see the log entry look for

12:53 The Twins - Lifestyle

I have put some flac files and attached it locally to the ROON Core NUC and they play all fine. Have not bee able to recreate the problem with the USB localy stored music files.

I do not have a tidal or qobuz account today and have therefore not tested this. But if it is of interest I can get Tidal from Sweden (my place of residence). Qobuz is still not available in our region.

Managed to get the same behavior while playing from the USB disc today.

12:17 Dalek I Love You - A Suicide (from the album To The Shores of Lake Placid).

Played the same track from another album just before so therefore I also listed the album title.
ROON gave a short bursts of white noise this time before skipping to the next track in the album.

Hello @Patrik_Falk,

Thank you for letting me know those timestamps, I can confirm that the newest log package has been received and has been passed on to the technical team for analysis.

Went back to the Sonos API to see if the latest Sonos updates made a difference.
And same behaviour still exists.

Blondie - Europa

Skips to Live It Up after a few seconds.

Hi @Patrik_Falk,

Thanks for letting me know the same issue occurs with the latest Sonos updates.

I am still awaiting further feedback from QA regarding your latest logs, we initially believed this to be due to the network or NAS performance, but testing on the USB key indicates that the NAS is not the bottleneck.

Can I please request that you send me a copy of your ROCK logs for this attempt by using these instructions? I would like to attach this to your case notes as well.

Thank you!

Please find the logfiles attached through this link.

1 Like

Thanks for sending those over @Patrik_Falk, I have attached them to your case and it is pending review by QA. Thank you for your patience.

Hello @Patrik_Falk,

I discussed your case with the QA team and we have activated some additional debugging tools for your account. Can I please ask that you reboot your Core, reproduce this behavior, note the time/date/track as you have done previously and send me a new copy of your logs?

Thank you!