Sonos audio dropout issues


(Bill) #1

Core Machine (Operating system/System info/Roon build number)

2018 Mac Mini, Core i7, 32 GB RAM, wired network to switch / router, Roon core 1.6, Build 401

Router: Netgear WNDR3700, Switch: Netgear GS108

Audio Devices (Specify connection type - USB/HDMI/ect.)
Attached storage on above PC via USB3, mp3 / m4a audio, no flac or other lossless files in use

Audio setup:

  • Mac mini, HDMI to Denon receiver
  • Sonos Connect, wired network to switch / router; RCA input to receiver
  • Sonos Play:5, Sonos mesh
  • Sonos Play:1 (L+R paired), Sonos mesh
  • Denon receiver (HDMI and AirPlay)
  • Sonos Play:5, AirPlay (grouped in app Play:5 configuration to allow for automatic port to Sonos Play:1)

Description Of Issue

@support Dropout issues with Roon core:

Using Roon to play audio through either grouped or ungrouped Sonos speaker setup using Sonos mesh results in random dropouts, ranging from once or twice within an hour to several times within a few minutes. Sometimes the Roon app states it has lost control of the audio device, however, more frequently the Roon app simply stops, and selecting Play will not resume playback. On a few occasions playback is regained by directly starting the Sonos app and using the controls from there, with the Roon app still frozen. Restarting the Roon core app usually resolves the issue.

All available playback configurations are successful (no dropouts) without Roon core:

  • Directly using the Sonos app via any native configuration (Sonos mesh or AirPlay)
  • Grouped or ungrouped, no issues during playback

Successful playback with Roon (no dropouts):

  • Roon playback using Sonos Play:5 via AirPlay (automatically ports to Play:1)
    • Grouped to receiver AirPlay
  • Playback direct from PC receiver HDMI

Troubleshooting steps:

  • Ungrouped Sonos speakers, using just one Sonos mesh device or the Connect wired device resulted in reliable playback from the wired Connect, but noticed a few dropouts within an hour with the ungrouped Sonos mesh speakers (Play:1, Play:5)
  • Set Mac Mini to wireless (bypass wired switch / router); same original frequency of dropout issues. As above, worse when Sonos is grouped, less so when playing individually assigned.

Please let me know what additional info or testing you require to address this issue, your help is greatly appreciated.


(ein) #2

My configuration:

Sonos Bridge (LAN route with my net inf.)
Sonos Amp (mesh)
Sonos :1 and One (paired via Sonoseqncr) (mesh)
Sonos :1 (zone - mesh)

All works perfectly fine via Sonos mesh, also (but, I prefer Sonos protocol, not Apple) works via AP2 brilliant. You have problem only via Roon, I see. De-enable all Sonos devices (first), restart Roon app (second), enable all Sonos devices (third). If nothing changes, maybe hardware solution works for you (Sonos Bridge on route?). I know, that Connect do similar work (routing via LANs, mesh routing), but Bridge is especially for that and in my system I haven’t issues, no drops, 100% smooth playback (I have many different WiFi clients in my home (intelligent things), many WiFi networks near, very problematic environment)

(My Core: iMac 2013 i7 4Ghz, 24GB RAM, gigabit LAN -> router -> Sonos Bridge)

PS. Hmmm, yours Core works on new mini, so… maybe strange T2 issue you have here. Many people complain, say a lot about errors with I/O operations (USB, BT and HDMI also?) on macs with T2 chip.


(Noris) #4

Hi @Bill_Greenawalt,

Thanks for contacting us regarding this issue. I am wondering if there could be a setting on your Netgear router that triggers this behavior. Do you by any chance have the ability to disable “Enable Smart Connect” on your router? We have seen this setting affect Roon behavior in the past and it exists on similar Netgear models but not entirely sure about your specific model. Are the Sonos endpoints connected to the 2.4Ghz network or the 5Ghz one?

Thanks,
Noris


(ein) #5

Are the Sonos endpoints connected to the 2.4Ghz network or the 5Ghz one?

Sonos devices work only via 2.4GHz network, not compatible with 5GHz…


(Bill) #6

@Antoni_Wozniak thank you for the response! I did try that startup procedure (unlink Sonos devices, exit, start Roon, restart devices via Roon) and that works great for startup but doesn’t stop the dropouts. Thanks for the information on T2, I hadn’t thought of that.


(Bill) #7

Hi @noris, there does not appear to be a Smart Connect feature available for the Netgear router, just a “Smart Wizard” which I did not use when I setup the network connections. As @Antoni_Wozniak confirmed, Sonos uses a (possibly) proprietary mesh that they state is 2.4GHz.

What I noticed: When the AirPlay connection to Sonos is assigned for playback in Roon, the Sonos app displays the individual track name that’s playing on the Roon selected Sonos device(s). No dropouts. When the Sonos mesh connection is assigned for playback in Roon, a Roon .flac file is displayed in the Sonos app, and the dropouts occur. Not sure if it’s the Roon’s .flac file that is an issue for the Sonos mesh. All other Roon core playback methods available to me work correctly (no dropouts), i.e. via HDMI from the Mac Mini to the receiver.


(Noris) #8

Hi @Bill_Greenawalt,

This is expected behavior because Roon is just sending a stream over to the Sonos devices.

Can you please verify if the same issue occurs when the Sonos devices are connected to your WiFi network or via Ethernet instead of the Sonos mesh?

If connection via Ethernet is not possible, there should be a way to connect them to the WiFi by disconnecting all of the Sonos devices and then pressing the two buttons to put the speaker in discovery mode.

It will try to find other Sonos devices on the network and if it doesn’t it goes into hotspot mode and you should be able to configure the WiFi settings via the Sonos App.

Can you give this a try and let me know if that changes anything?

Thanks,
Noris


(Bill) #9

Hi @noris,

I connected the Sonos devices to my wireless network (bypassing the Sonos mesh), removing the wired network connection for the Connect. Tested for several hours the past few days, zero dropouts from any of the Sonos devices with Roon, a definite improvement, to say the least! So the dropout issues seems to be where Roon tries to push to the Sonos mesh.

@noris I see the topic is now closed. Shouldn’t there be some activity from Roon to discern as to why the Sonos mesh feed drops in and out only when using Roon? Though switching to wifi is a workaround, the Sonos mesh (when not using Roon) is more reliable when there is wifi interference (such as microwave oven usage).


(Noris) #10

Hi @Bill_Greenawalt,

Thanks for letting me know that your Sonos devices are working on WiFi! If things are still stable in this configuration I would suggest keeping them on WiFi instead of using the Sonos mesh.

– Noris


(Noris) closed #13

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.