Sonos Connect as an Endpoint

For the past few days, I have been tearing my hair from my head trying to set up a USBridge to talk to a Roon approved Pro-Ject DAC box D2 Ultra. I just could not get this to work, and decided to call it a day with the USBridge and try something else.

Since I have a Sonos Connect lying around, I connected it to the Pro-Ject DAC via Coax. The resultant sound is good but it is not clear that I am getting high res outputs.

I tried something else. I used my regular work laptop as an endpoint to connect to the Pro-Ject DAC via USB. The Roon core remains on a MacBook Air elsewhere on the home network. However, I needed to set the audio output to the DAC, a rather inelegant solution. Moreover, I don’t see the Pro-ject within the Roon system with this approach.

In neither of these cases is the SQ outstanding, whereas when the DAC is directly connected to an iPad, it is!. I am obviously doing something wrong here. Can someone please let me know how to use the Pro-ject DAC optimally in either scenario?

Sonos Connect is limited to 16/44.1, 16/48.

What endpoint were you using with the DAC?

Thanks for the help. I outlined both setups in my first message.

A Mac? How did you set it up as an endpoint? Did you load RoonBridge? Roon? Either way, the audio endpoint should be using CoreAudio, if it using OS Mixer that would explain the lesser audio quality.

Sorry. When I connect my Mac, I do not see the DAC in the Roon list, only the Mac. Not sure about audio quality either, this being a subjective call.

I had assumed that when one is connecting a Mac to a Mac and the DAC to the Amp, one would see the DAC’s name on the Roon list. I am not seeing the DAC anywhere.

Hey @catman,

On the Mac that you’re connecting the DAC to, do you have any active firewall or antivirus? If you temporarily disable them, do you see the DAC as a connected device? You may need to set firewall exceptions for Roon and RAATServer in order to see the DAC.


A power-recycle solved the problem. Somehow, the connection with the uSBridge threw something off. Once I did a full power recycle, it was finally addressed. There is no firewall or anti-virus as this is a Mac dedicated to Roon. Thanks for your support. I think I am finally good to go.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.