Sonos Connect stops at exactly 29 seconds

I don’t know whether to start a new topic - hopefully Roon Support will pick up this message. This morning I have started to get this same message as this thread title, after exactly 29 seconds of playing a track - only on one of my devices - a Sonos Connect. Other devices play normally.

  • The same Sonos device was playing normally yesterday
  • Roon core is located on my Sonic Transporter STi5
  • As mentioned, other devices connected to Roon are working fine
  • The Sonos Connect does not actually lose connection. It just stops playing the track. Pressing play restarts.

Please let me know how I can resolve this - thanks.

You should start a new topic in Roon Support. That’s how they keep track of outstanding request for support.

Hi @Jeremy_Jones,

I’ve split your post into it’s own #support thread so I can better assist you. Is there any change in behavior if you reboot your Sonos Connect?

Is there any pattern to the type of content you are able to reproduce this issue with? Does it only occur on certain file types / sample rates?

Have you tried any troubleshooting such as rebooting everything?

Just to say that the problem disappeared as mysteriously as it appeared. I did reboot everything but what appeared to actually fix the problem was playing other (working) devices including my iPhone. When I returned to the Sonos it worked!

Hi @Jeremy_Jones,

Thanks for letting us know the issue is resolved! If the problem re-occurs, just let us know that you had this existing thread (and provide a link) and we can re-open the ticket if needed, thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.