Sonos dropouts (Roon lost control)

Hello,

I have been having sporadic but consistent drop outs where Roon loses control of the Sonos end points.

@Eric I sent you a description of my network and Sonos gear.

I still need to do more testing of Tidal vs in house music, but most of this has been with Tidal.

Thanks,
Rob.

1 Like

Hi @RobOK ---- Thank you for the follow up, I received your PM and have asked you for some additional information in regard to your network configuration.

Moving forward, I would like to kindly ask you to please run the following test to see if we can trigger a change in behavior here. Please see below.

In your PM, Rob. You mentioned the following:

When Roon loses the end point, it really loses it – it still shows, but can’t get it back. This has happened only with the Playbar/Connect/Sub grouping and the Stereo Pair Play:1 – I assume it is a coincidence that the ones it has happened to are groups, but thought important to say. (By group I mean done in Sonos not Roon)."

Please use the instructions found here on how to launch Roon with the mentioned “command flag” (see below) and confirm if you notice the same behavior with your various Sonos zones.

Flag: -nosonosflac

Let me know how it goes!
-Eric

1 Like

I will try that @Eric although I am not sure when I can do it.

So what does that do then, not use FLAC with Sonos?

Thanks for your support,
Rob.

Hi @RobOK,

That flag does indeed turn off compression on the stream Roon sends to the Sonos player. It switches us to pretending to send a single big .wav file instead of a single big .flac file. The goal of the test is to determine which of these two places the bug is:
our FLAC compression code and the code to send FLAC “frames” as whole units
our network code more generally.

I don’t think this is a network problem in the sense of a problem caused by marginal network performance in general. However, if it is, switching off FLAC will send more data, making the problem occur more often.

As always, fixing bugs like this is a gradual process of narrowing down all the places where the bug might live until there is just one left and we can squash it. Thanks for your patience while we resolve this.

I have been listening casually for the last few days and no issues so we will see if it pops up again.

I have not tried the -nosonosflac flag yet.

Okay, i have been listening more this weekend and got some Sonos “lost control” situations. I don’t have the sonos flag set.

@eric I will save the logs for you and PM you a message with the location.

Thanks!
Rob.

Hi @RobOK ---- Thank you for the PM/Logs, confirming that I have received, both :thumbsup:

We’ll take a look and see if anything pops out, as a potential cause of this behavior. I am interested to see how things behave via the use of the mentioned command line flag from above, please due let us know the results of that troubleshooting exercise.

-Eric

Well some bad news with slight good news.

With that parameter set Dropouts are rampant. The songs take 10-12 sec to start (is it caching?). Dropouts maybe 2-4 times in every song.

The “good” news- even though it says it lost control it picks back up in 10 secs or so. Sometimes I have to hit play again. But with earlier problems it was not immediately recoverable.

Do you want logs?

Thanks,
Rob.

BTW, switch to plain Sonos and it’s flawless playback.

Could Groups of Sonos be the problem? When I switch to one speaker, no problems yet. Does Roon create a stream to each speaker (vs Sonos doing some sort of multicast? Just a theory )

Rob.

Hi @RobOK ---- Thank you for touching base with me and sharing the observations you’ve made with the flac compression disabled.

I touched base with my team today along with one of our techs, who have requested the following:

  • In our PM exchanged you mentioned the following:

Main Floor (2nd) — in same cabinet as router, but I can’t remember if these are hard wired or wireless

  • The team would like you to please hardwire these Sonos devices sitting in the mentioned cabinet directly to your router (if they are not already).

  • Once the units are wired, could you please temporarily disable the mentioned repeater and other Sonos devices so we have a completely “clean” test environment.

  • When the configuration is setup, please group the hardwired Sonos devices (in Roon) and try playback to the newly grouped zone.

  • Then using the instructions found here please upload a new set of logs.

-Eric

1 Like

Thanks! I will but not until weekend…

1 Like

Grouped playback for Sonos hardware in general works roughly like this:

  1. The control system (Roon or Sonos app) picks a “master” device.
  2. The control system sends commands to the speakers to tell them what URL to use to get audio. For the master device this is a source file or stream somewhere, for the follower devices this is a special URL indicating to get audio from the master device
  3. The control system sends a “Play” command
  4. The master device gets audio from the source and distributes it to the follower devices.

Roon and the Sonos app both do roughly the same thing here. The obvious (but possibly wrong) reason to think that grouped playback is a problem is just that it requires moving more data total.

Thanks… not sure your final point, sounds like there IS more total data the more speakers you add in a group.

I suspect Sonos has added some secret sauce to their firmware over time that may not be exposed to their API commands?

Unless you have a different theory why playback behavior is different between native Sonos and Roon?

Rob.

@ben there must be some differences between Roon and Sonos as the results are different.

I think when Sonos starts a stream, the speaker is the external (Tidal) streamer but for Roon, Roon Core is the streamer. Is that accurate?

@Eric Ok, I opened up the cabinet and they were already hard wired. there is a small basic hub that is fed directly from the main router and then feeds the Sonos Connect Amps. That is not to say there are not other wireless speakers.

I disabled the wireless extender. I am still having dropouts and will send logs. I am trying to see a pattern, playing through different groupings of wired and wireless end points.

Let me know if you see anything in the logs,

Thanks
Rob.

Hi @RobOK ----- Thank you for touching base with me and giving the test a go, both are very appreciated! Moving forward, can verify where the logs were upload, I don’t recall seeing a download link.

Furthermore, I just got out of a meeting with one of my techs who has been helping evaluate this behavior you’ve reported and as per our conversation the team would like to have you run one more log gathering exercise to add another data point to our investigation. Please see below.

  • Start Roon
  • Ensure that every Sonos device is enabled in “audio” tab.
  • Group the devices in the Sonos app.
  • Go to “settings” -> “audio” and disable/enable every device in the group. Please repeat for every “grouped configuration” that you use.
  • Repeat by clicking the ‘group’ button next to different devices in the Sonos app.
  • Send us logs.

Just to give you some insight into this latest exercise and the need for the multiple “enables/disables” for every “group” :innocent: We are trying to determine how the Sonos app decides which device acts as the “master” and all the “follower” devices then connect to said master device.

-Eric

I had sent a Dropbox link via PM with the first batch of logs, the second batch is in same Dropbox. Let me know if you don’t have it.

I get it up to the fifth bullet. From step 3 I have speakers grouped. Let’s say i have 4 or 5 grouped. In bullet 5 there would only be one Group button. I couldn’t go to each device as they are in the group. Maybe I am missing something.

Hi @RobOK ---- A few things. First, I have received the latest set of logs via the dropbox link. Appreciate the clarification. Two, I have revised my instructions below. Hopefully these make a little more sense.

For each Sonos “group” you use with Roon…

  • Start Roon
  • Make sure all of your Sonos device are “enabled” via the “audio” tab (in Roon).
  • Group the devices in the Sonos app by clicking the the “group” button.
  • Disable the Sonos devices via the “audio” tab (in Roon).

Repeat the steps above for each configuration you use and then send logs once complete. Remember you want to enable/disable your Sonos devices in Roon and perform your groupings in the Sonos app by clicking “group” next to a different device each time, from the devices list.

-Eric

@Eric I think I did what you wanted. Had a bout of Transport lost. I am wondering if it is happening with Grouped Devices, i don’t been broader Sonos Groups, but I have paired Play 1 + Sub and in another room a Connect:Amp paired with a Playbar.

Logs uploaded. I made a Sonos group of endpoints. Went to Roon and sequentially Disabled and Enabled each endpoint. Then i ungrouped all in Sonos and made a smaller group in Sonos and then in Roon I disabled and enabled.

Uploaded logs in same Dropbox (location in PM).

I hope we can sort this out!

Thanks,
Rob.

Hi @RobOK ---- Thank you for touching base and performing the requested log gathering exercise. Confirming that I have received the logs an all materials are now with our techs.

Once my report has been updated and passed back, I will be sure to provide you with the team’s thoughts/findings in a timely manor. We greatly appreciate you “hanging in” during these extensive data gathering/troubleshooting exercises.

-Eric