Sonos Five stereo-pair starts and stops after 1 second

Hi everybody,

after month of problem-free playback i was stunned by a very weird playback issue that only appears on a set of stereo-paired SONOS Five.

As a senior software-engineer and network administrator i thought i have seen it all, but this leaves me buffled why this should happen. …even after checking and testing for quite a while :wink:

Maybe someone from support or from the community can give me a hint where to go next.

So here is the general situation:

Roon Core Machine

ASUS X99-E WS Board in Tower
Intel Xeon E5-1630 v3 @ 3,7 Ghz
Windows 10 v21H2

Roon Remote running on a range of items like
Windows 10 (different machines including virtual machines)
Mac Big Sur (Macbook Pro Intel)
A large portfolio of iOS based Devices from iPhone 13 Pro to iPad Pro with all in between…

All Devices and PCs are up-to-date with Roon (Core and Remote) on most current release.

Sonos is running S2 on most recent software version.

Networking Gear & Setup Details

Internet: 1000/1000 Mbit FTTH
Gateway AVM Fritz.Box 7590
MainSwitch TPlink managed with POE
all 1gbit Wired
WiFi by FritzBox and Mesh-Repeaters with excellent availability throuhout appartment
All Sonos use 2,4 Ghz with fixed IPv4 adresses

Connected Audio Devices

2x Sonos Play:1
1x Stereo-Pair of Sonos Five
1x Sonos HomeCinema (arc + sub + 2x sonos one)

Number of Tracks in Library

150.000 Tracks

Description of Issue

When starting a stream to this specific pair playback starts but sound cuts off after ~1 second. Nevertheless playback is continuing (at least at the UI) on the remotes (aka “slider continues to move”).

This behaviour is independent from “source” and “remote”. If i use PC based-, Mac based- or iOS based Remotes… whatever sources i try to stream (different Radiostreams via internet, ‘local’ NAS based content with whatever encoding/bitness…)… it will always ends up in 1-2 sec. playback abruptly ending.

BUT: The very same combinations with the very same sources work just fine when i use other “targets” like 2 different Sonos:Play1 or a SONOS “Moviegroup” (Arc+Sub+2x One) or even using the iPhone or iPad (with the remote on it) as the target itself.

AND: The very same SONOS 5 pair that shows this behaviour is working just fine using the Sonos App for the very same sources (so it is neither a general WiFi- or connection-problem in general).

My conclusion so far… : this happened after some recent updates from roon AND sonos. So this could be a software problem.

And before anyone asks… yes, i have tried the usual and the unusual things to fix it, including restarts, new installation, manual “updates” etc. etc.

I would be very happy if someone can look into this problem and possibly show a way out of this mess.

Thanks and greetings

Murphy there are a couple of threads active about issue’s with Sonos but stuttered and stopped playback was not one of the items.
It looks like you already have everything in place based on your description.

I have a few stereo pairs of play 1s and play 3s and I did have the problem on the play 3s in my study. One was plugged in and started routing traffic over it and not the Mesh WiFi it was plugged into, similar issues to you, but I got maybe 3 seconds.

Are the devices using traditional WiFi or SonosNet?

I moved all my devices off SonosNet and Ethernet onto basic WiFi during a factory reset and got to say everything has worked perfectly for me ever since.
Not sure this is the answer for you though

Hi Michael_Harris,

thanks for the quick response.

All sonos are running on Wifi (except the arc which is wired) and all the wifi-sonoses are “hard-routed” via their mac-adress to a specific wifi-band and access-point to circumvent the mesh-problem.

But you are right. Thats one of the few things i have not tried yet. As these are the speakers in my study, i can easily run a wired connection. I will try if this makes any difference.

Thanks for your hint. I will certainly try this later on.

Best regards and stay safe
Michael / “Murphy”

Michael based on your information I thought you had it all covered.

Hard wired was the cause of the problems for me, as for some reason a Sonos update started triggering routing through it, even though it was directly connected to my Mesh router, didn’t make and sense but I was able to diagnose it through traffic flow and speed.
All my Sonos are now 100% wireless and problems are gone.

One question have you tried breaking the stereo pair and playing to them individually to see what that does as this worked for me.

Another problem I found many years ago was that SonosNet was only ever stable for me on channel 6, channel 1 did not work at all due to interference, and channel 12 was too clogged. I am guessing that you already tested this extensively.

Yepp, the “will-try-wired (again)” is just me being frustrated and trying to fix it on my own :smiley:

As Wifi connections for the sonos are very steady without any problems without any channel problems et al i had never any problems with wifi-sonos. Especially because the pair here is just a few meters away from their access point.

The Fives just recently went to the study and were paired there, but thinking about it… Re-Pairing and factory reset is the only thing i have not tried yet. Was not on my mind because leaving roon out of the equation sonos on its own is running just fine with the very same sources.

I am running the Fives on “Sonos Streaming”. But the same problem applies to “via Airplay” if i enable both possibilites as targetoption.

So, yes… just out of pure frustration i will try the two scenarios “wired” and “reset and re-pair” just to be sure to really testing everything.

I come back later and report on it.


I understand the frustration as mine worked perfectly wired for many years until a Sonos update in the middle of 2021 and I have no idea how that update broke it so that it started taking over switch duties again.

stuff like this keeps us out of trouble and good luck with the diagnostics.
Funny thing is after resetting my first unit and setting everything back up again, my setup has never worked as well. I think not setting up SonosNet was the biggest benefit as WiFi has really moved on since 2006 when I bought my first 4 or 5 units. I feel that pure WiFi especially on a modern Mesh network

Just to wrap things up and to document this for fellows with similar problems…

Things fixed by the following steps
SONOS Update from today (25th Jan 2022)
After that the problem was still there. The time to cut-off was much longer (now 15-17 sec.), but it still cut off the stream after that.

unpair and repair the stereo-paired-Fives
following the hints @Michael_Harris gave in his replies, i tried the next easiest thing (again). I unpaired the stereopair and waited until both speakers appeared both seperated in roon.

After that i re-paired them to a stereo-pair and gave the am new (not yet used) name. Waiting again to show up in roon…

And finally… after enabling this “new” pair as a roon-target everything works normal again.

Wow…what a trip. The only disturbing thing is, that this happened out of nowwhere when no changes to any firmware, wifi-settings et al had been made.


1 Like

Good news and glad that you have reliable music again :+1:

Hopefully it remains reliable for you

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.