Sonos loses grouping [Solved - SONOS Zones Muted]

@support. I’m new to Roon as of yesterday. The install went very smoothly and it imported most of my music (another topic). I have the “latest” 1.5 build 363 64 bit using ROCK on a NUC with 8 GB RAM and 128 GB SSD.

I have 3 Sonos zones: Office, Living Room, and Whole House (mutually exclusive). I see all three in Roon but didn’t see any way to group them within Roon. I seem to recall reading somewhere that isn’t currently supported. Please correct me with the proper procedure if I’m wrong.

I went directly to Sonos and grouped the 3 zones using Office as the primary. Roon plays to all three but seems occasionally to have problems. In one case, I advanced the music to skip the rest of the track that was playing, and it dropped the Sonos grouping, i.e. it reverted back to just Office. It isn’t a big problem, since I can regroup them, but it is definitely a nuisance.

At at least 2 other times today, it has dropped the Sonos grouping seemingly at random. I wasn’t actively doing any fiddling with it at those times, so did not notice if something in particular was happening. I think the last time there was an internet slow-down or glich (not sure), which might have been the source.

If there’s some setting I can adjust, please advise. Otherwise, I would appreciate your attention to fixing this in one of your updates.

Steve Vorenberg

The Sonos grouping works better lately, that symptom sounds like a WiFi problem.

I have most everything connected via Ethernet cable. Two exceptions: the link between the Sonos router and “Office” is WiFi, as is the link between the Sonos router and the controller. My Synology NAS, PC, and NUC are all connected via Ethernet cable to the router. I did add a port extender to the router since I didn’t have a free port for the NUC, in case that’s pertinent.


A WiFi extender?

No, it’s a D-Link Ethernet port extender. You connect one port via Ethernet cable to the router (mine is Verizon Fios) which acts as the source for the remaining 4 ports in the D-Link. There isn’t any WiFi involved.

Steve, you probably have already done this but just in case: Once you set up something new in Roon (e.g. connect / enable a sonos speaker for the first time), it is important to quit and then restart roon core. I have noticed in my case that it solves a lot of problems like the ones you mention.

Re-reading the original post. You can group Sonos end points within roon, perhaps try that?

Just found that! I had overlooked it. I’ll run with that tomorrow and see how it goes. Thanks!

There’s lots to see and learn :blush:

Hello @Stephen_Vorenberg,

What is the model/manufacturer of your Router and D-Link switch? Sometimes we have seen a few routers require special settings be applied for Roon to work properly, we have documented these settings on our Networking Best Practices Guide. I would also give the SONOS grouping a try from within Roon and see how it goes, if you still need assistance afterwards just let us know!

– Noris

I tried using the Roon grouping this morning. It says it is playing to Office+2. The “+2” is Living Room, and also Whole House. When the music started, it played to Office and Living Room, but Whole House was silent. I checked the grouping in the Sonos app and found it was set to Whole House only. When I grouped it in Sonos, everything played. I’ll need to fiddle with this some more to see how consistent it is.

The tag on the switch says D-Link, which I think is the manufacturer. The model is DGS-105. I just bought it new from Amazon.

The router is one I rent from Verizon for FIOS access. The tag on the side identifies login, IP, and such, but I don’t see anything about the model or manufacturer. I’m getting 1GB service with it, if that’s pertinent and it has been working well for pretty much everything I’ve pushed through it.

Thanks for confirming that @Stephen_Vorenberg. I took a look at the D-Link switch and it is unmanaged so that’s in the clear. As for the Verizon Router, it would be useful to know the exact model in case it matches one of the routers we have found that need extra configuration applied.

If you ungroup everything in the SONOS app and try to just group them together using only Roon, does that work as expected?

– Noris

I’ve got it figured out. If any zone is selected in the Sonos app, Roon shows that as muted. ( I didn’t see the “muted” icon at first since I didn’t have my glasses on.) So there are two possible approaches: 1) Don’t select any zone in the Sonos app (it complains a little but lets you do it), or 2) Keep an eye on the “muted” icon in Roon to be sure all the Sonos zones you want are set to play.

1 Like

Glad to hear you figured this one out as well @Stephen_Vorenberg! Marking your post as the solution, thanks again for contacting us!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.