Sonos parametric eq

Hi everyone.

Posted this on a Roon facebook group, but didn’t get a resolution, so hoping the collective here may be able to shed some light.

Downstairs we have a bunch of Sonos speakers. The other day I decided to play around with parametric EQ , but no matter how high or low I pushed certain frequencies, it didn’t seem to make any difference at all.

For example, no bass distortion when whacking lows up. No cringing when whacking up the top end. Sounded exactly the same no matter what I did.

All eq points are enabled as well as the eq itself.

Same process works on my other kit - cambridge evo 75, as well as when listening on a mac using headphones.

Am I missing something?


Hi there Hook
I have just created a parametric filter to test it and was completely able to change the sound of music that was playing.

Do you want to share the DSP settings as a screenshot

1 Like

Hi Michael - sorry for the delay in coming back. Here’s the screenshot you asked for.

I’ve also tried adjusting bass frequencies right up/down as well as treble, and also tried changing the “grouped zone” in the top left and doing the same. I just can’t seem to here any audible difference, and I would expect extreme frequencies to be obvious.

Many thanks!

Hook that all looks correct, are you using Play One devices connected as a stereo group?

I will try it on another device, as I tried mine on an Amp, but it was very noticeable.

I will let you know how I get on

Thanks Michael.

It’s quite a big grouping to be honest, let me share a screen. But yes, there’s an amp with a couple of cambridge audio satellites front and two play:ones rear.

Bookshelf LR - Gen1 play:1
Kitchen White - Gen1 play:1
Kitchen Red - Gen2 play:1 smart speaker
TV - sonos amp, cambridge minx satellites and two gen1 play:1 as rears

So have you tried just using it on one device?
There might be an issue with Larger grouping.
You might want to try grouping in Sonos and do the parametric equalizer on just the one

Good idea. I did try muting everything except the one I was experimenting with, but I will try removing from the group and re-testing later tonight.

Worth a try and I will try the same this evening at home and include a Move and a pair of stereo ones

Just an update that the settings seemed to take effect when moving the speakers outside of the group.

1 Like

You’re saying the settings work on a single end point but not a group?

Seems to be the case. I could not notice much difference when adjusting the EQ whilst grouped, but was easily apparent when isolating a given speaker.

I need to be more scientific about it to confirm.

For example, I did not re-group, mute all speakers other than one, and then adjust.

1 Like

Additionally, you still have to select an individual endpoint to apply the EQ and adjust even when grouped. As far as I can see, there’s no concept of applying a single bunch of settings to an entire group, which is understandable and a good thing IMO.

Sorry I forgot I was going on holiday after work that day, so never got around to testing it further

As I am at home today I have brought the Move into my study where I am playing on two stereo linked Pay 1s. So I add a crazy Parametric filter and it totally changes the sound.

I then add the the Garden (Move) and it is gone

I then add the EQ (which has no impact)

Take the Garden out of the group and I can barely hear it due to the EQ being engaged again.
Put it back into the group and the filter has gone again.

So I have to agree with you it does not work on a Sonos group grouped through Roon
But If I build the group in the Sonos app the EQ filter is applied to all of them the same way

You might want to give that a try, as the way Sonos ungroups devices is annoying as 90% of the time is does not work

Thanks @Michael_Harris - some good sleuthing! I wonder if this is something Roon would be able to do something about in their software?

I would like them to fix the ungrouping issue as well. As adding a device to a group is 100% successful, but removing a device feels like it pretty much fails 100% of the time.

It has been complained about many times before but nothing has been done with it

Hi @support can you pick this up for @hook_menu_alter please so at least he can get an answer.