Sonos speakers not showing up in Roon

I’m new to Roon. I’ve been using sonos for 7+ years and it all works great using the Sonos app.

On the PC where I’ve installed Roon, Windows Explorer easily sees my Sonos equipment:

The Sonos app works perfectly on this PC as well. Sonos apps on iPad/iPhone work well all throughout the house.

The Roon app has shown a few of the Sonos speakers, but never more than 3, and right now shows none except the one that is AirPlay compatible:

In the current Roon log, I can see evidence that Roon “sees” the rest of my Sonos speakers:

Any help would be appreciated getting Roon to see all my equipment.


I moved your post into support as there responses should be quicker there. It would help if you listed your PC, Network (router,switches etc) for support to help. Some routers are a bit roon peculiar, as a for example.

Thank you.

Main router is a Netgear Nighthawk R8500. The PC that houses Roon is connected to a Netgear Nighthawk R7500, which itself is connected to the main R8500 by cat5.

CenturyLink fiber provides the internet connection to the R8500.

Are the two routers serving up the the same range of network addresses? Roon needs a flat network and won’t, easily, work across networks.

Yes, actually only the main router serves DHCP. The entire network is 192.168.1.x

1 Like

Hi @Andrew_White1,

Can you try disabling the disabling the “Enable Smart Connect” setting.

Is there any change if you temporarily disable any firewall and/or antivirus running on the Core machine?

Thanks for the help.

With Smart Connect disabled, no change:

With all 3 Windows Firewall profiles disabled, no change.

Thanks for giving both of those a try, @Andrew_White1!

As a test, I’m hoping we can temporarily try a simplified network setup so we can see if this yields any changes. If you connect the Core and one of the Sonos devices directly to the primary router (R8500) via Ethernet, is there any change?

The Sonos devices are currently connected via WiFi, correct?

Thanks for the reply, Dylan. Sorry for the delay, I’ve been travelling for the past week or so.

Update: I bought a fanless PC (Win10 Pro, SSD, etc…) to use as my Roon controller. This makes it easier to plug directly in to the router. I’ve taken one Sonos Play1 speaker and plugged it in to the same router. They are literally beside each other. I disabled WiFi on that Sonos speaker. (FYI, the rest of my Sonos set up is mostly WiFi, but there are 5 or so speakers plugged in via ethernet. I also have one boost and two bridges).

Roon does not see this Sonos speaker. It only sees AirPlay devices (2 Apple TVs, one Sonos ONE).

On this new pc I have the Windows Firewall turned off for all 3 zones. In Windows Explorer under Network you can see all the Sonos equipment.

I’m pretty advanced with PCs and networking, but this has me baffled.

Log files still show Roon is seeing the Sonos equipment:

Hi @Andrew_White1,

Just to confirm, this is the same even with the firewall completely disabled on the new Windows device?

Are you using the PC as a Core or is it just a remote that is connecting over the network to the Core machine?

This new PC is being used as my Core. It has the Windows Firewall completely disabled. It is plugged into the router right beside the Play:1 speaker, which has WiFi disabled.

Thanks, @Andrew_White1.

Moving forward, I’m hoping you could do the following:

  • Reboot the router, Sonos device, and Core machine
  • Once everything boots up, go to Roon and open Settings > Audio and confirm that the Sonos isn’t showing up
  • Respond here with the time that you open Settings > Audio and we can enable diagnostics so and take a look at what is occurring at that time


OK, I did the steps you outlined above. I also unplugged one bridge and the boost. I did a factory reset on two Play:1’s that weren’t behaving inside the Sonos app, and now Roon sees the Sonos system!

Thanks for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.