SoTM no longer appearing in Roon device list

Roon Core Machine

Debian GNU/Linux 11
Xeon CPU E3-1265L V2 2.5Ghz
16gb RAM

Networking Gear & Setup Details

Amazon eero Pro 6E

Connected Audio Devices

SoTM hardwired to eero node

Number of Tracks in Library

2000 tracks

Description of Issue

After some recent updates to Roon, my SoTM device no longer appears in the list of recognized devices in Roon. I’ve tried restarting the SoTM. Eero shows the SoTM is online and has an IP assigned (screenshots attached)

Replying to myself. Tried downgrading from early access to the production builds of both client and server. SoTM device is still not appearing.

Hi this is typicaly network related, have you tried rebooting all the network equipment?

Thank you for the suggestion
Yes, I did.

I tried pinging the SOtM from my roon server device, that’s working:

dave@jj ➜ ~ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=13.7 ms
64 bytes from icmp_seq=2 ttl=64 time=7.51 ms
— ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 1002ms

I’m a java developer by trade so I’m comfortable troubleshooting tech issues.

I also upgraded the f/w on the SoTM device, brought the Roon Ready version from 1.1.3 → 1.1.9:

Roon Ready information
vendor : SOtM
model : sMS-200
unique_id : 8f4322e8-4507-4b21-b93d-02040281418c
Roon Ready version: 1.1.19

What else should I do to troubleshoot this?
I have about 6 other (non roon ready) devices show up and work as usual: bunch of chomecasts and an airplay device

Ok, so wondering if there is something wrong with the SoTM device itself or my network.
I have an old ropieee so I figured I would reflash that to the latest version and try connecting that to my network.

According to the server logs, the roonserver can see the ropieee and connects to it (this is right after a roonserver reboot):

dave@jj ➜ roonserver grep ropiee RoonServer_log.txt
03/27 14:26:54 Trace: [raat] RAATServer discovered: RaatServer ropieee @
03/27 14:26:54 Info: [raatserver] GOT SERVER 954f1cd9-3cf4-5728-a83f-c23ba264a390::ef06b4f3-b031-49a0-9ff7-c6c439e9a338 @ ropieee PROTOVER=1 RAATVER=1.1.38
03/27 14:26:54 Trace: [raatserver] [RaatServer ropieee @] connecting (attempt 1)
03/27 14:26:54 Trace: [raatserver] [RaatServer ropieee @] connected

Gave it about a half hour after the server restart, but I don’t see the ropiee in my Roon desktop:

Two points:

  • Do you’ve enabled the firewall on your Debian system?
  • Are you using a managed switch and/or you’ve restarted all your network devices (router, switches,…)?
  • No firewall installed on the server
  • Yes, I have a managed switch which I rebooted yesterday. I have the roon server and the ropieee plugged in directly to the switch
  • Network connectivity looks good. I can telnet roon server → ropieee port 9200. Ropieee doesn’t allow ssh, but I’m able to telnet from another ras pi on my network into the roon server on port 9200. Checked the managed switch, see no dropped packets for either device
  • The ropieee appears in the “About” section of roon but not in the audio section

Then you’ve no DAC (powered on!) running with your RPi…

Right! I forgot with me moving stuff around that it had to be connected to a DAC to appear. The ropieee is showing up now. Looks like my SoTM is the issue here. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.