Sotm SMS-200 Ultra not being discovered after 1.8 update to core and Android

Core Machine (Operating system/System info/Roon build number)

Roon Optimized core Kit running on NUC. Firmware 1.0 (build 227) stable/, version 1.8 (build 753) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sotm SMS 200 Ultra New firmware version 0.5.1 which is latest

Description Of Issue

SOTM SMS-200 Ultra NEO no longer discovered after the update to core and Android.

I ran into problems with the update. Android Samsung Galaxy, NUC running roon core. Update went smoothly in the core. Player works, but Sotm SMS-Ultra NEO not discovered and does not show up. No option to enable it either. It is on the network as I can access using the ip address.

I have tried updating the latest version fimware for the sotm ultra NEO. v0.5.1. Tried a reset by unplugging sotm ethernet cable, waiting for 15 minutes, reboot by plugging lan cable back. Arcam av40 is discoverable. It is the Sotm that has the problem.

What else should I try?

Several reboots, unplugging, etc were all tried.

Tried posting in roon community and my question got lost in the long discussion. Any help here would be appreciated. Anyone else got sotm to work with Roon 1.8?

Today I received my SOTM SMS-200 Ultra NEO and installed it. I’m using Roon 1.8 core on my windows 10 pc. I had to use the android Roon app on my phone to enable it in the Audio settings but after that it worked flawless.

Hi @Joop_Seters ,

Do you have a DAC connected to the SOtM?
Do other zones still show up as expected?

Thank you for your response. Yes, I have a Chord Hugo TT2. The actual chain is sms-ultra to tx-usb ultra to Chord mscaler to Chord TT2 dac. The only change that happened was the software update. To ensure nothing is wrong with the cables or connection, I unplugged the USB from SMS-200 ultra and plugged it into the NUC USB running roon directitly and Mscaler shows up in the audio devices flawlessly. The bug is with Sotm SMS-200 ultra NEO not being recognized as far as I can tell.

Yes, other zones like arcam show and play fine

Hi not sure whether this will help:

After 1.8 upgrade my SOtM SMS was not showing under zones

I went to the MyEunhasu page and restarted the Roon ready app. Then it was visible in Roon zones

You may want to try this

Yes I have a DAC connected and playing music. All other zones show up.

Hi @Jmcomp124

Does the device show up in Settings > Audio, even if it doesn’t show up in the Zone Picker? Or does it not show up in Roon at all?

If it’s not showing up even in Settings > Audio, can you elaborate on your networking setup? What router are you using? How are your devices connected?

Is there any difference in how the Sotm is connected compared to other devices?

Hi Dylan, Joop, DrPo and others for trying to help me. It appears that something is wrong with the USB Audio port on the Sotm SMS-Ultra Neo. Reason I think this is because the other USB port on the Sotm is working fine. May from Sotm also was very helpful. I am still not sure how the Roon 1.8 update could cause this. Puzzling as nothing else absolutely changed in the system. I am curious to know what happened and as soon as Sotm receives the unit and if they are able to confirm the root cause, I will let you know.

1 Like

Hi Jai,

Have you solved the problem of the SOtM SMS-200 Ultra not being discovered after 1.8 upgrade?
I have the same issue.
At first the SOtM was being discovered after 1.8 update but prompted message saying the SOtM is not being certified by ROON and asked to contact the manufacturer,
After tried to unplug the USB connection and switch LAN plug at LAN switch, reboot all the software and machines, the SOtM disappeared and can’t be discovered anymore.
Now I can only listen music by connecting DAC direct to NUC CORE via USB.
Appreciate if you can give some advice.


I have three SOtM sMS NEOs. When they work they are great. Unfortunately they have all kinds of problems with drivers and connectivity, especially if you have more than one.

Standalone they are tolerable, but multiple zones forget it.

I spend more time listening to my Sonos Connects, because they just work. Unfortunately they’re only CD quality but although they are 17 years old, roon finds them (4) in a split second and they just work all the time with issues.

I sincerely wish that Sonos made a Hi-Res model. I really do.

I would trade all three of my SOtM devices ($2100) in a heartbeat.

I have three with the same issues. I’m getting ready to sell or give mine away it’s so frustrating

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.