Soulution 330 integrated DAC card with Roon Nucleus

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Linksys wi-fi router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Solution 330 integrated amplifier with Internal DAC card

Description Of Issue
I have used my Roon Nucleus with a Brinkmann Nyquist, Aqua LaScala and other USB input DAC devices without issue. After recently downsizing and having the proprietary Soulution Audio DAC card installed, which is a simple 2.0 device, I run into constant issues getting an error message after about 45 minutes of play and the music just stops saying “Roon has lost control of the audio device“.

Once this occurs one time, I am usually able to start it up again and start another song which will play for approx 20-30 seconds, then stop again with same error message. It will get to a point after several attempts that the Nucleus will then not even recognize the Device at all and will not even show up as a zone to select.

I do realize that the Soulution is not recognized as a Roon partner on the list of compatible manufacturers, yet I am stumped as to why this works for a while and stops working . Any advice would sure be appreciated.

Hi @Greg_McLean,

Can you share a screenshot of Device Setup for this DAC?

Have you tried a different USB cable?

Is this only a problem when the device is connected to the Nucleus? If you connect it to a Windows machine and play back from Roon that way do you see the same error messages?

hi Dylan, thank you for your reply.

I took my Mac Pro-book laptop, which also has a number of music files on it and plugged it directly into the USB input on the back of the Soulution 330 DAC card on the back of the amplifier, totally by-passing the Roon Nucleus and garnered the same results. Although I did not get the specific " ( Roon has lost control of the audio device " ) message as I was not connected to Roon in any way using this method, the files would play in the same fashion directly from the laptop for a short time, then stop as before and again, the Mac would " lose site " of the device even being connected. I have also switched between 3 different USB cables to make sure I was ruling that out as well, yet still the same results.

At this stage, I am beginning to think there is something of issue with the card itself, or perhaps, a software download/re-load offered from Soulution Audio themselves should be my next course of action. When the card was originally installed by the distributor technician, there was a software download also installed as well. Perhaps a re-load might clear up the issue?

thanks, Greg

There definitely sounds like an issue with the either the 330, the card, or the software install. A re-load would make sense as the first step.

Hi @Greg_McLean,

Since this behavior occurs outside of Roon on a separate PC, I would reach out to the technician or to the manufacturer for additional assistance with this issue. The firmware may need to be re-flashed or it could be an issue with the hardware.

I have a 590 from Soulution and I can’t even get it to be seen by Linux (including ROCK and Nucleus), but it’s also really weird on my latest MacbookPro… Only works on one of the 4 usb ports! Never seen this behavior on any device before.

We are reaching out to Soulution to figure this out

Hi @Greg_McLean,

Have you managed to sort out your problem?

I also have a soulution 330 with dac and use a mac mini to send music to the soulution.
I was previously using macOS with Roon and HQPlayer and the DAC seemed to be recognised and working well with a direct USB connection (I’ll verify again if any disconnect happens with time, directly from roon) as I didn’t monitor that back then)

I have however switched to using Linux (audio linux) to connect to the soulution (from the same mac mini), and as I recently wanted to try DSD I switched from using the Matrix spdif 2 to access the soulution through xlr to using direct USB.

The roon + HQP combination won’t work at all, and I tried using roon to access the soulution directly.
While roon does detect the soulution as a zone (the soulution needs to be started after linux has booted), nothing plays (roon quickly goes through the play list with a lot of errors in the log)

I am going to investigate further the behaviour from a mac OS perspective (as it seems working on my machine) and am happy to share any information if it can help on what happens under linux although I understand audiolinux is not the same OS as on the nucleus

That is something you need to raise with the administrator of the OS. Obviously RoonOS will be dealt with here, but an AudioLinux query needs to looked at by them (him).

Fair enough.

I actually was not so much thinking about audiolinux rather than the fact (for the OP) that I remembered roon on my mac mini to work well directly with the soulution (which may have indirectly helped).

As it happens, I just re-did a quick test on my mac mini, and roon on OS X cannot play directly to the Soulution USB, so probably no help here for the OP.

Quick correction on the above statement:
I couldn’t play from roon directly (on OS X) to the Soulution 330 dac only because HQP had locked the use of the device.

After making sure HQP is not up, playing through USB on the soulution dac has been working seemlessly for the last 2 hours.

My mac mini (late 2012) is running on OS X 10.14.6.
@Greg_McLean, let me know if you want more info on what works.
I can try tom to run music using a different player to the Soulution. Which one were you using during your test with the mbp?

I also had Problems with my 330 Dac Card as i received the amp. Then i write to Soulution and they sended me a new software for the Dac Modul. After installing the update everything was fine. I use the 330 Dac with a roon Nucleus via USB. Maybe that helps.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.