Sound is sometimes "pumping" or "throbbing" when playing songs from Qobuz

Roon Core Machine

Running in a Docker container on Synology DS1618+ running DSM 7.1.1-42962 Update 1
8192 MB RAM

Networking Gear & Setup Details

No VPN, Unifi UDM-Pro Dreamstation router with U6-LR WiFi AP.
Core / Synology is on wired ethernet
App running on Mac over WiFi
Audio devices running on WiFi

Connected Audio Devices

Sonos Playbar and paired Play:3 speakers, grouped (though the issue happens when they are not grouped too)

Number of Tracks in Library

7116 tracks, though the issue was when playing tracks from Qobuz. I’m not sure if it happens with local content.

Description of Issue

When playing some songs today, it worked for a while, but when I jumped to a different album, the sound started throbbing across the different speakers - very quickly getting louder and softer, each speaker doing this at a different rate. As you can imagine, this happening across 5 speakers in 2 rooms is INCREDIBLY annoying. I tried again about an hour later and the problem was still happening so I would expect that if it was a caching issue, it would have resolved in this time.

The same thing happened a couple of days ago when I started playing some other content from Qobuz but it resolved itself in about 10 seconds. This time, it kept going longer, even after stopping and restarting the song (and even now, an hour later).

Signal path thing is showing green for all of the speakers while it is happening.

Any suggestions? This has happened a few times. Trying to figure out if it’s something I can fix while I’m still in the trial for a few more days.

Thanks,
-Chris

Welcome to the forum, @Chris_Evans1!

I haven’t seen anything like this using Sonos with or without Roon.It’s bizarre.

Was the signal path image you posted taken from a device that was exhibiting the thumping at the time the thumping was happening?

Does it happen when you play to a single device or only when you play to a group?

It’s possible one of these folks, who have previously commented on Sonos threads, has an idea of what might be going on. Any thoughts @Michael_Harris, @Johnny_Ooooops, @AMT, @kitated, @Simon_Arnold3?

Never heard of that. Crazy.

Also want to see your signal path. Would be great if you can go into the Sonos app as well and paste a screen capture of that as well, because I want to know if Sonos is doing the grouping or not. If Sonos is doing the grouping, then this I think has to be entirely on the Sonos side and little Roon can do. If Sonos is not doing the grouping (as I discovered it doesn’t if you have zones set as AirPlay instead of Sonos native streaming) I can imagine how zones might get out of sync and you’d get “beats”.

1 Like

Nope not heard anything like that sounds like a faulty unit to me.

This one sounds a bit crazy.
Just to do a check, if you play music for an extended time on Sonos app or something else like Tidal do you get a similar affect.

I cannot think of a reason why this would happen. You have plenty of resource available. Are you only playing to the soundbar on its own or have you linked devices in Sonos app.

I can only suggest trying to set the system to downsample to 16/44 in case 8t is struggling to get the data out.

1 Like

Try your current streaming service a different streaming service but through the Sonos app. Does it do it then?

If so, yes Sonos side of things. If no it’s a Roon to Sonos issue.

Try ungrouping your Sonos products and have them set as individual zones.

Report back.

As per others I’ve never heard of such a thing with Sonos. It almost sound like you were describing a speaker setup function such akin to Yamaha soundbar of yester-years.

1 Like

Yes, the signal path picture I posted when the issue was happening. It happened when I was just listening to one room, but each room has either 2 or 3 speakers that are grouped in Sonos.

As I mention in another response, there are two rooms of speakers I grouped in Roon were both grouped sets of Sonos speakers (2 Play:3s in one room and a SoundBar and 2 Play:1s in the other, each of those groupings were set up in Sonos. Roon is using Sonos streaming, not AirPlay2). I’ve had these Sonos speakers for a few years and never heard this happen before when streaming to them from the Sonos app (or Airplay)

I played the same album and song using the Sonos app and streaming from Qobuz and it played fine going to the same set of grouped speakers. The two sets of speakers I grouped in Roon were both sets of Sonos speakers (2 Play:3s in one room and a SoundBar and 2 Play:1s in the other). I did try it yesterday with just one room’s speakers and it kept happening. It does not happen when going straight through Sonos, only when playing from Roon (and, possibly, only when playing from Qobuz through the Roon)

Switching these speakers from 24 to 16 bit does seem to stop it from happening so thanks! In fact, putting both pairs of speakers as 24 bit will make this happen every time, and switching either to 16 (which I assume changes the stream for all of them to 16) makes it stop.

So I guess the lesson is that Sonos speakers don’t actually (reliably?) support 24bit – at least through Roon.

Glad to know this now!

Thanks,
-Chris

1 Like

Chris sorry I was on mobile when I responded so I could not make that out.
We have a couple of thread discussions where we talk about the fact that having 24/48 does not actually offer any improvement in audio quality and makes them less reliable.
Even though I can run 24/48 without issue I have set all of my Sonos devices to use 16/44.

Regards

Mike

1 Like

Mike- there’s no way to set it to 44 max is there? I have all mine set to maximum bit depth of 16, which has had the desired result. But I don’t know how to force 44 cap. I also think if the goal is to constrain bandwidth, the bit depth is the biggest factor. But just wondering if I’m missing a setting. Thanks.

Sorry Johnny I say 16/44 as that was the limit of the S1 Sonos (at least in my memory) so I might use that term from memory (as opposed to the 16 bit limit).
But that was the setting you are talking about and it seems that a number of us have done this to make things work more reliably and it has worked for a good few people.

2 Likes

Glad you got it working!

@Johnny_Ooooops figured this out - I wouldn’t have guessed that.

The newer ones support up to 24/48 but many people have difficulty getting it to work reliably. Your home network (vendor, topology, distribution of access points, configuration, signal strength), the Sonos equipment you have, how you’ve connected the Sonos devices (fully wireless, exactly one device connected, more than one device connected), how you’ve connected to Roon (SonosNet or AirPlay), whether you’re streaming to one or a group, and more all play a role.

If you want to get play around with your setup, you can explore different network strategies. But as long as you can get 16/44 working reliably, you’re getting CD-quality, lossless audio and it’s hard to imagine that you’d hear much of a difference between 16/44 and 24/48 on Sonos-made speakers.

I hope Sonos someday modernizes their architecture. We’re at a point in time where fierce competition - at least in part driven by Roon and their partner ecosystem - has created real competition. Maybe that’ll provide the impetus for Sonos to improve. I hope so.

1 Like

Thank you all for the replies. Glad the issue is resolved and we can get back to trying it out!

2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.