Sound problems using WASAPI and Exclusive Mode on intel nuc

Core Machine (Operating system/System info/Roon build number)

Core is on QNAP NAS

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Intel Nuc -> HDMI -> Onkyo AV Receiver TX-NR929

Description Of Issue

I have my Roon core on my QNAP NAS.
I have an Intel Nuc connected to my Onkyo AV receiver via HDMI.

If i configure my Nuc Intel® Display Audio WASAPI to Exclusive Mode, I only get sound when playing MQA files. The following screenshots show configuration that can play MQA, but not non-MQA files on Tidal.

if i use the above settings, I get no sound from non-MQA music.
For example, the following screenshot is playing a non-MQA title, and the signal path shows purple, the music bar is moving, but i get no sound at all.

I only get sound from playing non-MQA files if i turn off Exclusive Mode, following which, i get the following signal path (green light).

Any idea why turning on Exclusive Mode would allow sound to come from only MQA files?
If i turn off Exclusive Mode, I am able to get sound from both MQA and non-MQA files.


Try sending everything at 48k. That is the native rate of AV audio.


thanks for trying to help. i read somewhere that Intel Nuc doesnt support 24bit over HDMI. so i tried to reduce to 16bit. I also tried your suggestion of reducing to 48k.

the following is a screenshot of the settings:

if i play an MQA file, i get sound, but then signal path turns green (as expected) due to the downsampling, as follows:

but if i play a non MQA file, i still get no sound, but the signal path remains purple… as follows:

the moment i turn off Exclusive Mode, i get sound from BOTH mqa and non-mqa files, but the signal path turns green due to the last step of the path: it changes to OS mixer rather than WASAPI. also, contrary to a thread i read on intel forums, HDMI is able to play 24 bit through the nuc, as i have set at 192khz and 24 bit. The MQA file playback signal path shows MQA core decoding to 96Khz 24 bit and get sound from my speakers just fine.

following are screenshots of settings with exclusive mode off, and signal paths of MQA and non MQA files

The only thing I can see is that the stuff that works is in the 48k family, the stuff that doesn’t is in the 44k family. I’d get Roon to convert 44k content to 48k and see if you get sound. I’d also find and try a 44k MQA track. Sorry, these aren’t fixes but an attempt to narrow down the problem.



Henry, you are a godsend.
Did as u suggested and got Roon to resample to anything other than 44.1khz and now all music plays, with Exclusive Mode on and WASAPI.
Apologies, I misunderstood u earlier and thought it was the bit rate and not sample rate.

Thanks so much!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.