Specific Album Not Being Detected

Ubuntu 19.04/Roon 1.7 Build 528

I have one specific album (that i know of) that will not show up in Roon. I have deleted and re-added and rescanned the library. Its this weird generic christmas CD. Could it be because it can’t really find it on any of the scrapers? It was ripped with EAC and the artist name is just “Various Artists.” it does have a discogs but its listed under Unnamed artist there. Would retagging/renaming it help?

heres the album

Did EAC find a match when you ripped it, or did you have to manually tag it?
What does Roon throw up if you go to edit album/identify album?

Hi @donfrenchiano,

First, I’d like to point out some documentation we have that may be helpful here. In our KB we have an article about Skipped Files and an article about why some files might be missing from Roon .

If you go to Settings > Library > Skipped Files do you see any of your missing files there?

I’d like to recommend looking at a couple of specific examples of tracks that did not get imported into Roon. Are they supported files? Are they showing up in Skipped Files? If it looks like they should be importing, let me know! Screenshots of these files in their storage location would be helpful for discovering what may be happening.

I forgot to mention. No they don’t show in skipped files.

Ill have to dig out the album and see what EAC says. But there is no album to identify. if i delete and add it it doesn’t show in recently added or anything like that. Its like roon ignores it completely. Doesn’t even show in skipped files.

Does it show up in Roon if you focus on unidentified albums?

I would delete it from your Roon storage, rescan Roon, clean up your library, then add it back and rescan again. See whether that helps.

You can also try to do a FLAC-to-FLAC conversion using a different converter to your usual one.

Also I have found that folders which end with a space are missed out by Roon. Check the folder name to see whether you’ve not accidentally added a space, ie "Album name " rather than “Album name”. These do usually show up in the skipped files though.

Would depend on how it’s tagged/named now, but maybe.
Could you post a screenshot of the files in-situ on your storage?

What you describe occasionally happens to me. I don’t know if it is the same but I usually find one of two things and this may help you or others reading this.

a) Roon adds the disk to an existing box-set in your library.
b) Roon makes it a duplicate of an existing album in your library.

Either way, it looks as if it is not in your library, but it is, just hidden in your library in either of these ways.

What I do is, I remove the album, clean up library (important) and re-tag the album so that at least it shows up in “recently added”. Re-tag the album title (so it is not matching something else in your library so roon think it is a duplicate), the CD number (i.e. make sure it is 1/1 and not 3/10 etc. so roon doesn’t think it is part of a box set) and possibly the album artist (just to make absolutely sure). When it shows up in in “recently added” you can edit again if needs be.

how do i do that

I ended up figuring it out. It was named something completely different in the library. When i went to genre and then to the Holiday genre if i deleted it from the drive i could see it disappear and come back when i copied it back over. Not sure what info it uses to try and find a match scraping. The artist and album name are completely different but the track listing is the same.

Redundant now, but in case you need to in future…

Inspector (you may need to scroll to find this)

Check the box next to ‘Identified’… then click on +identified (at the top of the dialogue box) so that it changes to -identified

Any unidentified albums should now be shown.

As you will see there are lots of other options…

As an aside, I’ve had odd results (such as files being split between two albums) when copying new files into a watched folder. As a consequence I now disable the watched folder before copying files, and re-enable when the copy is complete.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.