Spectrum Internet WiFi 6 Router (SAX1V1K)

Reposted from “Getting Started thread” per @Rugby giving me the go-ahead; edited for the items Big Dan cleared up in his lengthy and gracious assistance session!

Port Forwarding Issues @mike @ivan @connor

  1. Tried UPnP and Manual, but can’t get either to set up correctly
  2. My Core is set up on a laptop, that connects to my network via wifi only (I have no ethernet port on the machine)
  3. I simply play my WIN10 desktop Roon library to my Sonos Arc “5.1.2” system and it works great. I have no other endpoints.

I filled out the requested port forwarding/auto-config. Google Form the other night, which will provide a bit more detail on my ARC/Core setup experience.

Roon ARC is on my iPhone, it works on my home network. I have a red banner in the app at the top that says, “Roon ARC won’t work outside your house until you finish setup/More info" (bold link)”, which does not link to anything or activate.

Pics of my core “Roon ARC” settings are provided, as well as one of my core build. I also will link some “vidyard recordings” post/screen videos of how the purple troubleshoot button and circular refresh button (in the app housing my core) don’t provide any diagnostic info in the prescribed field.

Thanks for your help on this most basic step, for this most basic annual user, who was going to drop Roon because of the lack of mobile capability.

I can’t wait to get this set up! Super psyched to be included in the test!

Vidyard Recording?
Vidyard Recording?

Not sure what you’ve tried so far, but have you checked that UPNP is enabled on your router? If it is, have you then tried to set up port forwarding on your router? If not, and you’re not sure how to do either of those steps, you’ll need to post some further info on your networking gear, particularly the make and model of your router.

THIS document is linked from the Roon ARC setting (in desktop WIN) troubleshoot purple tab. I tried Case #1, 2 and 3.

  • UPnP is enabled on router
  • Port forwarding is also set up (See the above document for the steps I took)
  • Router is an Askey SAX1V1K (Spectrum’s supplied, wifi6 router)
  • Link to it online is HERE

Thanks, @DaveN !

Having read through a bit of the manual for your router I went back and looked at your screen grabs - and noticed that the ROON CORE IP is missing. Did you set a fixed (or reserved) IP address for your core before setting up the port forwarding on your router? I’m assuming you probably did, and it shouldn’t make a difference between reboots, but it might be worth checking.

One other thing I noticed: are you running Tailscale VPN? I can’t quite make out the logo in your taskbar, but it looks like it might be Tailscale. If so, try turning it off. I use NordVPN every once in a while and I’ve found that ARC doesn’t work when I do, so maybe Tailscale (if you’re running it) is causing a similar problem.

And finally, it might be worth you posting a screen grab of the port forwarding rule you’ve set up on your router. From what you’ve said it sounds like you’ve probably done it correctly, but it might be worth checking.

I’m sceptical that any of the above will help, so I’ll carry on digging around, but I’m not sure I’ll come up with anything else. Hopefully support will have something useful to add after the weekend.

1 Like

No worries, @DaveN. I appreciate your time on this, for me!

No, I don’t know how to do this. Although I did set the 55000 port in the snip you can see, above or in my vids, in the Roon ARC setting that relates to port forwarding (is this what you mean)?

I’m not running any VPNs; not sure which logo you’re referring to?

Please see the pics below from the Spectrum mobile app on my phone (the only way Spectrum allows one to access a router UI, lol; they don’t allow access to a browser IP address version

The fixed or reserved IP probably isn’t crucial at this stage, but you can probably look up how to assign one.

Inbetween Roon and Sonos, but I’ve just realised it’s Tidal, not Tailscale. Tailscale looks similar …

Screenshot 2022-06-18 at 23.00.16

OK, so the only thing I can think to check is the IP address. Can you confirm that is the IP address of your core?

The only other suggestion, assuming you’ve tried rebooting everything (core, router etc) is that you turn off any firewalls on the router and your core.

And if none of that helps, I suspect I’m out of ideas.

Sorry you’re having some trouble here @Joshua_Nelson@connor will be able to help here as well, so fear not – we’ll figure this out. This is why we’re testing :pray:

One note:

This guide is actually a bit outdated. @michael @brian2 we should make sure we fix that link in Roon, it doesn’t seem to be using the redirector.

@Joshua_Nelson (and @DaveN) we’ve got WIP docs about port forwarding here. I don’t know if it will help with your current issue, but feedback about the docs is welcome!

Thanks and standby – @connor will be in touch first thing next week so we can get this working for you @Joshua_Nelson!

1 Like

Yep, that’s a useful document but it might need a section on how to troubleshoot when the Diagnostic data isn’t being displayed. When I set up ARC on my core the diagnostic data identified a double NAT, which I knew about, but hadn’t fixed because it wasn’t causing any issues. In Joshua’s case the data is missing so there’s not much to go on.

Great @mike, thanks so much. I’ll check the doc and if needed, look forward to hearing from @connor. Can’t wait!

@DaveN - thanks again for your most gracious time/effort in assistance!


Hey @connor looking forward to hearing from you! :grinning:

1 Like

Hi @Joshua_Nelson,

Thanks for your patience over the weekend! We’d be happy to help get this set up.

The first thing I can suggest is that you see if there’s a setting for TCP-only in the Spectrum app port forwarding setup.

I’ll pull logs from your Core in the meantime to see if I can trace down a network problem that might be preventing the diagnostic pull. Stand by and we’ll get this sorted out!

Hi @mike and @connor ,
I’ve read the doc and it is a clear step-by-step. One suggestion. It is not always possible to put the provider’s modem in bridge mode. You could add the alternatieve method to use a DMZ address instead and routing all traffic to that address.

No worries on reply duration @connor! Appreciate your time/assistance.

Changed protocol to TCP only.

  • Still getting the linked doc from the purple troubleshooting tab in my desktop/core “Roon ARC” setting. Also, the circular refresh button exhibits the same behavior in simply “blinking” and not filling in the diagnostic field with any data

Linking an iPhone screen recording of the app access I have to my router UI, with annotation of some points that may be important and save you some time in the debug.

Also, here is the router info from earlier in the thread, if posting it here may help save you some time, @connor

1 Like

I may have misinterpreted what you said in your video, but did you say you’ve set up the port forwarding for your iPhone? If so, this is incorrect. It’s the machine running your core that needs the port forwarding. Again, my apologies if I misheard, and normally I’d listen again to confirm, but I’m just heading out the door.

1 Like

@DaveN - good catch. Actually, I conflated the two (my iPhone and my Core) in the screen video of my last post. The port forwarding is set up in my router UI, which is only accessible in an app on my iPhone. So, the port forwarding is set up in my router; I believe that is the instruction set, correct?

1 Like

Yep. Set up on the router (via the app on your phone), to forward Port 55000 to your core.

Yep, that is what has been the case since you and I started the debug on Sunday. My apologies for stating otherwise in my last iPhone screen video - confusing the matter at hand. Great catch for clarification, @DaveN !

1 Like

Hey @Joshua_Nelson,

Looking back at this screenshot, I’m noticing that the IP address listed doesn’t appear to be for your Core device - it’s the IP matching your iPhone.

Try updating that IP address to match your Core device’s static IP. Outside of that, the port rule looks all set, although I’m finding some reports in the wild as I look into this that it can take up to a full day for Spectrum’s settings to update after making changes in the web app/router GUI. Hopefully we’ll get this sorted sooner than that.

Standing by when you’re able to double check the IP address.

Oh… @DaveN was actually correct, and I confused the matter at hand again. I did target my iPhone with the port forwarding, not my laptop (core). I’ve targeted the laptop/core. I don’t now how to check the IP of my laptop/core, but have linked a screen snip of the IP that is now targeted in the router UI.

Is the below correct? @connor

A screen vid of the new set up, targeted at my laptop/core is [HERE](Google Photos)

So far, this has not changed the “not ready” status or the behavior for the purple trouble-shoot tab, or the circular refresh buttons in the Roon ARC setting (laptop core application).

1 Like