Spontaneous restarts after few minutes of playback (after applying latest patches)

Roon Core Machine

Arch Linux (with all updates available on 2022-04-03
OS: Samsung SSD 970 EVO 250GB (NVMe)
Audio data: Samsung SSD 870 QVO 4TB
Roon Core 1.8 (build 923)

Networking Gear & Setup Details

Ubiquiti Unifi wired LAN

Connected Audio Devices

Naim NDX 2

Number of Tracks in Library


Description of Issue

First of all … issue is currently solved/worked around by a partial downgrade (of the linux kernel package), but I wanted to share my experience to avoid others from having the same issue (which is still really strange to me).

On 2022-04-03, I did an update to latest and greatest of my Arch Linux installation running on an Intel Nuc. I did not instantly listen to music afterwards, but when I started playback later, it stopped after a few minutes (somewhere in the middle of a track, either the first or second in the queue).

Initially I did not realize what’s going on, when I checked on my tablet, I saw that it took a bit to load, but that sometimes happens (as my library is pretty large). After this also happened after I restarted playback again, I started checking what’s happening/going wrong. I could see, that the computer restarted, but no hints about a crash or ordered reboot in any of the logs (neither RoonApplication nor system log - via journalctl).

The only remarkable thing were some strange entries related to ‘BERT: Error records from previous boot’, so I assumed that this might be related to a hardware issue (still strange as there is no direct playback on the NUC and the Roon service was running without any issues for hours, but the issue occurred so quickly after starting playback, that it seemed impossible to me that something else could cause the behavior).

I stopped investigation after a while, and before continuing, my attention was dragged to another computer of mine, which was having an issue with NFS - also on an Intel NUC (different model/generation) after applying the same updates as on my Roon Core.

After identifying that only those two boxes were affected, I found a thread about an NFS bug (related to QNAP), which made me wonder whether the latest kernel update might be the cause of my NFS issues (being unable to mount NFS4 shares from my QNAP boxes). I first gave it a try on my other computer (downgrading from 5.17.1.arch1-1 to 5.16.16.arch1-1), turned out that this really helped to overcome the NFS issue. Next I downgraded my Roon Core (from 5.17.1.arch1-1 to 5.16.8-arch1-1) which solved the NFS issue there two. I was already wondering whether the kernel update could have caused the weird behavior of Roon too, and it turned out that it was the case.

I’m afraid I cannot provide much more information as there were no information logged before the system restarted (just like pulling the plug in between), even my attempts to monitor this reboots did not show anything remarkable (eg. increase in memory or CPU load).

Regarding the link which helped my finding the workaround … NFS4 (client share to one of my QNAPs) is configured on my Roon Core, but only as a mounted directory for backups (not for playback at all). The corresponding thread can be found at [BUG] NFS stoped working after update / Newbie Corner / Arch Linux Forums

Overall it’s hard to assume that there might have been something different causing the spontaneous restarts than Roon playback and the latest kernel update. In case of any questions, please let me know (I’ll try my best to answer them). If you like I can keep you informed, my plan is to wait for the next kernel update and check, whether the NFS bug is fixed there, in case it is, I will try the same on my Roon Core (crossing fingers, that the restarts won’t occur aftherwards again)

Thanks & regards,


@Markus_Rachbauer, hopefully you can get your Core running again how you like it.

Any reason you picked Arch to install the core on?

Seems like a rolling release distro would be a massive headache to maintain for an application like Roon.

Hi Andy,

thanks for your reply. The reason for me to use Arch was because it is a rollilng release distro (and I’m using it on all my other computers). I’m aware that this might cause issues sometimes (but after +20 years of Linux experience I’m usally able to get around most issues - actually this is only the second time having issues with Roon on Arch Linux).
Anyway … the issue is solved for now (by downgrading the linux kernel package), I just wanted to let you/community know (as it might be hard to identify the real cause and how to work around)



1 Like

Glad you got it sorted matey.

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.