Sporadic extremely high CPU usage by Roon and RAATServer

Core Machine (Operating system/System info/Roon build number)

Roon Core is running on a 3 GHz 6-core i5 iMac with 32 GB RAM, Catalina 10.15.3. Roon v 1.7 (build 511).

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

1Gbps Verizon FiOS optical gateway --> Cat8 Ethernet cable --> Plume.com Superpod router --> Cat 8 cable --> TP-link TL-SG105 switch --> Cat 8 cable --> iMac

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

The problem occurs even when I use the iMac’s “System Output” audio.

Description Of Issue

Most of the time the Roon as well as the RAATServer processes use only a very small amount of the iMac’s CPU (typically ~ 3% for Roon). However, occasionally, for no discernible reasons, the CPU usage spikes to a very high number - e.g., 260%, where it stays. Roon does not appear to be doing anything extraordinary. E.g., there are no indications that it’s doing anything with the database, or such. Simply closing and restarting Roon does not fix the issue, but rebooting the iMac and then restarting Roon fixes, it.

I have attached screen shots of Activity Monitor showing the problem below:

Roon logs: https://www.dropbox.com/s/dwabhxcrrr8ay2g/VladS%20Roon%20Logs%20CPU.zip?dl=0

RAATServer logs: https://www.dropbox.com/s/kugasrt0gsuukno/VladS%20RAATServer%20Logs%20CPU.zip?dl=0

I noticed the problem when “Petits Machins” - a 88.2 kHz 24 bit track from Qobuz - was playing (CPU = 262%). After the system reboot, the same track plays back with a Roon CPU load of ~ 14%.

(Signal Path: System Output, Processing speed: 46.6x, Qobuz FLAC 88.2kHz 24bit 2 ch --> 24bit to 64bit Float --> 88.2kHz to 96 kHz --> 64bit Float to 24bit --> This Mac RAAT --> System Output, OS Mixer).

Thank you very much in advance.


I have the same problem with my 16 inch MacBook Pro (MacOS Catalina 10.15.3).
In my case, I use MacBook as a Roon remote. But the cpu usage always spikes up more than 30% if Roon is running. I play flac or dsf files stored in sinology NAS. Roon version is 1.7 (build 511).

I’m having the same issue. After a couple days post-install as core on osx 10.15.2, Roon pegs 3 cores (300% use reflected in Activity monitor) and RAATServer claims another core (99% use). My build is the same as above, 1.7 x511 stable. This is one of the reasons I ditched a competitor whose name sounds like nirvana. I have no extensions or displays set, and the processor use is immediate + constant, as long as Roon is running

Hi @noris, wondering if Roon QA / eng. is making progress on understanding this issue. Thanks.

Hi @VladS/@Joe_Franco ,

Thank you for your report. We’re still looking into this behavior at this time.

We have made some progress here and have identified an interesting data point - other users who reported this behavior mentioned that turning the WiFi/Ethernet adapter temporarily resolves it.

Can you please check to see if this is the same in your case as well?

Hi Noris, would you be so kind as to clarify, pls.: what do you mean by “turning the WiFi/Ethernet adapter”? I run my Roon Core iMac with its Wifi turned off permanently, and use wired Ethernet to connect it to the switch.

Hi @VladS,

This guide should help clarify:

Does turning off/on the adapter temporarily resolve this behavior?

Thanks, that’s helpful. I’ll try this next time the CPU spikes. (I rebooted earlier today so all’s temporarily OK).

1 Like

Hi @noris, just tried this, and unfortunately it did not help:

Roon CPU has been at ~ 10% or so over the past day of playback to System Output, but a few minutes ago I noticed it went up to 286% and stayed there (RAATServer is at 96%).

With Roon active but paused, I toggled the Ethernet Service off and on ("Make Service Inactive/Active), but the CPU stays high throughout.

I closed Roon and toggled the service again, but when I relaunched Roon its CPU is still high.

So it looks like only rebooting fixes this.


@VladS if it happens again, try turning wifi on instead of toggling ethernet off and on. I have a 2018 Mini that I normally keep the wifi turned off on, too. When I had a CPU spike with RoonBridge and RAATServer a few days ago, I tried turning wifi on and after a few seconds the CPU usage went back to normal. I turned it back off after a little while, and so far it’s still been normal.


Wow - that worked! Thank you. I will keep wifi on, and see if that cures the problem permanently.

@noris, the icing on the cake would be for Roon to explain why this is happening, and fix it :slight_smile:

1 Like

Hi @VladS,

That is a very interesting data point, thank you @jcharr1 for suggesting it! So it does look like the WiFi adapter plays a part in this issue (even if it’s not in use), and I have noted this in the investigation ticket.
@VladS - I have also followed-up via private message if you would like to help us troubleshoot this further, just let me know there is you would be willing!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.