Spotty Connection to roon server and and airplay and sonos devices

Core Machine (Operating system/System info/Roon build number)

Roon Server running on MAC OSX 10.13.6, Mac mini (Mid 2010) 2.4 GHz Intel Core 2 Duo 8 GB 1067 MHz DDR3. This is a headless server. I remote desktop into it

Roon build 1.6 build 401

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

google mesh wifi 11021.84.4

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)

3 Sonos Speakers
2 apple TVs via airplay

Description Of Issue

The connection from iPhone and iPad roon apps is spotty. often wait for minutes for a connection to establish. Once a connection to the server does happen it is very common for no audio devices to be present. The only method that seems to help is to remote into the headless server. once I see the desk top, the ipad/iphone connect fine and all audio devices are available

Sounds like your Server is applying power saving mechanisms of some sorts (either on the system in general or the network specifically). You should check the OS configurations in these areas.

1 Like

Hi @Kristian_Desch,

Do you by any chance have an active firewall or antivirus application blocking Roon on that Mac? In addition to @Blackjack’s suggestion of checking the power saving settings, I would also check to make sure that both Roon and RAATServer are listed as exceptions to your OSX firewall by using these instructions.

Also, how is the Core connected to the network, via WiFi or Ethernet?
Is the behavior the same if you connect it over Ethernet?



  1. I am not running the MAC firewall. But I will check the provided instructions
  2. I am running Sophos AV. Do I have to disable it or uninstall it?
  3. I have the MAC Roon Server connected via ethernet and wifi. I’ll try only using Ethernet by turning off wifi on the box. If I remember correctly, I see the same behavior regardless of what combination of network adapters I have turned on (eth only, wifi only, or both)

I’ll try tonight when I get home from work and report back.

Hi @Kristan_Desch,

For your point #2, I would try to temporarily disable the AV to see if that has any change. As for the rest of the tests, do let me know how it goes.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.